Tuya local

Thanks. We’ll see how it goes. I think I’ll make a backup for when I screw it up somehow.

1 Like

someone knows Tuya Local supports LED Controller like this one?

How? Can you link to a video or something.

Its taken me a full day to work out how to get the device ID’s to use localtuya and by the end of it still doesn’t work. So a recent guide to this would be great. I have tried doing OTA before and it hasnt worked.

I gotta say as a beginner these instructions are all over the place. After watching many youtube videos I eventually found a non english speaking guy who was able to show what the process was. Incredibly frustrating.

Once I got it all done, it doesnt work as intended anyway. Only 1 of the 5 devices was auto discovered and trying to get them to work was a nightmare. I gave up.

Good luck everyone else

2 Likes

Hi Tre,

I had the same kind of problems and took the easy way…
The hardest part is the device-id’s and device-keys, indeed, it’s all over the place.
I Installed Homebridge (docker) and because I had all the device ID’s and keys etc) it
was as simple as to load a plugin (homebridge-tuya v1.2.0, with regular updates), modify the the config a bit and go!
Then back to homeassistant and a new integration is ready to be activated.
Choose the homebridge controller and all the Tuya devices nicely show up.
I didn’t give up and you shouldn’t too!
Regards,

Nongsung

No the hardest part is trying to decipher what people are suggesting as if we all have the same level of understanding.

It’s no wonder the cloud based plug and play businesses are making a killing with shitty products

2 Likes

I posted this a while back before tuya grab was created.

So below the line is my previous advice prior to tuya grab
Now do this…

follow these instructions. To setup the iot. Tuya bit. Then run tuya grab instead of the command line bits

Tuya grab to do the command line bit


… _________…
I was having trouble getting local keys for a while.

This is what I ended up doing on Windows pc.

First download + install node.js

Then you can follow these instructions.

Which basically involves setting up a project in iota.tuya.com

You setup a project, link your tuya account, and set the 3 required api bits needed from the setup link.

Then run these two commands in Windows command terminal window in administrator mode

npm i @tuyapi/cli -g

tuya-cli wizard

The first 10 mins of this youtube helps with iota and commands bit

You need to run the commands from the installation directory…

So likely…

C:/username/roaming or similar

Username being your local computer name.

Fyi
‘Tuya custom’ integration seems better for rgb lights if you want a color wheel

Hi HasQT,

I got the ID codes, took me 6 hours on the weekend but I got there in the end and yes that pathetically instructed nodejs crap was one of the biggest issues. No noobie is going to get that. They go into so much detail with other sections but the one section that diverts to a completely new process the instructions become extremely ambiguous. If anyone in the future has problems with this message me and Ill help out here however in 2 months time this will probably be obsolete anyway.

I literally followed @nongsung directions to the letter but only one device is showing up in HA.

I have 2 devices but only one is showing which is the office fan

Wondering if my config is wrong or something else

Hi,

I had the same problem and here’s. part of my config:
{
“name”: “Corridor”,
“type”: “RGBTWLight”,
“manufacturer”: “Unknown”,
“model”: “Smart Wifi Bulb”,
“id”: “blablabla”,
“key”: “blablabla”,
“ip”: “192.168.1.28”
},
{
“name”: “Stairway Up1”,
“type”: “RGBTWLight”,
“dpPower”: “20”,
“dpMode”: “21”,
“dpBrightness”: “22”,
“dpColorTemperature”: “23”,
“dpColor”: “24”,
“maxWhiteColor”: “221”,
“colorFunction”: “HSB”,
“minBrightness”: 10,
“scaleBrightness”: 1000,
“scaleWhiteColor”: 1000,
“manufacturer”: “Unknown”,
“model”: “Smart Wifi Bulb”,
“id”: “blablabla”,
“key”: “blablabla”
},

As you can see, both Tuya but different brand or type.
You can play around with the non-working entities till you get results,
I’m hopeful that you are almost there.

Give it a try.

Succes,

NongSung

One more thing: I don’t know how a dimmer should be coded but the logs might tell you what’s wrong. Otherwise I would contact the author of the plugin, he usually answers within 48 hours.
Or check https://github.com/iRayanKhan/homebridge-tuya/issues maybe a similar problem was fixed in a certain way

How did you get the codes. I get to the entry point Provide a ‘virtual ID’ of a device currently registered in the app: xxxxxxxxx
After typing enter after a while cmd will crash in win10

If you are talking about virtual ID in npm then it is this ID

The number that appears underneath the item

I know yes, but if I enter it in cmd it waits for a while and then the cmd table closes

Resolved. I didn’t have items enabled in API Groups. :sob:

I have tuyalocal working in home assistant and am attempting to migrate my devices to a separate VLAN with no 'net access. I have moved one tuya device to this different VLAN and can control it with the Tuya app. (as long as the Tuya app is on the same SSID). I was able add the device on the different VLAN to the tuyalocal integration (using the integration, no YAML entries). However when I add the device on the different VLAN (different subnet), the device does not respond. I can ping the Tuya device on the different VLAN from the HA network.

As an added note I have NOT blocked 'net access (yet!) on this different VLAN.

Any suggestions?

Hello Community! May I ask you about tis device.

When I tried to set it in TyuaLocal - it offered me good choice of options to select

Most likely someone has similar motor.

So what values should be filled in against every line when setting device first time? Thanks a mill!

Hey mate, I finally got there. Got all the devices into HA.

However I cant work out how to code a 2/3/4 gang switch. Do you have any of those and show me a sample of the code?

Not sure if you already got this to work, but you can add the below to your configuration after connecting the controller to your wifi network through Magic Hue or Magic Home apps:

light:
  - platform: flux_led
    devices:
       # IP address of your LED controller
      192.168.XX.XXX:
        name: staircase
        # Type of you LED controller
        mode: "rgbw"

I wish I had the correct answer too, I am trying to do exactly what you are doing.

I managed to add the device and get it working with these settings.

I have a Scene which closes the blind and works fine but the Schene I did which is the exact opposite of the close Scene does not work

I wish there was some documentation on what these values mead, what are the values in brackets for example?

1 Like

For those, who understand german can here find a solution how to get the local key with postman: https://youtu.be/dBtrsXZOk8M

Any luck here? I’ve the same but for so far no luck