Tuya RGB Bulbs no longer recognized as color

I have a pair of Tuya RGB Wifi bulbs. On Tuesday they where working perfectly. Wednesday morning they suddenly where appearing as White only dimmable bulbs! All RGB functionality is completely gone in Home Assistant. I changed nothing in HA Tuesday or Wednesday.

In the Tuya app they still work perfectly fine as RGB. I can control them no problems. But in Home Assistant all options for color are gone, as are the color options presented to Alexa and Google Home via Nabu Casa.

So far I have tried removing the Tuya integration in HA, deleting the entities, rebooting HA and then re-adding them and restarting again, no dice. I also tried removing them from my Tuya account and setting them up all over again in HA, no luck yet again.

Anyone have any ideas what I can do to get them working right again?

you arent the only one. being discussed here:


and it also looks like its been an issue for some people since November…

mine stopped working yesterday

The fix i used worked for me

Integration ha_tuya_custom on HACS


Appears to fix the recent problems - github page has instructions to follow.