Unable to access HAS Locally since setting up Duck DNS

Hi (Again)

I seemed to have locked myself out of the Home Assistant page since trying to set up Duck DNS.

I followed the following video to help me with setting up the DNS;
https://www.juanmtech.com/hassio-duckdns-add-on-set-up/
and got as far as 3:43. Once I went to go back into Home Assistant, I was presented with this page;

So Port forwarding was set up from 443 to 8123 and Duck DNS was started with no issues present.

I have tried removing the port forwarding rules on the router but to no avail.

I’ve clearly messed something up in the Home Assistant setup, but not sure what to do now I cant get back into it.

Any Ideas how I can regain access?
Note: I can get into Hassio locally from the Raspberry Pi, but am not familiar with the commands required for this.

Many thanks

I also have port 8123 forwarded to port 8123 on my router as my instance would not connect without it,
are you trying to login using:
https://your.duckdns.org/8123

According to that screenshot you’re trying to access it via your ip address still, you should be using your duckdns address.

Or
You could use nginx and access it both locally and remotely (just incase your Internet ever goes down - apocalypse’s can happen, and we are due one pretty soon :rofl:)

Hi, Thanks for the responses. Hopefully there will be no apocalypse anytime soon! Well not before I get this working anyway :slight_smile:

So, I have tried accessing via the mydomain.duckdns.org site, but no joy there either. I just get the same ‘Refused connection’ page.

As I say, I was only part of the way through the set up, so never added the duckdns URL or SSL information to the cofiguration.Yaml file. So this could be the reason I can’t get access via the duckdns page?

Is it possible to ‘Stop’ the DuckDNS in Add Ons from the Hassio page locally on the Pi? Maybe if I could do that it would revert to a position where I can access it locally and start the set up again?

Thanks again for your suggestions

If that’s the case, then there is nothing using the DuckDNS or SSL.

Based on what you have already stated, this add-on isn’t actually doing anything, so it’s not your problem.

Hi Flamingm0e,

The problem I have is that nothing else has changed. So, not sure where else to look or what to try?

One minute I was accessing the Pi Locally whilst doing the DNS Setup. Then Following changing the Port forwarding to 8123 and restarting the router, the access was lost.

Read the log file. It will tell you WHY it is failing to start.

hold on, why would you restart your router? If you didn’t have a DHCP reservation in place for your Home Assistant server, it probably got a new IP address.

I restarted the Router because it says to do so on the You Tube video I followed. It says to restart once you setup the Port forwarding.

The local IP of the Pi has not changed. I have made this static and checked it on my network. Its connected with the same IP as it was.

Regards to the Log file, do you mean the log file in Hassio?
Apologies if I’m sounding stupid here, but I’m new to this stuff so everyday is a school day for me.

Thanks again

I question the knowledge of any individual that says you have to restart a router after creating a port forward.

Yes. Open the file and read it to see if it tells you WHY it’s not running.

I assume the reason for rebooting the router is to ensure the settings have registered? They are saved anyway?

But that aside, the only log I have access to is the boot log of the Pi when connecting the Pi to a monitor via HDMI. Watching this as it boots, there doesn’t appear to be any errors and Hassio seems to start.

As I can’t access the Home Assistant page, I can’t see the Log File for the DuckDNS, or any log file in Home assistant??

When you create a port forward it is saved. Rebooting the router doesn’t make it save any more.

No, you have access to the log file OF HOME ASSISTANT as well.

Sure you can. The Home Assistant log is just a file on the filesystem. You did set up samba or SSH right? If not, you will need to use a keyboard attached along with the monitor to access the file.

I had tried setting up Samba (Its running as an Add on in Home Assistant). But when I look at the drives in the Network all I have is two drives

I assume that the Logs are in the F:\ but can’t access this as its in Linux format?

So, I have a keyboard / mouse set up to the Pi, so just need to know what command to enter to get the log

Again, apologies for my lack of knowledge here

This isn’t a screenshot of a network drive. This is inserted into your PC, which Windows cannot read Linux partitions.

These drives aren’t inserted into the pc. Although I know what you mean by the fact they are not under the Network. But, they relate to the SD card which is the in the Raspberry pi.

I have tried accessing via the Putty app I have, but to no avail??

I’m beginning to think it might be worth reformatting the SD card and starting again, which would be a shame as I had it all setup fine with Home Assistant and various tasmotised devices.

No, moe means that they don’t appear as a network share eg //192.168.0.200/config is typical
Did you map these drives ?
I didn’t think Windows would mount a file system it couldn’t read ???

Then how is it showing the BOOT device of the pi as a drive letter? That doesn’t happen on its own.

Your screenshot plainly shows that you have a REMOVABLE drive inserted (SDCard), and is not being accessed over the network.

Did you set up SSH before you broke everything?

Look, you have a couple of options. You can hunt down the configuration directory (not sure where it’s located exactly on HassOS), read your log file, and fix the configuration issue.
OR
You can insert your SDCard into a Linux machine (or get an app that can read Linux partitions in Windows) and fix or save your configuration and reload if you want to.

But given that adding DuckDNS to your system was a major change then you must have taken a backup, so just restore from that and use a different guide to do duckdns.

Guys, Thanks for the earlier responses. Just to let you know I ended up re-flashing the SD card for the Pi and starting again. This got everything back to where I was.

I have similar problem, but then I’m using https:// before typing my ip address, then i can use my ip to access homeassistant again.

2 Likes