Unable to connect on New HomeAssistant Blue

I’m a newbie and excited to take par on Home assistant journey …i ordered HA Blue in March and got it delivered today …
Was all excited and hooked up HA Blue to to ethernet and power cable … and then went to browser of my pc and tried http://homeassistant.local:8123
to my surprise it said page can’t be reached.

i tried https and then did some circus to get a monitor, keyboard connected to the HA Blue and saw the login screen.
Then i entered root and via net info got the ipv4 address. (i verified the same address on my verizon router page)

i tried connecting via ipv4 address but still i get site cannot be reached

i’m pretty disappointed and waited 4 months for blue …

Any leads on how to fix it.

Note: when in the HA blue connected to monitor / keyboard when i do HA Core check … it says command executed successfully
when i tried HA core restart it says unknown error check supervisor

Have you tried connecting to the HA IP address explicitly with your PC browser?

For example:

Yes… My HA blue IP Address is

i tried … still no luck … i get the same error ‘this site can’t be reached’

Any advice on how to fix it

My HA is RPi based, so I’m afraid I wouldn’t know where to start. You could have a look at the HA docs on Odroid perhaps?

thank you …
i’m at my wits end … Can someone else please assist

Someone else found the HA head office helpful.

From the supervisor terminal run: ha os update --version 5.10
If you have tried that, you should refresh using this guide https://www.home-assistant.io/hassio/flashing_n2_otg/

when i type ha os update
i get error that Version 6.1 is already installed

My bad luck stream continues …
when i tried to flash it … i get error message that Failed to launch Petitboot
so i can’t proceed with flashing again

i can reach supervisor observer … just not HA…

After Su Repair … this is the new logs