"Unable to Connect to Frigate" when installing Frigate Integration

I get the same error when trying to add the integration after installing via HACS and restarting.

I can’t figure out what is wrong, and am starting to think it’s not me.

Are you running Frigate in a supervised version of HA or separately in a docker container? If the latter you have the wrong URL

I think I am in supervised version. I had the frigate integration working before upgrades to both HA and Frigate.

Resolved. Reloaded

Would you mind sharing how you resolved it? Reload what? HomeAssistant?. Did not work out for me. Same “Failed to connect” redish message.

Install frigate NVR and not Frigate NVR (full access). Restart Frigate and then all works

I had the same “Failed to Connect” problem and switching from "Frigate NVR (full access) to “Frigate NVR” fixed the issue. I’m running Home Assistant Supervised on a Pi 4 with Pi operating system.

Someone found any solution for this issue?

I facing same issue here

Solved. Each host-name is diferent. Each one has to use his/her own hostname. Host-name can be finded on configuration > supervisor > FrigateNVR, just above of “CPU usage”.
Then you have to chage the “http://ccab4aaf-frigate:5000/” for “http://YOUR-HOST-NAME:5000/” and it’s done.

Good luck everybody

2 Likes

worked, thanks!

I had the same problem.

SOLVED by removing “Frigate NVR (full access)” and then installing “Frigate NVR”

Have the same issue and I am kinda puzzled here.
I don’t have the menu point “configuration” in the menu of HA like @jordi.palomares.f implied. I have the supervisor in the “Devices & Services” menu but no such entry as host-name.
How Can I switch from “Frigate NVR (full access)” and then installing “Frigate NVR” like @jeffconnor proposed? I installed “Frigate” over HACS. There is not even an option with NVR there.

“Frigate NVR” and “Frigate NVR (Full Access)” is in the add-on store, not HACS (these are different things).

Hi,

I joined this topic because i have the same problem, used to have my frigate ( another machine in docker ) in my HAOS ( rasbpi ) but don’t want connect anymore

my rasbpi is 192.168.0.10 and my host with docker is 192.168.0.6
frigate proxy configured with 192.168.0.6:5000 is working well

but the frigate integration refuse to connect :

http://192.168.0.6:5000/api/stats: 500, message=‘INTERNAL SERVER ERROR’, url=URL(‘http://192.168.0.6:5000/api/stats’)

Is there a way to tell frigate bottle detections?!

I have a coral on it…