Unable to connect to Home Assistant from local network after installing DuckDns add-on

Thanks for the reply! I will take a look at the video. I have been trying lost os things because the strangest thing is that everything happened overnight. I have been running HA for years without this problem and didn’t change anything recently. I don’t know if ISP can change that without notification.

Yesterday, all of a sudden i also have this issue.
i haven’t done anything with my configuration in weeks and it has worked, but last night i couldnt access home assistant.
https://xxxxxx.duckdns.org:8123 does not work
connecting thru iPad or/and iPhone app does not work
it doesn’t matter if i am on my wifi or on external network, connection does not work.

connecting thru https://192.x.x.x:8123 does not work either…
connecting thru https://homeassistant.local:8123/ works

From what i can see when i manage to connect thru https://homeassistant.local:8123/ is that the https:// is in strikethru in chrome, do not know if that is something relevant tho.

Have anyone of you managed to solve this? as i said above, this just happened, all of a sudden.

hit this same issue today. SSL working for months. After a hard reboot of the Pi i couldnt get the Hass gui, but services were running (Samba, dhcp).

https://xxxx.duckdns.org —no result
https//192.xxxx:8123 — no result

Outside access is broken also.

only url loading is with https://homeassistant.local:8123 . I get the cert error but thats ok, i get a login screen and can get in. I reloaded nginx and duck addins, nothing weird in the logs.

I got the same thing after the last update, I can access locally but not through duckdns.

Tried everything but it doesn’t want to work. It killed my alexa as well.

In the log of NGINX:
2021/07/10 12:14:40 [error] 219#219: *27 upstream prematurely closed connection while reading response header from upstream,

I’m having this same issue. Nothing changed, but now external access from *.duckdns.org gives me “can’t connect to home assistant”. Local IP address does work. Nothing in the logs. Curious if anyone has figured out what’s going on

Have you updated your installation to 2021.7.x?

Yeah, I just did. It wasn’t working, so I updated to 2021.7.4 and still not working.

Have you read the breaking changes for using a reverse proxy?

If you are using a reverse proxy, please make sure you have configureduse_x_forwarded_for and trusted_proxies in your HTTP integration configuration.

I saw it but didn’t read it. But I guess this must be it. I don’t think of myself as using a reverse proxy? But maybe I’m wrong?

Any suggestions for what IP addresses and subnets I’m whitelisting? Do I now need to keep a whitelist of any IP my phone has??? I feel like I’m missing something here…

“This is required when using use_x_forwarded_for because all requests to Home Assistant, regardless of source, will arrive from the reverse proxy IP address. Therefore in a reverse proxy scenario, this option should be set with extreme care. If the immediate upstream proxy is not in the list, the request will be rejected. If any other intermediate proxy is not in the list, the first untrusted proxy will be considered the client.”