Unable to connect to Home Assistant from outside after update

I made the update to v0.87.1.
When I now try to reach my HA from outside, I get the message Unable to connect to Home Assistant.
The link in the browser changes automatically to .../lovelace and show the error message
When I explicitly enter .../states, I can see my HA.
I haven’t found a hint in my nginx log.

Nobody an idea what went wrong?
Do I need special a configuration for lovelace in my nginx reverse proxy?
Why is lovelace now the default?


Because it is better than the old way.

What you need to do is read the breaking changes for 0.87 and figure out if it applies to you.

Lovelace: I agree :grinning:

But after upgrading to 0.89.1 I can’t reach my system from outside, even not with the /states.

Nobody an idea, where I could look to locate the problem?

I’m using nginx as reverse proxy.
I can ping my system from outside using ip address or hostname.
The Let’s Encrypt certificate is valid.
The login screen opens, but when I log in, I end with

Error while loading this panel.
Go Back

When I than do a refresh, I see an error in the nginx-error-log:

2019/03/08 10:24:55 [error] 1932#1932: *2 connect() failed (111: Connection refused) while connecting to upstream, client:, server: xxx.myfritz.net, request: “GET /auth/authorize?response_type=code&client_id=https%3A%2F%2Fxxx.myfritz.net%2F&redirect_uri=https%3A%2F%2Fxxx.myfritz.net%2F%3Fauth_callback%3D1&state=eyJoYXNzVXJsIjffgdgHR0cHM6Ly9pZXA1a2NuYTkxZDh6Z2M0Lm15ZnJpdHoubmV0IiwiY2xpZW50SWQiOiJdgdRwczovL2llcDVrY25hOTFkOHpnYzQubXlmcml0ei5uZXQvIn0%3D HTTP/1.1”, upstream: “http://[::1]:8123/auth/authorize?response_type=code&client_id=https%3A%2F%2Fxxx.myfritz.net%2F&redirect_uri=https%3A%2F%2Fxxx.myfritz.net%2F%3Fauth_callback%3D1&state=eyJoYXNzVXJsIjoiaHR0cdgdg6Ly9pZXA1a2NuYTkxZDh6Z2M0Lm15ZnJpdHoubmV0IiwiY2xpZW50SWQiOiJodgdgvL2llcDVrY25hOTFkOHpnYzQubXlmcml0ei5uZXQvIn0%3D”, host: “xxx.myfritz.net”, referrer: “https://xxx.myfritz.net/

Without more information it is impossible to help you.

You presented this as a potential problem with Lovelace and NGINX, and I can assure you it is not.

Now you have upgraded again and lost access entirely. Perhaps share some of your layout/config and we can lend a hand. Are you trying to use api password?

Not sure if this is related but you do show authorisation issues in the log. This is an extract from the 0.89 notes. It’s the only thing I see related to authorisation in the release notes.

  • Addition of config for trusted networks auth provider. It is a breaking changes for users who manually configured trusted network auth provider. An invalid config error will be thrown and HA won’t be able to fully started. (It is NOT a breaking changes for user who didn’t manual configured trusted network auth provider.) (@awarecan- #21111) (breaking change)

To be honest: I assume, that I haven’t used that. Assume, because I could not match that description to anything I have configured. All with security I did, is using a certificate…

I just described what I did before the error occurred. My assumption was something with a bad configured reverse proxy. But I forgot to mention, that I did a OS update, too.

Yes, I have configured API password. Used the UID/pwd login, but the behavior is the same when trying to login with API password.

disabled ssh, just with OpenSSH Public Key and changed the port (see here)

Updates nginx to v1.14.2-1, configured as reverse proxy (see here)

I have HA running on a ubuntu system. I did the Manual installation as described here. What I did is described here.

I was pretty sure they removed that capability in 88

Maybe, but the behavior occurs with UID/passwd. I used the API password just to check, if this works.

But found this entry in the log

https://xxxmyfritz.net/frontend_latest/401352253e833b70a294.chunk.js:1:0 SyntaxError: expected expression, got ‘<’

What I am suggesting is remove API password from your config and restart HA.

Same behavior

and your NGINX reverse proxy is configured per the documentation?

Found a problem in the nginx configuration:

if ( $http_referer ~* (babes|forsale|girl|jewelry|love|nudit|organic|poker|porn|sex|teen) ) {
    return 403;

But I still do have problems.
@flamingm0e: Which documentation are you referring? I know this old one and that one (in German for SmarthomeNG).

The NGINX documentation?

Restored a backup and did the updates (HA, OS, certbot) again.
But the solution was fairly simple: Clear Browser Caches :grinning:

I was experiencing the same problem with using a netscaler. I solved it by enabeling websockets in a http profile and binding it to the load balanced virtual server. You can read my post on how to get it working with netscaler:


I think it can be solved with nginx or apache in a similar way.