Unable to connect to MQTT Server - Fresh Installation of Sonoff E Dongle and zigbee2matt

Hi Everyone,
I am new to HA and recently got a SONOFF Zigbee 3.0 USB Dongle Plus (E). I was trying to configure zigbee2mqtt today, but have failed to connect to MQTT Server.

My HA is installed on Oracle VM Virtual Box and i added the Zigbee Dongle in USB Device Filter.

I followed this video to configure the Zigbee Dongle and zigbee2mqtt.

My configuration for zigbee2mqtt is as below:


base_topic: zigbee2mqtt
user: mqtt_user
password: mypasswordhere
server: my HA IP:1883


adapter: ezsp
port: /dev/ttyACM0

I have tried different combinations of the serial config, i.e. with and without:

adapter: ezsp

also i have tried the port as

port: /dev/ttyACM0

and also as

port: >-

But irrespective i always get the below logs:

[16:10:06] INFO: Preparing to start…
[16:10:07] INFO: Socat not enabled
[16:10:08] INFO: Starting Zigbee2MQTT…
Zigbee2MQTT:info 2024-02-19 16:10:10: Logging to console and directory: ‘/config/zigbee2mqtt/log/2024-02-19.16-10-10’ filename: log.txt
Zigbee2MQTT:info 2024-02-19 16:10:10: Starting Zigbee2MQTT version 1.35.3 (commit #unknown)
Zigbee2MQTT:info 2024-02-19 16:10:10: Starting zigbee-herdsman (0.33.8)
Zigbee2MQTT:info 2024-02-19 16:10:13: zigbee-herdsman started (resumed)
Zigbee2MQTT:info 2024-02-19 16:10:13: Coordinator firmware version: ‘{“meta”:{“maintrel”:"3 ",“majorrel”:“6”,“minorrel”:“10”,“product”:8,“revision”:“ build 297”},“type”:“EZSP v8”}’
Zigbee2MQTT:info 2024-02-19 16:10:13: Currently 0 devices are joined:
Zigbee2MQTT:info 2024-02-19 16:10:13: Zigbee: disabling joining new devices.
Zigbee2MQTT:info 2024-02-19 16:10:13: Connecting to MQTT server at my HA IP:1883

Can someone please point me what my next steps should be.

What do you see in the log that you believe to be a problem?

I don’t really see any error messages in the log. Is there anything obvious i am missing ?

Looks like I have misunderstood what you posted. That’s not a fragment of Zigbee2MQTT’s log but all of it and the last line indicates it’s trying to connect to the broker but never progresses to “Connected to MQTT server”.

I’m using the Zigbee2MQTT add-on and don’t have base_topic, user, password, and server set to anything (i.e. those options aren’t listed in the add-on’s configuration).

If you are not using the Zigbee2MQTT add-on then someone else will need to help you because I have no experience with configuring Zigbee2MQTT in any other way.

Thanks, yes those are the complete logs & it doesn’t go to “Connected to MQTT server”.

Should I just delete the attributes - base_topic, user, password etc, or just delete the whole config ?

I am using the Zigbee2MQTT addon.

In that case, what reference did you use that instructed you to enter those four parameters?

I suggest you remove them and restart the add-on.

That worked, thank you .

You’re welcome!

Please consider marking my post above with the Solution tag. It will automatically place a check-mark next to the topic’s title which signals to other users that this topic has been resolved. This helps users find answers to similar questions.

For more information about the Solution tag, refer to guideline 21 in the FAQ.