Unable to find my mqtt device path to use in zigbee2mqtt

Firstly, I would just like to say, I am very new to HA so sorry if I don’t understand anything you say.

I bought a CC2531 adapter off amazon to try and get my Philips hue light to work, however all the tutorials I have found aren’t helping as they all say I need a device path to put in here:
However, no matter what I try, I cant seem to find the device path, I have tried everything from checking the supervisor logs to checking dmesg but I have found nothing, I would really appreciate if someone could help me out as I really don’t want to flash the device, thanks!

I am using HomeAssistant Supervised

The adapter I bought: CC2531 Zigbee2MQTT Firmware with Antenna for Home Assistant, Open HAB etc. : Amazon.co.uk: Computers & Accessories

Hi Welcome to the community :slight_smile:

It is really important that you provide the details necessary to give us a full picture.
Without it is hard for everyone (the community and yourself) to get your topic solved.
I can highly recommend getting through this greate topic about it:

Now enough of warm welcome :wink:
What is important to know here is:
Which kind of HA setup (OS / Container / Supervised / Core) are you running?
Which hardware does it work on?

Hi Martin,
I made a mistake in my original question, I am pretty sure I am using HA Supervised
This is running on a virtual machine on windows 10.

If you go into the Supervisor section, select the 3 dots and it should open a Hardware section for all the devices you have connected. Look for your CC2531 and use that path in Z2M.

Hi, CC2531 doesn’t come up for some reason

Look for Silicon Labs I think.

If you cannot see your hardware as @dextar described,
check if you have forwarded the USB drive to the virtual machine.

Not sure which hypervisor you are using (hyper-V or VMWare Workstation or VirtualBox),
depending on there are different ways to forward USB port.

If you are very new to HA it is mostly the easiest way to start with something like non virtualized hardware (e.g. Raspberry or Home Assistant Blue / Home Assistant Yellow)

1 Like

Yea once again, that doesn’t come up.

Like @mk-maddin has mentioned

1 Like

Can you share a list of what devices it shows?

Sorry for the late response, I have gotten it to work, thank you both!