Home Assistant Community

Unable to get fresh install to work

#1

I built a fresh install of HASS (virtual) earlier today based on the instructions on the website. I did not get any errors during the installation. Now when I start HASS, these are the errors in my log file:

2019-04-20 22:53:10 ERROR (MainThread) [homeassistant.components.device_tracker] Unable to load /home/homeassistant/.homeassistant/known_devices.yaml: Config file not found: /home/homeassistant/.homeassistant/known_devices.yaml
2019-04-20 22:55:52 ERROR (Thread-16) [homeassistant.util.package] Unable to install package hass-nabucasa==0.11: Exception:
Traceback (most recent call last):
File “/srv/homeassistant/share/python-wheels/urllib3-1.19.1-py2.py3-none-any.whl/urllib3/connectionpool.py”, line 594, in urlopen
chunked=chunked)
File “/srv/homeassistant/share/python-wheels/urllib3-1.19.1-py2.py3-none-any.whl/urllib3/connectionpool.py”, line 391, in _make_request
six.raise_from(e, None)
File “”, line 2, in raise_from
File “/srv/homeassistant/share/python-wheels/urllib3-1.19.1-py2.py3-none-any.whl/urllib3/connectionpool.py”, line 387, in _make_request
httplib_response = conn.getresponse()
File “/usr/lib/python3.5/http/client.py”, line 1198, in getresponse
response.begin()
File “/usr/lib/python3.5/http/client.py”, line 297, in begin
version, status, reason = self._read_status()
File “/usr/lib/python3.5/http/client.py”, line 266, in _read_status
raise RemoteDisconnected(“Remote end closed connection without”
http.client.RemoteDisconnected: Remote end closed connection without response

Any idea how to resolve these errors or do I need to start over?

#2

There are about 10 different sets of instructions on the website, specific to individual circumstances, so its hard to tell exactly what you were attempting. Can you post a link to the instructions you used.

1 Like
#3

I rechecked everything and found I had a typo in my services file. All is good now.

1 Like
#4

Glad i worked out.

I personally have installed home assistant 5 different ways and I know of at least 1 other way I have not tried.

Troubleshooting is different depending on how it is installed.

#6