Unable to pair Sonoff Zigbee SNZB-01/WB-01 Buttons

Tags: #<Tag:0x00007f73a59fe078>

I’ve got 2 Sonoff SNB-01 buttons, and neither of them work in HA.

I’ve tried pairing with a Sonoff Bridge flashed with Tasmota, and also a zigbee2mqt USB dongle. They appear to be paired, but in fact are not. The only entities I get are for battery state - but not the switch state. A Sonoff motion sensor and door/window sensor paired and work fine.

(This page:


implies that there is a particular way to report issues like this, using a template, but I can’t find a specific page to do so!)
Jim

You won’t see a switch. You should listen to the events the button produces.

Thanks fot the reply, Francis.
I’m not sure what you mean. There’s no entity state to listen to, only the battery state entity - ‘eWeLink WB01 4510d61c power’. Maybe I’m misunderstanding the way the button works.

Jim

I think they will need a quirk to work, worst zigbee 3.0 devices seem to need a quirk with ZHA despite them being able to fallback to HA1.2. The developers, and the do a fantastic job, seem to say it’s because the manufacturer doesn’t follow the standard. However, I have zigbee 3.0 certified devices which still need quirks so not sure.

1 Like

Thanks for the reply, Francis.

The problem is that there’s no button name/entity to select.

In Developer Tools -> Events I can listen for zha_events. If I press a button I get:
Event 4 fired 09:33:

{
“event_type”: “zha_event”,
“data”: {
“device_ieee”: “00:12:4b:00:1c:d6:10:45”,
“unique_id”: “00:12:4b:00:1c:d6:10:45:1:0x0006”,
“endpoint_id”: 1,
“cluster_id”: 6,
“command”: “toggle”,
“args”: []
},
“origin”: “LOCAL”,
“time_fired”: “2020-08-14T08:33:43.675881+00:00”,
“context”: {
“id”: “dcfaf613de0811ea8a66857578c757a4”,
“parent_id”: null,
“user_id”: null
}
}
So the button is actually working, but I can’t find a way to access it in HA or Node-Red.
Jim

Thanks Jason - looks like it’s going to be a tough one to crack - and far beyond my skills!
Jim

Yes ,me to I’m going to spend time on the weekend with the documentation and see if I can work it our, I’m not a programmer.

You can request it on the github site if you follow the links from the ZHA documentation. From the device in ZHA, you gather the “signature” and request the developers to help out.

I had a similar problem, I couldn’t find the 8 identities from my 8ch remote paired with Sonoff bridge.
I managed to solve it with catching MQTT messages in NodeRed so I didn’t even need the entities in HA

1 Like

I’m new to ZHA as well, can you listen for the zha_events from that device ID?

Here is an example for SmartThings Button.

I sorted my problem out - see this post, it may help:


Jim

There is a HACS add on to turn an event into a sensor.

Jason

Thanks Jason.
I’ve had a look at it and it seems a bit of a ‘faff’ to set it up, compared to Node Red. (I’m finding that most things are easier to do and trouble shoot in Node Red.)

Jim

Hi,
How did you get this far, I have tried

image

and get nothing?

I recommend that you try Node Red, - it’s very much easier.
Jim

1 Like

Hi, Installed the Integration from Hacs but unsure about configuration

I selected any other for integration firing events to listen for.
image
This is my log from hza_event

Event 1 fired 5:22:
{
    "event_type": "zha_event",
    "data": {
        "device_ieee": "00:12:4b:00:1f:91:92:1f",
        "unique_id": "00:12:4b:00:1f:91:92:1f:1:0x0006",
        "endpoint_id": 1,
        "cluster_id": 6,
        "command": "toggle",
        "args": []
    },
    "origin": "LOCAL",
    "time_fired": "2020-08-20T04:22:23.187561+00:00",
    "context": {
        "id": "bec98dbae29c11eaabda8592a0fd5882",
        "parent_id": null,
        "user_id": null
    }
}

I tried this configuration


This is what I am seeing, bad_state ?
image

This is the device info
image

Any pointers to guide me on the configuration?

Regards,

What Radio are you using?


flashed with Tasmota
I know the Switch is working as I have it set up as an automation, Trigger type event, event type zha_event and works fine.

Sorted

works like a charm, thanks to the Author Eugenio.

2 Likes

Anyone know how to solve this without resorting to 3rd party HACS?
I see so many problems with people losing HACS configs during updates I’ve avoided it!
Would really like to see HA properly support events to entities…?
Thanks