Unable to reach esphome from my Raspberry Pi

Hi all,

I’m meeting a strange problem…

I’m unable to ping my ESPhome devices (Sonoff S26 and Wemos D1 mini) from my rpi…

Thy are reachable with my main computer, like all other devices (wifi and ethernet ones).

I’m able to ping everything else from my rpi except to the ESPhome devices.

I’m running my rpi with static IP, with Pi Hole as my DHCP server. DHCP on my router is disabled.

Any ideas ? I’m out on my side…

Thanks !

By name or ip address?

Both unfortunately.

what is the ip address of the windows machine?

It’s, fixed by the DHCP on PiHole. for the rpi, static in dhcpcd.conf.

Why ?

Suspect to see if you are crossing vlans and firewall rules.

Are you getting the same as the last post in this thread ?

1 Like

Just making sure everything on same subnet.

Hum OK, so yep it’s all on the same subnet

Yes, PiHole is installed on the HA machine, it’s the rpi. HA is installed through a venv, with different user. I don’t think there’s a problem withe the HA configuration, for me it’s more on the network side.

The thing I’m unable to understand it’s why I can’t reach the ESPhome devices from the pi, and at the same time I can reach everything else (NAS, phone over wifi, laptop on Windows, on linux, etc…)

Only difference I can tell is that ESPhome on ESP8266 boards don’t support IPv6, but I don’t see how it’s affecting ping with v4.

All of this appeared after I switch off wifi for 10mn or so, disconnecting the pi (it’s connected over wifi) and ESPhome devices. Then after switching back wifi, I was able to access HA, but my ESPhome devices were unreachable. It’s from there that I checked ping and stuff (I reprogrammed the ESPhome devices via UART, with no result).

OK, so problem solved, but I’m not explaining it…

In fact, the windows machine is connected to the router through Ethernet.

Whereas the rpi over WiFi, on 5GHz band. But the ESPhome devices are connected on the 2,4GHz.

After disabling the 5GHz band on the router, thus forcing the rpi on 2,4GHz, everything is back to normal and I can ping every devices from everywhere.

Thanks John, the linked post made me realize that I have the two wifi frequencies enabled on my router.

1 Like

This is strange, unless you have allocated different IP range, your devices should be discoverable across both bands, unless there is a specific setting in the router that blocks the IP addresses from 1 band to another.
You can enable DHCP in router and try to check again with enabling both bands in router. If you are worried about the RPI ip changing - you can reserve the ip address in router (unless your router does not support it)

I am just saying this since 5GHz significantly improves the connectivity across the devices (including internet)

1 Like