Unable to SSH or FTP into Home Assistant

First of all - thanks to the devs for supplying HA (and at such a competitive price, too!).

I’ve installed HA on a Raspberry PI and it all went OK (though I was taken aback as to how un-Rasbian it is).

I’m trying to ssh or ftp into the Pi and have installed and configured the addons. Any attempt at connecting is refused. With SSH I’m using a key generated by ssh-keygen, copied and pasted into the config.

I’ve nmap’ed the Pi but all the ports are closed, including 21 and 22.

I’d be grateful for a bit of help here, please!


The number of different ways of running HA is unbelievably complicated and not well documented. (There is a great flow chart in this post which made things clearer for me.

Sounds as if you are running it as an operating system on the Pi, replacing Raspbian or whatever else you would be using, so you shouldn’t expect normal Pi stuff to work. By trial and error I have discovered that installing the Terminal & SSH add-on allows access to the various HA configuration files etc. Beyond this, if you remove the SD card from the Pi and mount it on your PC you can get direct access to the hassos-boot partition. As this point I lost my nerve and gave up.

I flashed hassos_rpi3-3.13.img.gz onto the card and went from there. It’s an idea to transfer files by removing the card and accessing it on my PC (Linux), but there must be a better/proper way! If I do mount the card on my PC, I might put an empty ssh file on the boot partition, and hope that it enables ssh as it does on Rasbian. Once I can access the system I’ll use Filezilla to transfer files.

It looks like a nice system, but there’s a lot of weirdness goes on under the bonnet - I always thought that a ‘docker’ was a burly bloke that loaded and unloaded ships! :wink:

Thanks for the reply ‘Stiltjack’.


For transferring files I use the samba share add-on. It works particularly well with CX File Explorer on my Android tablet. It also makes it possible to do a backup to Dropbox.

I struggled with it for days. Found a solution and made it work. I have documented it on https://arkor.nl

I have used samba in the past, but as I don’t use Windows I’ve not had a lot of use for it. I’ve had a perfunctory browse, but can’t see the WORKGROUP.

I’ve noticed that with both the smb and ssh addons that whilst after installation, starting the services doesn’t actually appear to do anything because nmap showed the ports to be closed. After a reboot the were open.

I may well ditch this installation and do it again from a Rasberian installation. At least with Rasberian ssh is very easy.


Managed to get ssh working. I think that the problem was that I might have missed some characters when I copied and pasted the key.


Are you willing to disclose it ? Website does not like access.

I seem to have the same problem with FTP. I don’t know how to remedy it.
By the way, SambaShare add-on does not show all files on my HA OS, does it?

In my case, this is probably the reason:

Blockquote[23:35:32] WARNING: Password is in the Have I Been Pwned database!
[23:35:32] WARNING: Password appeared 147396 times!
[23:35:32] FATAL:
[23:35:32] FATAL: We are trying to help you to protect your system the
[23:35:32] FATAL: best we can. Therefore, this add-on checks your
[23:35:32] FATAL: configured password against the HaveIBeenPwned database.
[23:35:32] FATAL:
[23:35:32] FATAL: Unfortunately, your configured password is considered
[23:35:32] FATAL: unsafe. We highly recommend you to pick a different one.
[23:35:32] FATAL:
[23:35:32] FATAL: Please change the password in the ‘users[0].password’ option.
[23:35:32] FATAL:
[23:35:32] FATAL: Check the add-on manual for more information.

“Please change the password in the ‘users[0].password’ option.”

How to do that?