UNEXPECTED ERROR reolink IP camera

To anyone still having issues with this integration, I opted to NOT use the Reolink integration and found this link online to be extremely helpful.
I was (with the Reolink IP Integration through HACS) getting an unexpected error.
Switching to ONVIF it connected first try. Hopefully this helps someone!!


@INVADIA666 To clarify, I believe you mentioned you are trying to setup the E1 Pro.
I also purchased the E1 Pro, had to set it up using the ONVIF integration not the Reolink HACS Add-on through the custom repository (or the newly added IP devices one in HACS) as the E1 Pro is not supported.
I found out the hard way as well…always read the fine print.
As someone said in this thread, read through the “Read Me” from the Reolink Add-on…if you’d like, skip to the very bottom where it mentions unsupported devices. E1 Pro is listed…unfortunately. Wish I could get controls in HA!

1 Like

thanks for your comment mate , the main camera I’m trying to set up with every integration possible is the DUO POE, it’s actually supported , but I always receive the same error when I try to add it . haven’t had any luck with webrtc and onvif , I get the same error , I really don’t know what else to do , what’s left I think is to create a different account with reeling , remove and reset the cameras and add them to the new account , with a new IP and try … if that doesn’t work , I honestly give up .

Home assistant team needs to fix the issue with the cameras , it’s not only me who’s facing this issue , there’s heaps of people out there frustrated with this problem .

which other camera apart of reolink are good and easy to integrate with home assistant ?

cheers mate

That’s mate, I was having the same issue as original Poster and I followed your steps and it’s working perfectly. Thanks

1 Like

I have the same issue, the ONVIF worked for me mentioned above, one thing i did see was that the two camera that werent connecting using the Reolink IP Integration were both connected by Wifi OR were remembering a wifi password. There were also fewer choices than the two cameras in settings.

It might also be worth mentioning that i couldnt connect to the two cameras that wouldnt connect in the integration through the browser.

Quick update after couple of months , now with the official integration i was able to integrate all the cameras into HA , even is they are not in the same wifi network as my HA instance .
I had a minor issue with a DUO 1 Poe that was connected to a different network , it couldn’t connect at all , so i decided to plug the Ethernet cable into the same network as home assistant and it connected perfectly.

1 Like