Updating configuration.ymal after after installing DuckDNS, HA does not start anymore

Tags: #<Tag:0x00007fc422292bb8>

Hello, I am trying to configure remote access to my HA by following these two videos:

so far I have:

  1. Create a port forward rule in router (8123 (outside) -> 8123 (inside))

  2. Successfully create a DuckDNS account are obtained a token

  3. Successfully installed DucDNS add-on and configured with:

    lets_encrypt:
      accept_terms: true
      certfile: fullchain.pem
      keyfile: privkey.pem
      token: xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxx
      domains:
        - xxxxxxxxxx.duckdns.org
      aliases: []
      seconds: 300
  1. Edited configuration.ymal with:
http:
  base_url: xxxxxxxxxx.duckdns.org
  ssl_certificate: /ssl/fullchain.pem
  ssl_key: /ssl/privkey.pem
  1. validated configuration

  2. restarted

Once restarted, I cannot anymore access HA with the internal IP address (192.168.1.251:8123)… (I am not sure if I could access it form outside as well)… the only way to make it work, it to access via ftp /config/configuration.ymal and delete the followings:

http:
  base_url: xxxxxxxxxx.duckdns.org
  ssl_certificate: /ssl/fullchain.pem
  ssl_key: /ssl/privkey.pem

it seems to me that the http configuration is somehow breaking the system…

any suggestion?

2 things:

  • when you enable SSL, accessing via the internal IP address will now produce a security error in your browser due to the certificate being for your DuckDNS address and not the IP (they don’t match). You can usually accept the security error and continue anyway, but generally not recommended.
  • depending on the version of HA you are running, base_url: has been deprecated and you need to provide external_url: under the homeassistant: heading in your config.

if you can FTP in, you can access and check the logs for errors why HA isn’t starting.

Are you using http or https?

Video material is very quickly out of date with a product like HA you are best reading the documentation or browsing the forum (weighting more recent posts (or ones that are updated) higher than older ones

I am running latest version… so you are right, base_url is not working anymore :frowning:

you are so right! I have find rthe solution here: DuckDNS - It's not just me - it's you!

now it works :slight_smile:

thank you everybody!

Yeah, I maintain that one :rofl:
Be sure to like the post it will raise its ranking