USB Boot on Raspberry Pi 4

Sorry, not great with all this.

Would a new rpi4 (8gb) work with the below, or still not possible to boot from usb and use HassOS PIB2M21 USB to M.2 SATA Converter for Raspberry Pi and Development Boards - Red

Yes that board would work with the 8gb Pi 4 (See However the Pi firmware is still a beta version, so may have bugs and whilst it may be possible to hack the current version of HassOS, I’d suggest waiting until the Pi f/w is out of beta and there is a version of HassOS that has the appropriate updates (or someone publishes a way to make it work :slight_smile: )

So you could go for the generic Linux install (over raspbian) now called HA Supervised.
This may be related to the drive adapter, see James Chambers blog on system from SSD.
Alternatively you may need to wait for a more resilient hassos for pi4
Can you identify what ssd you have along with what adapter and how it identifies itself to the USB hub (see the James Chambers article on specifics).

Any snapshots you generate will be transferable to your final system

@Blueman2 today version 4.8 has been released. According to the commits the new kernel needed is included. Have you tried this version? You can install it with Balena Etcher as always.

1 Like

Thanks for the heads up. I just noticed that first thing today as well. I am excited to give it a try later today. I have fingers crossed since I already have direct boot from SSD working on Raspian 5.4.42 kernel.

1 Like

Well, no joy here. I burned the new 4.8 image for RPI4 onto my ssd, tried to boot from RPI4, blank screen. Move the ELF and DAT files over from my working Raspbian 5.4.42 SSD (which boots fine off the beta EEPROM RPI4) but still no joy with the HASSIO boot.

I am very confused why this is not working. Same RPI4 (with updated EEPROM), Same 5.4.42 kernel on both the Raspbian and HASSIO SSD’s. Same .elf and .dat files on both SSDs. But one boots just fine and the other does not.

1 Like

Is the same SSD model?

Actually, it is the same SSD. I am using the same SSD and Adapter, just overwriting the SSD each time. Yes, takes a while but I wanted to exactly duplicate what works with Raspbian.

Hi all

When I set my Pi3 to boot from USB I had to download a special image which I got from here

The Github Page

The standard image would not boot.

Hope that throws some light on something, if you look at the code there have been some tweaks

Re Dave

Thanks for the link, Dave. I think that is only for RPI3 thought. RPI4 is what I am looking for since it can use high speed USB3.

Hi, yes I did realize that you wanted to use a Pi4, I was just pointing out that the standard image did not work when booting from USB on a Pi3, so I guess it will be the same for a Pi4

At the time I remember looking at the source code of the USB Boot code, and there where not too many changes.

Hopefully somebody will come up with a solution for the Pi4. I have always been amazed that a USB boot option has never been looked at by the HA team.

Re Dave

1 Like

In theory it was added official support for the Raspberry Pi 3 in Hass.os version 3.0:

Only needed was to add the program_usb_boot_mode to the boot partition because the Pi3 has not eeprom.

But I understand what you say, maybe is not enough the new Kernel, and it needs something more. I suppose that once the Eeprom goes out of beta, it will have more interest for everybody.

1 Like

Home Assistant OS updated again, version 4.9. I don’t think it will work now but who knows…

I’m waiting for the possibility to boot from USB. Because then I can for example connect larger disk copy movies and use plex plugin for Hass os.

It is really painful for me that we can’t mount external USB HDD.

New hassOS released yesterday, has anyone had luck getting the Pi4 to USB boot with version 4.10 of hassOS?

I doubt it works. The changelog is a regression of the raspberry pi 4 kernel:

Thanks for the reply @McGiverGim… Alas I will continue the wait for native hassOS USB boot on pi4 :confused:

1 Like

let me know when it will be available :slight_smile:

If you haven’t do that… go to and add a :+1: on the first post in the issue :wink:


Just finished installing the new HassOS 5.0 build straight to an SSD then booted on a 4Gb RPi4 and it works perfectly!

Huge thanks to the HA team, great work!!