Use IPv4 and IPv6

Hello Guys,

is there a way to use HA with IPv4 and IPv6 ?

If i’m using http: server_host: ::0 only IPv6 is working.
Is there a way to use both, IPv4 and IPv6 simultaneously?


No. Home Assistant is single stack currently. It’s just the one or the other. You could only work aroung whis by using a reverse proxy that is dual stack.

1 Like

I will look for a workaround with reverse proxy.

Works with Caddy…

Caddy ? Do you have a link?

My HA runs 100% on IPv6 - my duckdns domain only has an IPv6 address…

OT: @DavidFW1960 why would you use caddy and duckdns? The duckdns addon has let’s encrypt already build in. Just to use IPv6?

In my case, I don’t use the duckdns addon at all. My router does duckdns but on my NUC I have a different domain and just use a script to update DuckDNS (only updates IPv6 address) and use LetsEncrypt via Caddy.

In actual fact my IPv6 address is static but I still use it for external access via a duckdns domain.

Also, Caddy is a reverse proxy so I actually only open 443 and 80 but can access all Hassio addons like configurator, tasmoadmin etc without extra ports…

1 Like

Thanks for your explanation. I’ll look into it!

I have a tutorial here if you’re interested.

Only problem with IPv6 only is the mobile network for my phone is only IPv4 which is a nuisance. My iPad 4G does IPv6 though and on the phone I can VPN in to my router and use the IPv4 IP address for HA and connect…

Solved it with using 6tunnel for debian. Thanks all!

is this still the case at the time of writing? I’ve enabled both ipv6 and ipv4 and the connection broke in a very interesting way. I was not able to resolve DNS correctly. DNS requests resolved to IPV6. Connection through IP however was working fine. I had to disable IPv6 to make everything working again.

I just had this issue again similar to past issues, could access via http no problem and https still loaded but it was the retry button splash screen. Had just recently enabled ipV6 again on eero (disabled before because of similar issues but wasn’t sure if ipV6 was actually the culprit) and lost access to remote access. Unplugged the ISP modem a few times, rebooted eero network (must’ve reset ISP because I had to re-enable bridge mode on the ISP modem) and restarted duckdns and NGINX and then she was all fixed up.