Vacuum component fails after latest update

are you haveing the same errors in the log as I had? I havent got the time to tinker with this at the moment but I can try to reopen the ticket and point them here if you give some logs

seems I cant re-open them if someone else closed them :confused:

After I reset my roomba to factory default I couldn’t reproduce the problem anymore. So it’s hard to troubleshoot at the moment. I don’t get the error with the wrong flags:
def _internal_on_disconnect()

So I am a bit stuck. Maybe the error will come back. So I suggest do a factory reset. Hope it helps

my problem is that I dont know how to run commands in docker, I have reset my roomba to factory defaults and added it in the app and now I cant get the password from it again since it probably has changed after the reset. I tried to install the ssh addon but when I try to run:

docker exec -it homeassistant python -c 'import roombapy.entry_points; roombapy.entry_points.password()' 192.168.1.73

it only gives me: bash: docker: command not found :frowning:

I used this one https://github.com/NickWaterton/Roomba980-Python
I created virtualenv and installed required libs and runned the roomba command. This one worked better than the library used in home-assistant.