Vanilla install on RPI4B 4GB with RaspBee

Error from home-assistant.log:

... adding custom device "/dev/bus/usb": no such file or directory")


20-02-04 14:18:52 INFO (MainThread) [] Load add-ons from store: 65 all - 0 new - 0 remove
20-02-04 15:06:48 INFO (SyncWorker_19) [hassio.docker.interface] Clean addon_core_deconz application
20-02-04 15:06:49 ERROR (SyncWorker_19) [hassio.docker] Can't start addon_core_deconz: 500 Server Error: Internal Server Error ("linux runtime spec devices: error gathering device information while adding custom device "/dev/bus/usb": no such file or directory")
  • Flashing Dresden Elektronik’s deconz image on my Pi4 - zigbee network runs perfectly.
  • Flashing vanilla (latest) on the same Pi4 gives this dev/bus/usb error.

Possible hardware error? Faulty Rpi4?

Is this a hardware error, or “configuration/install/eeprom/config.txt” related inside the scope of a install? I’m having issues when connecting USB Keyboard / USB Mouse with the Raspberry Foundations stock images.

Tried keeping configuration as small as possible, to eliminate other sources for failure. Official Deconz add-on, 18W Apple iPad Pro USB-C charger, brand new SD-Card, tried several, also booting from USB Drive. supervisor v195 reports this hardware, tried both:


This is the add-on config:

  "device": "/dev/ttyAMA0",
  "vnc_password": "my_s3cr3t_p4ssw0rd",
  "dbg_info": 1,
  "dbg_aps": 1,
  "dbg_otau": 1,
  "dbg_zcl": 1,
  "dbg_zdp": 1
  • config.txt is set up according to the Deconz Add-on documentation.

  • I’m unsure about having SPI on or off as RaspBee communicates UART, but I’ve tried both to same result.

I’ve emailed support at Dresden Elektronik but haven’t heard anything for a week, and Zigbee is pretty critical for my smart home. At least I now learned I need a backup zigbee controller up and running somehow.


1 Like

I have a Raspbee running on a RPI4B 4GB. It took a LOT of browsing forums and trial and error though. Basically: I needed to edit a config file in the boot partition and add a code so it would recognize it. I don’t remember which one but a quick search should get you on the way. I could only access the boot partition on Windows though (Mac didn’t access it) or with SSH by enabling port 22222 (which I couldn’t get working). After installing Windows I managed to access the boot partition and edited the config file.

After all that I got RaspBee working, but I couldn’t update it with Deconz add-on. Without the update I could not add/use most (if any) Zigbee devices. The update installed but then after that it still was on the old version and asked me to updated. After 40 something attempts and hours of searching, I finally found out I could install Deconz on the sd card as its own OS. With that I could update the Raspbee. Then I once again for the 14th time, reinstalled and it all worked. Having one sd card sure was a pain lol.

So in short: Raspbee on RPI4B 4GB does work.

Edit: here is a post I made as a solution for others. Editing config.txt issue. Make sure you read the links I provide there :slight_smile:

Thank you for the help; I’m still getting the same errors.

  • To edit config.txt, I’ve found the easiest is to install the alternative Terminal from the community repository

  • With this terminal, you can enable showing the hassos_supervisor container.

  • Then get a shell within with exec -it hassos_supervisor /bin/bash then mount boot with mkdir /home/foo; mount --rw /dev/mmcblk0p1 /home/foo and then edit config.txt with vi /home/foo/config.txt to add the Pi4 config for the Raspbee.

  • I’ve followed your example, installed the Dresden Elektronik image, booted to that and made sure the RaspBee is upgraded. Firmware is 26330500, version 2.05.67 17/11/2019 - this is the same you have, right?

  • Just to be sure, I left the deConz linux image running overnight in case it did some other smartness in time.

  • Rebooted to my hassio image, but I still get the /usb/... error. Is this the same error you got in your hassio supervisor logs when trying to start the deconz add-on?

I’m again going to trying to reinstall hassio from scratch. I’m now at my third week of not being able to control my zigbee network and WAF-factor of our smart house is at an all-time low :wink:

Anything else you can remember doing to get everything working?

  • I know there might be a faulty batch of Pi4’s regarding USB, as I mentioned.
  • I’ve read of multiple cases people had trouble getting USB keyboard/mouse running on stock Raspberry Foundation images.
  • Everyone who got their Pi4 replaced, booting the exact same image on the SD, mouse and keyboard started working again.
  • Perhaps this is one of the Pi4 boards I have. Thing is it’s not trivial for me to get it replaced as I purchased the Pi4 second hand.

Moving forward

I have 5 x ODROID N2 and 5 x Google Coral USB Accellerators on the way which I will set up as a kubernetes cluster with 20 TFLOPS from the edge-tpu’s - to run tensorflow lite machine learning containers. I’m starting with which is simply mindblowing easy to use.

  • When that hardware arrives everything is going to be set up containerized, not using just installing Home Assistant on its own and everything else in individual containers.
  • docker-compose for everything moving forward.
  • I realize my smart house setup is too critical to have weeks of downtime like I’ve now experienced.
  • Since everything HA is open source for good and bad, getting support is not trivial when you’re stuck. Also since the RaspBee works perfectly on its own with the deconz image, Dresden Elektronik can’t be expected to provide support with deConz within Hassio.
  • To avoid have to reboot Home Assistant so often, I’m going to find somehow a way to be able to mitigate that, perhaps by running two instances of HA and getting an extra zigbee controller as a failover backup somehow.
  • I wish I didn’t invest in so many zigbee based sensors and actuators, everything I have on the Z-wave part of my setup has been rock solid and so much more robust. Support from Aeotec has been incredibly good, even with extreme edge cases they have provided me with competent support resolving my issues. Thumbs up to Aeotec, depite the troubles with the Z-stick gen 5 RPi4 USB issues-