WARNING: latest docker-ce (20.10.0) not compatible with Home Assistant supervised

Thx for the info, unfortunately I saw it too late and the disaster was inevitable. I lost most of my docker containers, including the main HA one :(.
Fortunately I managed to downgrade docker and repair the containers and with a little help of my daily backup I was quickly back in the game :).

Yup. I posted a few days ago about this when it happened to 2 of my servers. Derp. Really annoying.

Nice to know this issue !
I lost a lot of time to go back and run again !

How can I know the supervisor issue is solved and compatible with the latest docker version ?

If helpful, this got me back up and running. FYI I originally installed using the installer on Ubuntu. This didn’t overwrite or change any of my other settings.

This process will roll back to the last release of docker. Note I’m running Ubuntu 20.04 (focal). If you’re running a different release, you’ll need to change the release name in the second set of commands. You can explore previous package versions on your release with the commands:

apt-cache policy docker-ce
apt-cache policy docker-ce-cli
apt-cache policy containerd.io

Login as root (or use sudo) and run these commands:

apt purge -y docker-ce docker-ce-cli containerd.io
shutdown -r now

After the reboot, run these commands. Add your machine architecture to the installer command line if needed (eg. --machine intel-nuc):

apt update
apt install -y docker-ce=5:19.03.14~3-0~ubuntu-focal docker-ce-cli=5:19.03.14~3-0~ubuntu-focal containerd.io=1.3.9-1
curl -Lo installer.sh https://raw.githubusercontent.com/home-assistant/supervised-installer/master/installer.sh
bash installer.sh

Give it a bit and refresh and hopefully things are back to normal!

Thanks a lot mcemce!

In case anyone has this same issue on a Raspberry Pi (if not 4 then just change the machine type) these are the commands:

apt purge -y docker-ce docker-ce-cli containerd.io
sudo reboot

After the restart:

sudo apt-get install docker-ce=5:19.03.14~3-0~raspbian-buster docker-ce-cli=5:19.03.14~3-0~raspbian-buster containerd.io=1.3.9-1
sudo bash installer.sh --machine raspberrypi4

After running the setup again everything was back to normal pretty fast :smiley:


I’m following this issue.

Registered just to say thank you for posting this. Logged in and set docker to be held back in apt. Is that sufficient or are there more steps I should take to keep it from updating?

I can confirm that version 20.10.1 is available and compatible.

1 Like

Anyone else who can confirm this? :wink:

I’m running HA on raspbian in docker. I upgraded my hole system yestsrday (apt update and apt upgrade). Docker is now on version 20.10.2 and everything works fine so far. Only thing is, for some reason I had to start the home assistant docker container manually.

HA is version 2021.1.0, supervisor is 2020.12.7

Just letting you know that I have updated following packages to the latest version and now the GUI does not load on x64 and Ubuntu 20.04.2 LTS.
Removing docker-ce (5:19.03.14~3-0~ubuntu-focal) …
Removing containerd.io (1.4.3-1) …
Removing docker-ce-cli (5:20.10.2~3-0~ubuntu-focal) …

Not sure how exactly, did not check any logs.

10.10.2 works so you have some unique issue. First check the obvious…did the IP address change. Then check the logs.

Same story with docker 20.10.4 on Rasbperry Pi 3B+ (Raspbian). I have used following command in order to restore docker 20.10.3, keep it (now it won’t update docker to 20.10.4 during sudo upgrade/update) and restart homeassistant container:

sudo apt-get install docker-ce=5:20.10.3~3-0~raspbian-buster docker-ce-cli=5:20.10.3~3-0~raspbian-buster containerd.io
docker restart homeassistant
sudo apt-mark hold docker-ce docker-ce-cli containerd.io



I was able to recover from the docker upgrade.
Thanks Vivant.

I am never gonna update docker, ever again!!!

Just had same issue with upgrade of dockers from 20.10.3 to 20.10.4 on Armbian, which is debian buster. Had to do the downgrade to 20.10.3. Hopefully the dev team will have an upgrade to supervisor that works with 20.10.4 soon. I could restart the containers directly using docker command but systemctl restart hassio-supervisor.service just did a silent exit once it tried to start things. Nothing useful in syslog.

Docker 20.10.5 for Debian has just been released and works well with supervisor-2021.02.11.

Take a look here

1 Like

Beware, it might work, but might as well not. On Debain possibly, on Raspbian it’s tricky… I updated (directly from 20.3 to 20.5 as I skipped 20.4, to be on a safe side - at least I thought so) … it completely ruined my docker installation, it didn’t even start anymore, showing:
ERROR: Cannot connect to the Docker daemon at unix:///var/run/docker.sock. Is the docker daemon running?
None of the Google found solutions worked in my case and also downgrading to 20.3 didn’t work, I had to install the Raspbian once again from scratch!

I updated docker-ce on my pi4 which basically killed my supervisor. I did this to fix it immediatley:

sudo docker pull homeassistant/armv7-hassio-supervisor:latest
sudo docker tag homeassistant/armv7-hassio-supervisor:latest homeassistant/armv7-hassio-supervisor:latest
curl -sL "https://raw.githubusercontent.com/Kanga-Who/home-assistant/master/supervised-installer.sh" | bash -s --machine raspberrypi4

for pi3:

sudo docker pull homeassistant/armv7-hassio-supervisor:latest
sudo docker tag homeassistant/armv7-hassio-supervisor:latest homeassistant/armv7-hassio-supervisor:latest
curl -sL "https://raw.githubusercontent.com/Kanga-Who/home-assistant/master/supervised-installer.sh" | bash -s --machine raspberrypi3

--machine don’t work for me
-- -m this is the command in official installation

1 Like