Web Access Failure

Hello,
My name is Tomás.
I installed HA recently (HassOS “direct” - without Linux) on a Raspberry Pi 4.
Everything was working perfectly.
Working in the configs and testing the system, I created a dynamic DNS with DuckDNS and activated the Lets Encrypt add-on.
I don’t know if it has anything to do with it, but then, on the same day, I lost access via web (http://ha-ip:8123).
I did a network drive map in Windows and I have access to the files. The configured IP also responds to ping. But the HA interface does not open in the browser.
Does anyone have any idea what may be going on?

Thankful…

Tomas

DuckDNS includes Lets Encrypt security certificates to allow for secure encrypted browsing.

After installing DuckDNS you will have to use https, not http. Also you will have to allow a security exception in your web browser if navigating to the ip address as the security certificate is for your DuckNDS address, not the IP address.

If your router supports NAT loopback you can go to the DuckDNS address on your local network without any added latency.

Wow… so simple!!! It worked!

Thank you very much for your prompt response!

Kind regards!

No problem. Please mark the post solved (button under the post that helped) as it may help future users with their searching.

Tom (namesake!), one more doubt:

On my home router I already configured port 8123 for the Local IP of HA both in NAT and in Port Triggering.
However, when I am logged into the Wifi network at my home, I’m not able to access HA through the app, only through the browser. But if I disconnect from Wifi and access via the mobile fone operator’s network, ok, I can access through the app.
When trying to access the app, with the mobile phone connected to the Wifi LAN, a connection error is displayed:
“Unable to connect to HA. - There was an error loading HA, please review the connection settings and try again”.
By clicking “Ok”, I can edit this options: HA URL, HOME NETWORK WIFI SSIDs and INTERNAL CONNECTION URL fields.
I kept the following settings:

  • HA URL: https://“my-domain”.duckdns.org:8123
  • HOME NETWORK WIFI SSIDs: I typed the SSID of my Wifi network
  • INTERNAL CONNECTION URL: https://XXX.XXX.X.XXX:8123

What could be happening?

Thanks for listening


Tomas

Yeah I have to use the duckdns URL for both internal and external.

If your router supports NAT loop back this won’t actually go outside your network.

Thanks again Tom!

So, just to validate my understanding: if we use DuckDNS with Lets Encrypt it is no longer possible to use the HA App when we are connected to the Wifi of the local network at the residence. That’s correct?

Via browser, in my case, when I am connected to the Wifi network, the address https://mydomain.duckdns.org:8123 does not work but https://myip:8123 works.

Did I configure something wrong? I’m thinking here …

No, not correct at all.

You just have to use the duckdns address instead of the IP address in the app config.

Then there is something wrong with your router setup. Maybe it does not support hairpinning?

Hello Tom,
I use the cable TV and Internet service provider’s router. I checked the options on the router interface and found nothing about hairpinning.
So, under these conditions, for me to continue using the HA app when connected to the wifi network, perhaps one option is to disable Lets Encrypt (and keep DuckDNS) …

A better method would be to use a reverse proxy. This would allow http access inside your network while retaining encryption for remote access.

See: