What does this mean: Integration zwave does not support reproduce state

I’ve browsed the forum and googled everything but it seems I am the only one having this issue in the log.

I dont see any weirdness with my zwave dimmers so far but I would like to have 0 errors in my home assistant log.

can you paste the actual error please?

2019-12-27 22:41:23 WARNING (MainThread) [homeassistant.helpers.state] Integration zwave does not support reproduce state

and it keeps repeating.

I believe it has something to do with setting up scenes with the scene editor instead of doing it manual. when I remove the zwave devices from my scenes the errors disappear.

What I can see in my scenes.yaml is that the installation with the frontend makes a state open or closed for the [entity].level and for the [entity].switch. I removed it just now because I had the same error. I will look tomorrow if this made the error disappear.

So it looked like this:

      state: open
      state: open

I changed it into:

      state: open

You can’t use zwave.xxx entities in scenes anymore, because they don’t support reproduce state, it’s the same for remote.xxx unfortunately :roll_eyes:

But anyway I don’t think you want to use the zwave.xxx entity in the scene, as this is just the device, you can’t turn it on/off/dim or whatever. You need use the entities created by this device, like light.xxx or switch.xxx.

You will probably get the same error again. Change your scenes to scripts to make it work.

I used the Scene creator in the UI and was getting this error.
I logged it as an issue as I believe the UI scene creator should not generate such errors.
Good to know the reason for it though.
It gives the error whether I do the zwave devices as entities or devices.