What is needed to set up home Assistant on a Raspberry Pi 2 Model B?

Is there any initial setup required on a Raspberry Pi 2 Model B that is not needed on a Raspberry Pi 3 Model B+?

Additional info: I have next to no knowledge of home automation but have managed to get Home Assistant running on Pi Model 3B to the extent that I can log onto 192.168.0.X:8123 and view devices - presently just a television, WiFi router and a Sonoff Zigbee 3.0 USB Dongle. The P1 3 Model B+ was “borrowed” from another project but I have three redundant Pi 2 model B which I have been trying to set up - but with no success. I am viewing the activity on the Pi with a monitor connected to the HDMI port.

Trying image hassos_rpi2-5.7.img.xz the Pi boots to the ha> prompt and I am able to ping it but not connect to 192.168.0.X:8123/lovelace/0. Using a more recent image, haos_rpi2-7.1.img.xz, Isee the system booting up until it reports:-
Error returned from supervisor: System is not ready with state: setup

I assume from playing with Linux in the past that I need to edit something in /etc/ but have not found out what needs doing.

Any assistance would be much appreciated.


First & foremost, installing on anything less than a Pi 3 is not officially supported. That means hassos is not designed to run on the Pi 2.

Many people here use a Pi 3B+. I use mine with a test HA instance.

1 Like

Thank you Prodigyplace, but several people have mentioned elsewhere that they are using Home Assistant on Pi 2 model B and the most recent image I installed, Haos_rpi2-7.1.img.xz was released 2 days ago so I assume working at least at some level

As I am using this only to control the heating in a shed so that I can get it up to temperature in the morning it should not overwhelm the simplest of systems. Other things like door alarms can come later.



Other reasons whay I would like to use the Pi 2 Model B is that I have them; that my one Pi 3 Model B+ gives occasional “Under-voltage detected!” errors with 2.5V power supplies including the reccommended Samsung 2.5A supply; and because it is a long weekend and it will take several days to get a Pi 4 or Pi 3; and not least because Pi 4 is now between £79 and £140 on Amazon.

Even some obsolete instructions from the days when the Pi 2 Model B was not a social pariah would be helpful.


Hi , Please test the Pi 2 Model B and let me know the result ,please also link to the same bin you will be using as i also will test it

The Pi 2 Model B i am using for HA instant is also giving me Under-voltage detected and I though its a bug because the HW is old and and the version for this PI is also old . I am also not sure it has to do with the power supply because I also tested multiple power supplies but there are just regular ones

This error was one of the reasons I moved to PI4


Hi ALDIY. Until I find out how to get the Model 2 to setup correctly I won’t be able to test it. However, on your problem with under-voltage detection, I think my trying everything-in-sight has found something that may help.

My model 3+ has problems with Samsung ETA-U90EWE 5V 2.5A wall-warts which were recommended by Raspberry Pi for the model 3+. I have tried two different ones with the same result. A no-name wall-wart marked 5V 2A is in fact slightly better with one under-voltage report in 5 minutes vs about 2 under-voltage events a minute with the Samsung units. An Amazon wall-wart model no. PS57CP and marked 5.2V 1.8A is perfect, giving no problems. I think the difference in being 5.2V instead of 5.0V and/or possibly the smoothing was better.


Thx for the tip , I will test hassos_rpi2-5.7.img.xz but I think the under-voltage is going to be the least of our problems with support and performance issues later on.

If you find out anything useful to do with the PI2 then please let me know because I could not and that is the whole reason I used it before with HA test instance but really I do not need two HA hosts .


O.K., I managed to get Home Assistant running on a Raspberry Pi 2 Model B. I found the following which looked promising:-

By working through this line by line, avoiding the diversions for other machines, I got it working. The only panic was after the last line ( sudo dpkg -i homeassistant-supervised.deb ) where nothing seemed to be working but after I went away and had a coffee, I was able to log on with and everything seems good now.

Next thing is to try to get to grips with the rest of it. At the moment most of the nice easy instructions for setting up Home Assistant might as well be written in Latin - but if I stare at it hard enough for long enough it may begin to make sense.



Hi leadinglights, Its very good you had it working .The minor concerns from the guys before is on support which is not that important and performance which could be okay for small setup .

Although i had no real reason to move from pi2 to pi4 ,but for sure the performance is much better on the pi4 which could safe a lot of time in testing and integration as your setup gets bigger

Cheers and please update us if you face issues so we could avoid the same

May I ask where you found the rpi2 image? It’s not listed in the installation guide.

I’m considering considering switching from OpenHab, and I’d like to test it with my existing hardware before committing financially to upgrading.


You can find the latest release here: https://github.com/home-assistant/operating-system/releases/tag/9.4

The most recent image for rpi2 seems: haos_rpi2-9.4.img.xz

I have not yet tested it myself, but plan to do so.
Curious about your experiences.

In case others are looking for it, I found it here: https://github.com/home-assistant/operating-system/releases/download/9.4/haos_rpi2-9.4.img.xz

For some reason, they don’t have it documented on the RPI installation page.

I got it. Thanks for the link to the 9.4 release version. I could make it run on my Raspi 2.
The steps I followed were:

  • download the image from the link given.
  • put the image into a SD card, with the Raspberry Pi Imager (double click on the image downloaded).
  • switch the Raspi on, with the SD card inside, so the OS get installed and selfconfigured. (tons of patience, because due to the limitted hardware of the Raspi 2, the installation is very very very slow).

I previously didn´t know that Home Assistant do not provide a “graphical interface” (desktop) as other Raspbian distros, so… although I was waiting with a monitor plugged to the HDMI interface of the Raspi 2… nothing seems to be happening…
Finally, after couple of hours, I tried in another computer linked to the same network of the Raspi wiht http://homeassistant.local:8123… and… It worked!!!

After that… I started playing wiht the add-ons and so on…

I only wanted to say thank you to all the tips and guidelines.


What is the minimum space in the SD card to install home assitant???, is it also 32Gb???

I could never get any of the HAOS images to boot on an RPi 2B, and I gave up and flashed a Hypriot image that booted without any problem, then used the HA Docker image, and I was up and running in no time.
I get that the OS offers some more features (which I am not sure I need) but the fact that none of the images were able to boot was a lot of time wasted…

Just manage to install on my old Pi 2B (after scratching my head for an hour trying to understand why it didn’t boot then realizing it was a Pi 2 not a Pi 3:-)).
You will find all realeases here:

I managed to load the latest (now 10.5) by browsing through the releases until I found the pi2 image. Loaded the SD card using the official Rasberry Pi software. Then it took ages to boot, but it’s now up and running.

Not overly worried regarding the performance as it will just be used for one or two generic thermostats in our cabin.

Only drawback so far is that you cant install the Studio code server add-on due to incompatible HW but I can manage with the standard file editor plug in.

But for my home? No way:-) To many things running on it, it would never cope with the load.

Hey @moelito,
just checking, how much time are we talking about? A few minutes or hours? Can’t seem to get it to boot…

Well, about an hour if I recall correctly.