What is the preferred way to rename z-wave entities?


#61

Correct! This is why they are showing up unknown. The basic functionality might work without a full definition if they are simple switches.

I have some Leviton switches that are light that; and do not need any custom definitions.


#62

Also take a look in the configuration/integrations/zwave tab of the web UI to see what it lists for devices.


#63

Thanks for pointing out the new menu option, it only import les then half of my z-wave devices.
Also the history is still not recording, so my z-wave Neo CoolCam devices is not working.

I have setup a new Pie, so I can start from start. First I need to figure out how to manage the z-wave devices properly.

I would have preferred one menu option e.g under config/customize where we could modify all the values.
z-wave node information is now spred out in several files/database and one node can consist of many entities.
It would be nice to see this informaiton as a merkel tree with easy edit of the individual entities.

Do you know where I find manufacturer_specific.xml in hassio?
I have tried Configurator, but it won’t start anymore after a couple of versions ago.


#64

One info to the „changing via UI is more consistant“
If you changing the entity ID via UI and using a (by mistake) uppercase letter, you will break the entity ID and you are not able to rename this ID again. You have to go the the .storage/entity registry…
Wow I hate this new registry shit so much…


#65

Yes, the upper case thing is tough; particularly if you had devices named with caps before in the Zwcg*xml file and then it auto-imports them and screws up the .storage/device/entity by doing so…

So make sure your zwcfg*.xml “names” are all lower case!!


#66

Just do a find / -name manufacturer.xml from the command line.


#67

I have to toss in my thoughts here.

With the above mentioned changes, the ZWave platform has suffered a severe regression.

It is a core concept of zwave that a device has entities. It does not make sense for a device’s name to not propagate down to it’s entities.

Additionally, I have several ZWave plugs that measure power. These create a switch component as well as 5 sensor entities related to power monitoring. That would be absolutely insane to maintain long term as they are moved about. For example, I have one that I use for random stuff I want to be able to control remotely short-term. It’s been used for an extra fan, humidifier, Christmas tree lights, etc. I renamed that zwave node each time so I could find it easily. This is not possible, and would require multiple edits that allow for human error 7x over.

Finally, I have multiple devices of the same kind. For example, I have 12 of the GE 14291/2 dimmers/switches, and 10+ of the monoprice generic plug in switches. If I open that zwave network in OZWCP, all of those devices are indistinguishable from each-other. Additionally, this is a problem should the entity registry become unusable, or re-use is not desirable. The first case is obvious: corruption, accidental deletion, etc. The second matters when attempting to run a second installation of HA (such as for testing a new version when breaking changes affect you. Previously, since ZWave node names were in the zwcfg file, that wasn’t a problem.

I don’t want to be overly dramatic, but the first rate support of ZWave in HA was one of the biggest reasons I picked it over the likes of other options. I would hate to see one of my biggest draws to this project over other OSS options eliminated over a desire for consistency within a new feature that isn’t even finished yet.


#68

Are you saying that I should not touch my zwcfg_*.xml file? I have done that in the past when I want to rename a zwave node when I didn’t get it to work from the zw config in HA. Now I can’t even find the option in the zw config to rename node anymore.

Another question I have is related to rebuilding the zwave mesh. I have recently added a couple of smart plugs and they work fine, but looking at the node info they don’t report any neighbors!!


#69

That functionality was removed in ~V0.76.

I’m not sure what the interaction is between the new entity registry system and the xml file. I don’t know what will happen if you edit the xml file now.


#70

I’ve not had much luck editing the zwcfg*.xml file, but I also have never had my sensors and other z-wave devices drop off so, when I add a new one, it is only a minute or two renaming any entities I want to keep and excluding any entities I don’t want to use. Excluding particular entities from being visible has always been per entity. Additionally, my HASS install on the Pi 3 takes longer to reboot than it takes to update entities via the UI (which does not require a restart for entities to update).
It is a different way of doing things, but I personally feel that the less mucking around we have to do in xml and yaml files the better. It’s quite easy to mess up. I find the UI quite easy to use for managing things.

Also, remember that in OpenZWave, the zwcfg*.xml file is a cache file and OpenZwave could overwrite this anytime, changing every value in it back to the defaults from the main OZW config files for the device.


#71

I’ve never needed to modify the xml file either that I can remember.

However, I have needed (or more correctly, desired) to modify my z wave node information on the Z wave controller to make it more human-readable-friendly just in case I ever had to switch my installation to some other platform. It used to be easy to do in the OZWCP in HA. Now we can’t do that any more. At least directly in HA.


#72

@finity
That is definitely a valid point.
I guess from a “user friendly” perspective, basic home automation users would only use HA and not swap between multiple systems. That is more a tinkerer/hobbiest thing to do.

I guess you still need to run OZWCP separately to do that.


#73

It’s a shame that the rename functionality is gone, i really like to name my z-wave entities according to my own scheme.

After some tinkering i managed to replicate the same result as before, it involves editing the core settings files and the zwcfg file manually so it is probably not recommended.

This is how i did it.

  1. Add device via home assistant as normal
  2. Shut down home assistant
  3. Edit the zwcfg file, find the newly added node and change the name tag to desired name
  4. Remove all occurrences of the new node from the entity registry, i removed everything inside the braces.
  5. Start up again and the entity registry should repopulate with new entities with correct name from zwcfg.

At least this worked for me, and again, it would be nice to get the functionality back that we used to have since this is quite cumbersome.


Migrate z-wave to other device, can I still go back?
#74

Since restarting Home Assistant can take a while on a Pi, next Zwave device I add I’ll try this method:

  1. Add device via HA UI
  2. Verify device added
  3. Stop ZWave network via HA Zwave panel
  4. Modify zwcfg xml file with changed device name
  5. Start Zwave network via HA Zwave panel

My theory is it’ll work and save me time from restarting the WHOLE Home Assistant application.


#75

I don’t think the entity registry gets updated on zwave network stop and start


#76

Might since a new device gets “discovered”, won’t know for sure until I’m able to try it.


#77

I wish to second this sentiment…

We need to find a way to integrate the Z-Wave rename into the overall renaming process or at least to reinstate the wave renaming that used to exist. Having Z-wave nodes with identical names at the openzwave level is just too confusing.


#78

Good luck with that. I’ve been complaining about it ever since the stuff with the entity registry for z wave started and it made it worse when they removed the rename node functionality. And I’ve been completely ignored along with all the others who have voiced their dissatisfaction with it.

Ya know I understand its “their game” and all but I don’t see why there can’t be some small compromise or some kind of “official” explanation to at least TRY to get us to understand why it HAS to be this way.


#79

Or at least have the UI trigger the zwave rename function when the name is changed for the registry entity bit.


#80

I just wanted to add a new power plug to my Zwave network and found out about this problem (15 subentities…). Reading this topic I get the impression that this issue is flying under the radar completely even though one of hass’ prime features is now unusuable for new users and hardly usuable for others.

Do we have any clue who to contact for this? The solution is obvious imo, return the old renaming system and only remove it once a proper replacement is ready.