Where do I have to move the text so that it is executed with Assist?

Hello.
So far I have implemented my voice input as follows.
I have assigned a button on my Android phone (long press on Volume Up when the screen is off) so that the Google voice input translates a text and then sends it via Tasker (Android app) to my Home Assistant in a variable.
I then used Node Red to evaluate this sentence and execute the corresponding commands.
This all worked very well, but each sentence had to be handled in Note Red.
I would now like to switch to the Assist function as well, as it is much more flexible.
However, I would like to keep the function on the mobile phone so that I can enter a voice command when the screen is off.
Is there a variable or entity where I need to store the sentence in Home Assistant so that the voice input via Assist works?
I can also enter a command for Assist via text input in Home Assistant.
So how can I enter a text for Assist from “externally”?
It’s probably that simple, but I haven’t found anything on how to do it.

Best regards Monika

Is this helpful? I am pretty sure it does not require Tasker.

Hello,
Thank you for the quick reply.
I have already tried this with it. However, I can’t get the function to be assigned to a button on the mobile phone. Besides, I can only type in the text there and not speak. The microphone does not appear. Only the text input appears after the question "How can I assist?
Greetings Monika

You’re mixing two different things here, let’s do it one by one. But for both a little more information might be necessary. :slight_smile:

The first problem is the app, if configured correctly (and all working as it should), you should be able to open the assistant overlay by clicking on “Assist” in the companion app top right corner (three dots). The default is set to “open and speak”, so your mic should light up.

As this seems not be the case for you, what exactly does it do? Please describe in detail what happens, eg.

  • open the app
  • click on the three dot menu
  • open Assist

You get the idea. :slight_smile: And while we’re at it, please provide some basic info about the app, like installed version and so on. Ideally you could provide some logs from the app. Go to the app settings, there you’ll find the logs. Maybe restart the app, try the Assist and then copy the logs for this period.

The second problem is the wanted function to assign a button to this. What I found via a quick Google search, this should be easily possible. As soon as the HA companion app is working as expected, you can asign a task to almost everything to start the default Assistant on the phone. As you can set the companion app as your default Assistant, you can then call it via Tasker in different ways.

Let us know about the app and we’ll see where it takes us. :slight_smile:

Also the companion app can now be configured so that it acts as your android assist app, ie when you hit the magic android keypress which would normally fire up google assistant (in my case it is the on/off button) it fires up the HA Assist function.

There is a whole blog post and corresponding thread Year of the Voice - Chapter 3: Ready when you are - Home Assistant

Hello.
No, the microphone does not come up for me when I click on the three dots in the app.
This is probably because I haven’t configured anything in the “Speech to text” settings for Assist in my Home Assistant. I don’t really want to, because my Raspberry Pi on which Home Assistant is running is not connected to the internet.
That’s why I wanted to translate this via the Google voice assistant on the mobile phone and send it as a text command to a Home Assistant via Tasker from the mobile phone.
I just don’t understand where I have to put it in Home Assistant so that Assist can process it.
I hope I was able to explain my “problem” in a way that people can understand.
But thank you very much for the feedback.
:see_no_evil:

I think you want the conversation.process service.

1 Like

Thank you very much. Conversation.process was what I was looking for.
Kind regards
Monika

1 Like

Great you got it working. :+1:

It’s customary in this forum here, to mark the helping post as solution, so please take the time and mark @nickrouts post as solution. :slight_smile: It just makes it easier for future users to see, if the question was answered and solved.

Thanks a lot and have fun with Assist! I do love it, it’s such a great feature :wave:

Thank you for pointing this out.
How do I do that? I don’t understand where I can mark the post as a solution? :flushed:

Not a problem at all! :slight_smile: If you don’t mind, I’ll just forward you to this topic #21:

:slight_smile:

I don’t like to say it, but when I click on the three dots, I can only bookmark the post. The checkbox to mark the entry as a solution is not present.
:see_no_evil: :hear_no_evil: :speak_no_evil:

1 Like