Where is homeassistant hiding?

Sucess although it prefferred
sudo apt install python3-dev

Iam now starting HASS

1 Like

With your latest revision, do you think I would not needed to install those addition items?

Home Assistant installation was successful. I logged into the web interface and am ready to start configuring.

You Sir are a gentleman of high standing. Your patience with a noob is awesome. I am not a Linux expert, but I do believe that this experience has contributed to my understanding. I only hope that I can be as helpful to others.

All the best,
Kerry Rock

1 Like

Hard to say off the top of my head tbh.

Glad you’re up and running :+1:

I finally got back to this install to set up auto starting and got an error on this command.

[email protected]:~$ sudo systemctl enable [email protected]
Failed to enable unit: Invalid argument

I wondered why there was a “-” between home and assistant, so I removed it and got this:

[email protected]:~$ sudo systemctl enable [email protected]
Failed to enable unit: Unit file [email protected] does not exist.


Did you create the file as the documentation says?

As @flamingm0e says it looks like you haven’t created the file, instructions are in my post prior to the lines you’ve just entered.

I did create it. Did not show because it seemed to work correctly

Please don’t post photos when you can copy and paste code.

There is an x at the end of your final line. It doesn’t seem to be there in the example.

1 Like

Well done eagle eyes. I can only assume it was caused by a poorly time ^X. My bad. Thanks

The guide provided the following steps
To have Home Assistant start automatically at boot, enable the service.

$ sudo systemctl enable [email protected][your user]

To disable the automatic start, use this command.

$ sudo systemctl disable [email protected][your user]

To start Home Assistant now, use this command.

$ sudo systemctl start [email protected][your user]

So I did this:
[email protected]:~$ sudo systemctl enable [email protected]
Created symlink /etc/systemd/system/multi-user.target.wants/[email protected] → /etc/systemd/system/[email protected]
[email protected]:~$ sudo systemctl start [email protected]:~$ sudo systemctl --system daemon-reload
[email protected]:~$ sudo systemctl enable [email protected]
Failed to enable unit: Unit file [email protected] does not exist
[email protected]:~$ sudo systemctl enable [email protected]@orangepizero
Failed to enable unit: Unit file [email protected]@orangepizero.service does not exist.

Apparently I do not understand what is required for

[email protected][your user]


Your service is home assistant running as a home assistant user. It’s not running as klrock.

it’s the user called homeassistant that you ran all those commands for and that you created the service for. Its the user that runs the service and the user that owns the venv and the config

That was the correct command, as evidenced by the reply you got in the terminal…

Then you tried

Looks like you copy and pasted it from some guide or other and picked up an extra load of text, hence why it didn’t work. What you wanted was…

sudo systemctl start [email protected]

If you look up at my original post with all the steps that got you this far, that is the command I typed.

All the other stuff you then went on to do, I have no idea where you got that from. Please please please don’t keep running off to use other guides, just follow one set of instructions from start to finish and make sure that you follow each step correctly. If something doesn’t work, double check that you’ve done the step correctly and then come back here and paste the error.

Different guides may follow a completely different way of doing something that may be incompatible with the last one you tried. Hence why everyone is pointing you back towards your Linux books, so you can spot the difference :slight_smile:

In any case, the enable command worked, so next time you start or reboot the device homeassistant will be running in the background, so long as something else you’ve done since hasn’t disabled it :+1:

After getting homeassistant installed and started, I did a small part of the configuration, then left it running two days while busy with other stuff. When I came back, the interface was still open but displayed “connection lost, trying to reconnnect”. I left it that way for a few hours and then closed the browser page and opened it again, but it has now been collecting data for several hours.

I was able to SSH into the Orange Pi Zero and attempted to start Samba found I need to learn a lot more before I can use it.

Still need to get the interface running again, but out of ideas now.

How did you install homeassistant?

Why did you create another thread with the same name as the one we were already working with you on?


I searched for the same name and could not find it, so I started a new one thinking it would be recognized. I apolgize if that created a problem.

I flashed my Orange Pi Zero with ARMBIAN 5.59 stable Ubuntu 18.04.1 LTS 4.14.65-sunxi. and executed the following list of commands provided generously by m> Social:

[email protected]:~# sudo apt-get install python3-pip python3-dev python3-venv

[email protected]:~# pip install awscli

[email protected]:~# apt install python-pip

[email protected]:~# sudo apt-get install build-essential libssl-dev libffi-dev python3-dev

[email protected]:~# pip3 install wheel

[email protected]:~#  sudo pip3 install --upgrade virtualenv

[email protected]:~#  sudo mkdir /srv/homeassistant

[email protected]:~#  sudo useradd -rm homeassistant

[email protected]:~#  sudo chown homeassistant:homeassistant /srv/homeassis

[email protected]:~#  sudo usermod -aG dialout homeassistant

[email protected]:~#  sudo su -s /bin/bash homeassistant

[email protected]:~# cd /srv

[email protected]:/srv# sudo chown homeassistant:homeassistant homeassistant

[email protected]:/srv# sudo su -s /bin/bash homeassistant

[email protected]:/source /srv/homeassistant/bin/activate

[email protected]:/pip3 install --upgrade wheel homeassistant

[email protected]:/srv$ cd /srv/homeassistant

[email protected]:/srv/homeassistant$ python3.6 -m venv .

[email protected]:/srv/homeassistant$ source bin/activate

(homeassistant) [email protected]:/srv/homeassistant$ pip3 install homeassistant

[email protected]:~$ sudo systemctl enable [email protected]

[sudo] password for klrock:

[email protected]:~$ sudo systemctl start [email protected]

[email protected]:~$

have you just tried restarting the service and looking at the logs to see if it fails?

Threads merged

1 Like