Why is this so difficult?

Stibbons, yes you took the words out of my mouth. But with a lot more words. Lol

Please don’t get me wrong anyone. I absolutely appreciate the Devs and Community for what you all do for this platform. It’s awes and better then anything out there. And the price is perfect! I don’t or didn’t expect this to be a easy journey I just have gotten frustrated and wanted to see if I was the only one.

You guys do a fantastic job here. And I really do appreciate you all!

@ Flamingm0e - I’ll have to search and learn how to do that.

Is there a reason why my Wemo switches disappeared after being there?

I only recently started with HA and Hass.io myself, and I can totally understand you. At the same time I think it’s very exciting and rewarding once you acutally learn something and get stuff up and running. I currently consider home automation rather a hobby than a necessity - this might certaintly change once I am more experienced and have spent more on stuff to automate - but this mindset helps me a lot.

1 Like

Thanks for the shout-out @aidbish . Here is a link to the direct post on my site.
https://www.vcloudinfo.com/2018/02/journey-to-docker.html
There is also a link above to all my smart home articles on the site as well. Glad you found the move to Docker great. I agree that there is no turning back! :slight_smile:

I don’t think you have answered the question about whether they appear in the states page of home assistant. (Click <> in the side menu)

Sorry @nickrout I’m still at work and I don’t have remote access (I finally will tomorrow as my isp finally gave me a static IP) but I don’t believe they are showing up. Other then maybe the Wemo devices.

This is NOT normal and indicates an inadequate power supply or SD-Card.
2.5 amp is minimum for power on a Pi3 and I got a 3 amp one. Also using a 32gb Samsung EVO Plus SD-Card and have ZERO issues with anything like this.

1 Like

It’s not a power issue, I restart because of the added automation and/or script doesn’t show up in my UI but will show up in HomeKit and work if configured properly

Something must have gotten entered in my YAML configuration that blocks the UI from displaying my items.

I’m going to try to start over from the beginning and work slowly adding information back in to see if I can catch anything

I think we went through the EXACT same thing. Download ftp from BoM and parse the xml. I tackled it every single way I could think of, even installing the SSH add-on and ‘SSHing’ back into itself. I beat it do death and it still wouldn’t work so gave up :slight_smile:

I managed to get PTV API working pretty well and was a fun experience using the RESTful sensor.

I agree with Tekki. If you have full control of a system, then use the guide he linked to here to install HA in a virtual-env on any server.

I wrote a little wrapper script that I find useful to help me manager my homeassistant setup. One thing to note is that I put my HA venv in /srv/homeassistant when setting up, but the mv’d it to /srv/homeassistant-current. I then setup a symlink /srv/homeassistant -> homeassistant-current. I did this to make it easy to manage backups of my homeassistant install. Also, my HA config files are in /etc/homeassistant.

When starting out, do something simple to start, like turn on the lights in the living room at sunset. I copied the dim lights when media is playing example into my configs early on and they are still in there. :slight_smile:

I find HA was relatively easy to pick up, but I already had knowledge of yaml and jinja templating from deploying servers with ansible, so perhaps I had a leg up. My configs could be better, but they are online here. The examples really help.

command_line sensors are not really tricky… They are essentially “run some command to return a value.” I use the following to grab a value that I use to create a graphana graph of my computer’s uptime:

- platform: command_line
  name: 'Grater uptime'
  command: cat /proc/uptime | awk '{ print $1 }'
  scan_interval: 60
  unit_of_measurement: minutes
  value_template: >-
    {% set uptime = value | int %}
    {% set minutes = (uptime / 60 ) | int %}
    {{ minutes }}

For device tracking of phones for automations, I have found OwnTracks to work reliably quite well. I set up the very simple via http setup and then just paste in a URL into the OwnTracks app on the IOS device.

@GervaisdeM If you know Ansible you can use it to manage your Home Assistant too, especially to create, update and check config files.

@Tekki
I use ansible to setup my home servers, but I like keeping my config file in git. :slight_smile: I know that I could ansible to pull from git, etc. Since I am the only one working on these files, I just edit them in place with vim and push to git directly from the server where I run HA.

I finally figured out how to get the entites in the UI! Awesome one issue down!

1 Like

I totally agree here that the install flavors make things complicated. I already had esxi running on a low power server 24/7 so I went with install on Ubuntu for a while. Upgrading / backup / restore was a pain (especially the time I forgot to take a vm snapshot and a breaking HA version jump killed my zwave setup). And that other time when HA required higher python version and wouldn’t run at all after upgrade.

So then I looked for a better way. Not a coder or a sysadmin, so the choice between hassio, virtualenv, and docker was far from obvious. Went with docker after reading the getting started guide on dockers website for a couple of hours. So far happy with the direction and believe error HA devs should promote this direction.

But, someone more knowledgeable than me should put together some sort of table describe install / upgrade options with pro and cons and required skills. I think that would help folks like OP and myself.

1 Like

I agree, I love this platform and community.

I’m slowly coming along. Trying to tackle one issue at a time!

I am an IT “Professional” too, but other than maybe knowing my way around Linux, it was of little help. To your point, patience and determination is key. Do you know how may times I mess up my YAML syntax? A lot. Still my HA is really powerful and its stable. I made a post the other day about this very thing. People complaining about HA/Hass.io, etc. I wonder how long they have been trying to use it be they get frustrated? 1 day, 2 days, a week?

Be patient everyone. I assure you if you are serious about home automation, and especially if you want to do custom things with your smart home, you won’t find a better solution.

2 Likes

i really can see the point from the hassio verus non hassio making things confusing.

on daily basis i helpout people here mostly with Appdaemon and HADashboard.
I always have to check for every question that isasked if they use hassio or not.
an if they do i need to dissapoint them sometimes, because not everything is possible in hassio, what is possible in a venv or docker setup.
and it is to bad that that isnt well documented. yeah there is a page telling why hassio is so great, but to give people a real choice the disadvantages should also be mentioned.

searching on the forum also got worse after hassio got included. because there is a big dfference between an addon or the other ways thins are installed. but they show up because yu look for a certai keyword.

i think hassiocan be very good for a lot off peole, bu i think its also confusing or difficult for ohers.

1 Like

My collection of command_line sensors to parse weather forecast info out of BoM feeds don’t work because hass.io doesn’t include xmllint - basically the exact same situation @BrendanMoran described.

I think this is a common misunderstanding. Hassio does not run Linux or have access to a full shell to run typical Linux commands. This is really the only difference between Hassio and the other install methods.

If you want Linux and access to a full shell, then you want Hassbian. If you are using Hassio then things that use a Linux shell are not going to work. That is really the only “limitation” of Hassio though, but it’s just because they run two different operating systems under the hood.

I do not work in IT - actually I am in the arts which has nothing to do with computers - and I really enjoy tinkering with all this stuff. So it is possible if you are not a technical user :slight_smile:

1 Like

dream on.

installing and using third party python libraries with hassio is also not easy possible.
default dirs created by appdaemon are relocated and not accessible (for instance the compiled dir that appdaemon uses to create HAdashboards is just a link, and its almost impossible to clear the files below that dirs)

and thats just 2 simple things i run into lots off times.

what you actually say is: the only thing that is different between windows and linux is that you dont have linux when you run windows. :wink:

there are many things you can do in other installs that you cant do in hassio.
but you can say the same for windows.

like windows, hassio is a restricted platform for people who dont want to tinker a lot. thats not a problem, but it needs to be made clear to people that those restrictions exists.

1 Like