WHY THE HECK can't we freely configure a Cover to interpret its percentage value as "percentage open" or "percentage closed"?

And even though it is doable with templating - I have 20 cover entities and that is no fun to do 20 times over. Besides the fact that I then have 40, half of which behave opposite to the others.

I understand you. I just showed one possible solution, how it can be implemented at the moment. I would also prefer a better method.

Maybe you can do this in a blueprint.
You can for sure hide the unused (non-inverted) entities (since 2022.4).

1 Like

Hi Matthias,
i successfully tested alexa with a cover. If i say “alex set cover xyz to 80” ( DG Rollladen Studio rechts
cover.rollladen_dg_studio_rechts home assistant) the cover will close to 80%. I used the inverted entity. :slight_smile:
I am pretty sure it is also working with home kit and google home

BR Branimir

1 Like

And if you say “close cover” or “open cover”? Afaik some translate this internally to a percent value instead of calling async_clise_cover() - and I would guess it wouldn’t know of inverted positions :thinking:

Perhaps this works:

create a cover that does nothing. After that create a routine that close the cover to xx%
Then create an automation with the trigger close cover and condition close cover to xx%
?

Edit: Ok i found a solution with node red that actually works with alexa. Working commands are
Alexa set xx to yy %
Alexa close xx
Alexa open xx

The service i call is my inverted cover helper “cover.dg_rollladen_inverted”

I used this plugin node-red-contrib-virtual-smart-home (node) - Node-RED
Now i would like to test the plugin node-red-contrib-amazon-echo

Thnx Brainjay! I use z-wave and somfy RTS for my covers. I’m going to try this solution. But as you said, a built-in solution would be easier. I have only 4 covers were I need to have them inverted. But it’s a lot of code and hassle if you have a lot more covers. So still voting for my feature request :slight_smile:

1 Like

Thanks so much, I inverted my Luxaflex Duette Top Down cover and now the arrows perfectly represent which way the Duette should be going :slight_smile:

1 Like

iBlinds (Z-Wave) v3 have that now in their newer motor’s firmware…

Reversing the blind motor interpretation is available in pretty much any blind, but is is not meant for fixing unintuitive UI. I want my blinds to go up when I tell Google to do so, reversing the option would break things there. The request is about how percentages should be interpreted. I do not like the fact that I currently have 21 template covers to complement the 21 actual covers that do not operate the way I’d like them to. As this is somehow different for all, it should be configurable. It all has to do with how you see blinds, as a way to keep light out or a way to let light in. To me blinds keep light out, so 100% should mean 100% blinded to me. As it stands, 100% is now 100% unblinded.

The situation is probably even more obvious when using top-down bottom up blinds. Those have a top bar and a bottom bar, each needing a cover control. But when the top bar is fully down, the window is totally uncovered, letting all the light in. For the bottom bar it is the other way around. It would not be so strange to have the top bar percentage be reversed of what the bottom bar percentage does.

2 Likes

I agree. You should not have templates for this goal. The current implementation is not correct.

But I don’t understand why it is still not changed and make configurable. I think it is a small change.

This post was flagged by the community and is temporarily hidden.

2 Likes

Bump. Really a fundamental config imho

so I tried to implement some workrounds from this thread

I have both problems in my setup… some show 0-100 reversed, some had inversed buttons.
However eithe:
→ I could change the slider: 0% = open, 100% = closed → fine
→ the actual buttons do the right thing. up = open, down = close → also fine

But:
After I inverted the slider or the buttons … the standard ui element greys out the correct action
So in below screenshot the blind is open, slider shows 0%, the buttons do the correct action
BUT the button for Down / Close is greyed out
image

is there a solution for this?

    zw_blind_4_invert:
      device_class: shutter
      friendly_name: "Raffstore Theke (ZW Blind 4)"
      position_template: "{{(state_attr('cover.zw_blind_4', 'current_position') | int)}}"
      tilt_template: "{{(state_attr('cover.zw_blind_4', 'current_tilt_position') | int) }}"      
      open_cover:
        service: cover.close_cover
        data:
          entity_id: cover.zw_blind_4
      close_cover:
        service: cover.open_cover
        data:
          entity_id: cover.zw_blind_4
      stop_cover:
        service: cover.stop_cover
        data:
          entity_id: cover.zw_blind_4
      set_cover_position:
        service: cover.set_cover_position
        data:
          entity_id: cover.zw_blind_4
          position: "{{position}}"
      set_cover_tilt_position:
        service: cover.set_cover_tilt_position
        data:
          entity_id: cover.zw_blind_4
          tilt_position: "{{tilt}}"

thank you !