Window open, climate off

Thanks for your answer. Can you please share the information of the climate entity (ip:8123/developer-tools/state)? Are you using Homematic IP? Please tell me the model of the Homematic Thermostat.

Can you please share the information of the window sensor (ip:8123/developer-tools/state)?

  - auto
  - heat
  - 'off'
min_temp: 4.5
max_temp: 30.5
target_temp_step: 0.5
  - boost
  - comfort
  - eco
current_temperature: 24.5
temperature: 4.5
preset_mode: none
id: NEQ1514196
interface: rf
battery: 2.9
rssi_peer: -65535
valve: 0
mode: Manual
friendly_name: Livingroom
supported_features: 17

Is that what you are looking for?

The Model is HM-CC-RT-DN and it is not Homematic IP

Here is what I have for my door (window) entity.
friendly_name: Patio Door
device_class: window

hope this helps.

Yes, exactly! Actually I do not have a clue what is wrong. It has the necessary HVAC modes as well as the right mode (Manual). My question is: Why do “Homematic” devices do not react to the services to climate.turn_off (if it is on) and climate.turn_on (if it is off)? (Please double-check again before proceed!)

I have absolutely no experience with Homematic besides it is a very popular system in Germany. Therefore, please ask some Homematic users, how they are experiencing and handling Homematic Climate devices and forward the information to me.

Of curse there are several ways to control the climate. On the other hand this blueprint is aiming to be a general solution for all climate.* entitys in HomeAssistant. If there is NO other solution to it, I would recommend designing a special Blueprint just for the Homemtic users.

Thanks. Also here I do not have an idea what is crashing the automation. It looks fine so far as you are having the device_class: window. It could be a problem with the Konnected Integration or the climate.entity you are using.

As Home Assistant has a brilliant new feature please have a look at the new automation trace debugging feature and share your information. You will find a new symbol to each automation that directly brings you to the new feature.

@duesseldorferjung Please also share your automation trace. Thanks

Is it helpful like this?
And I double checked. Climate turn off work just Climate turn on doesn’t work.

As expected the problem is on the “Homematic” integration side. I did some research for you and found out that the behavior you are experiencing also report other HM users. Please read this topic: Getting Homematic Thermostats (HM-CC-RT-DN) into Google Home
It refers to a home-assistant/core issue: Homematic thermostats can't be adjusted with Google Assistant · Issue #17742 · home-assistant/core · GitHub
And there is also a workaround to get it working: Getting Homematic Thermostats (HM-CC-RT-DN) into Google Home - #5 by infernix
I highly recommend doing the modifications manually or open an issue on GitHub. As more than 80% of climate.entity in Home Assistant can handle climate.turn_on/off please perform modifications on your side rather than on this blueprint side. Thanks!

Hi @SmartLiving.Rocks and thanks for this great blueprint!

I’d like to kindly ask if it’s possible, to add another (optional!) „custom action“.

I have few TRVs which don’t work by setting hvac mode (they automatically switch back to auto after few minutes with the windows still open…), instead I need to set the temperature for the valve to close (by e. g. setting target temperature to 7 degrees Celsius).

Would be great to have this option in this blueprint. :slightly_smiling_face: :+1:

If not by adding a custom action, maybe as direct options:

  • „Window open target temperature“
  • „Window closed target temperature“ (not sure how to save the one set before running the automation and restoring that value)

Thanks for the research I will test and cofirm.

1 Like

Hi, this blueprint is designed for general purpose and not for - as you mention it - a few corner cases. I think that more than 80% of climate entities are capable of handling the blueprint.

That would mean to replace the service turn_off with a temperature. The chance that the change will stop working is too high.

Yes, the most challenging part is to save the temperature in a variable. I think an additional input.number helper (that the users have to create manually before they can use the blueprint) would be necessary.

Maybe you can create a workaround like this guy on github. Please share with us the TRV models that are not working.

Hi @SmartLiving.Rocks

I am just passing by to share the results of my tests with your Blueprint.

I used it for a while and figured out it didn’t match my requirement.
In parallel, I investigated arount Templates and found something more suitable, at least for me.
Here is what my automation looks like now:

- alias: as you like
    platform: state
    entity_id: WINDOW
    for: "00:00:30"
  - condition: state
    entity_id: #whatever condition you like
    state: 'on'
  - service: >
        {% if is_state("WINDOW", "on") -%}
        {% else %}
        {% endif %}
    entity_id: CLIMATE

Thanks for sharing this blueprint; it helped as a basis for me

Can you please explain in a more detailed way what your requirements are? What exactly did not work in your specific case and how did you figure it out? I am just asking because the latest response from you was:

I left home and realized afterwards that I did not explain my reasons

While I was testing your automation and some others, I had to restart HA regularly.
It created some strange behaviour on my climates until I figured out that restarting HA kills the delays or waiting phases of any automation.
By introducing the template I shared with you, I got rid of this behaviour and keeps all the benefits of your automation

That is absolutely right! And I have to say that your way is also very smart! :partying_face: I am wondering what condition you are using. How does the automation know what to do in the summer vs. wintertime?

Thank you

I use a manual binary switch as condition. Just as simple as that :smiley:

Exactly what I had in mind.

  1. The binary switch has to be created manually.
  2. The binary switch has to be switched manually in order to know the difference e.g. in summer and wintertime. Of curse, it could also be automated. But there are too many manual steps for a click and go blueprint that makes it easy for non programmers and Home Assistant beginners.

I am very happy and a little proud that my work helped you in your learning curve! And I totally understand your point of restarting Home Assistant. I will change the description and inform the people about that!

Instead of alerting everyone with the issue, wouldn’t it be appropriate to change your automation and use the template?
So far it has no downside and the next will download a new version directly.
Just proposing, this remain your blueprint at the end, you decide

I tried to explain to you that it is not possible as you have to create a “helper” before you could be able to use this blueprint! It makes things more complex and that is an issue! If I am wrong please provide me a working code that I can test. Thanks in advance!

Hallo zusammen,
vielen Dank für die Automatisierung. Funktioniert bei mir soweit ganz gut, aber wenn das Fenster geschlossen wird, geht das Thermostat nicht mehr auf den Heizplan des Thermostat. Es wird einfach nur Heizen eingestellt. Wie kann ich die Programierung anpassen das es nach dem Schließen des Fensters wieder auf den Heizplan schaltet? Als Thermostat nutze ich Tado und die Fenstersensoren habe ich von Aqara. Leider habe ich hier nichts passendes in den Dokus gefunden.
Beste Grüße

Hello, everyone,
thank you very much for this blueprint. Works pretty well for me so far. But when the window is closed, the thermostat no longer goes on the heating schedule. Heating is simply set. How can I adjust the programming so that it switches back to the heating plan after closing the window? Tado Thermostat and Aqara window sensors. Unfortunately I didn’t find a solution in the documentaries here.

Best regards

1 Like