Wyze Cam V3 - RTSP works!

Answering my own question… I added this to configuration.yaml:

# REST_command to refresh wyze-bridge camera snapshots
rest_command:
  wyze_snapshot_cam:
    url: "http://localhost:5000/snapshot/back-yard-cam.jpg"

Restart HA.
Then (from the HA GUI) created a script to call the above service, and added the script to the HA lovelace dashboard.

Is there a way to arrange the order of the cameras? I have 8 cameras and they are all detected and working fine but they seem to be ordered in a random fashion and I can not figure out how to re-arrange them.

Where? How are you showing them? Frigate? Lovelace?

Just in the Docker Wyze Bridge?

Can’t help you- I’ve never used the Wyze Bridge. Didn’t even know it was a thing.

Very first post on this thread will take you to it.

Looks cool, but I am not running Docker anywhere.

I am trying to get my 6 V3 cams and 2 Pans to work with RTSP as internet goes down often in the part of the world I live in. Nothing happens when I click on the RTSP under the Video Streams but the RTSP Snapshot works fine? I take it I am missing a step in my setup?

Did you flash the cameras with the RTSP firmware from Wyze?

No need to flash that with the Wyze Bridge. See video: https://youtu.be/YZVJ1yvdobE?si=lAJB-o-6peg7L78v

Anyone on here that has the Docker Wyze Bridge setup in HAos and has the RTSP feed working?

Yes. What’s your compose.yml look like for your wyze-bridge?
Does http://192.168.0.199:5000/ work?
When I run rtsp://192.168.0.199:554/driveway from my browser, it launches PotPlayer and streams the video from V3 cam. Note I have mapped port 8554 to port 554.
My HA and wyze-bridge are running in docker on a raspberry pi 3b.

1 Like

Not showing a compose.yml :frowning:

Yes the http://192.168.0.199:5000/ is working but the RTSP does nothing there either.

So l think I am missing a step?

Well I’m not an expert on this but on my rpi 3b, sometimes the stream does not start, an I have to retry again after some time. This is especially true when I have several cameras taking snapshots or streaming. It seems like rpi 3b cannot handle the load. It may help to ensure you don’t have other browser windows open trying to connect to the camera too.

One thing to try is use the VLC application on your laptop, select “Open Network Stream…”
Then enter rtsp://<HA IP address>:8554/<your camera name> as the network URL.

The wyze-bridge (from calling docker logs wyze-bridge) log shows something like this:

[WyzeBridge] 🎉 Connecting to WyzeCam V3 - Driveway on 192.168.0.150
[driveway] 📡 Getting 180kb/s HD stream (H264/20fps) via LAN mode (WiFi: 98%) FW: 4.36.9.139 🔒 (DTLS) (2/3)
[driveway] WARNING: Skipping smaller frame at start of stream (frame_size=1)
[WyzeBridge] ✅ '/driveway stream is UP! (3/3)
[WyzeBridge] 📖 New client reading from driveway
1 Like

Can this bridge be installed on proxmox, just started using proxmox so still new…

Thank you hassiopi for that test tip! Yeah I can grab the rtsp feed just fine in VLC. So does that mean my Computer running the HAos just can not handle the 8 camera load on my network?

I tried starting the Wize Bridge and get a failed to start error, Port 8888 in use. Anyone know what to change it to?

Technically you can use any unused port.