Z-Wave controller unable to include/add any new devices even after a factory reset

The short-ish version:
My previously working Aeon Labs Gen5 EU Z-Wave stick is unable to include/exclude any devices via HA controlled Software. This seems to be true for both the old ZWave config and the new OZW Beta setup. The stick has been reset to factory defaults and still does the same. But manually doing inclusion/exclusion via the stick does work. The new nodes show up, but end up stuck in Probe status. Actually interacting with nodes does not produce anything.

Long-ish version with some history.
I suspect my Z-Wave stick is somehow broken in a weird way that makes no sense. Stuck in read-only mode? (which to the best of my knowledge doesn’t exist).
My Z-Wave installation has been semi-working for a long time in my HA setup, but has been neglected for a long time, and was suffering misc issues. I have 4 Neocool plugs (mains powered), 2 different underfloor heater units (aliexpress something, mains powered), 10+ Heiman smoke controllers (battery powered) and a couple of door sensors. All running for at least a year or so on a RPI4 and controlled via a Gen5 Aeon labs stick (via usb hub). It was working fine for a long time, but none of my devices were hugely active in the automation parts, mostly in data logging. When they misbehaved they would often be neglected for quite a while. So in the last few months the zwave network was barely working with only a couple of nodes alive, and the rest in a various stages of Probe or Cached-something. I could never really get it fully operational, but never put too much thought into this. Then 0.114 came out and I wanted some mqtt goodness into my zwave network as well as getting this thing sorted out and cleaned out. I had amassed many nodes that had come and gone, so my node id count was getting quite high. And I had one node that I could never find out what it was, but that I could never exclude and get rid of. It was a phantom node that did respond. But it was none of my otherwise working nodes, so I could never figure out what to do with it…
So, I decided that it was finally time to dump this whole thing and start from scratch. I knew that this is messy at best with a zwave network, but still a whole lot better than trying to clean up what I already had.

So I factory reset the controller, and with an upgraded 0.114 installation (venv), and ozw beta in a docker container I got started trying to set up a new network. But whatever I do I cannot get it to work. Adding new devices just doesn’t work. Secure or not secure (none of the devices I have are secure devices to the best of my knowledge, but should fail back to non-secure anyway). I have retained and used the same network key. I have tried to revert back to the old integration, and same story there.
Manually adding nodes via the stick (unplugged) works. When plugged back in I can see the new nodes, but I cannot query it, I get no new info and it seems that it is unable to actually progress in any way beyond what the HW part has done. It seems to me as if the stick goes into some sort of read-only mode for the lack of a better explaination.

So, I am a but confused as to where to go from here. It is not like the stick is clearly broken. It can add/exclude devices - but only in the stick.
It is quite possible that I have broken something somehow - especially with the (pure frustration) factory reset.
I have nothing to lose, but since this was working in my current setup before, and I have tried to reset it and use it in the same env as before (minus an updated HA) I can’t think of a HW change or a config change that would explain this.

Any ideas? Please?


Have you managed to fix this? I have the exact same issues and tried the same things.
Been at it for days and it’s driving me nuts.

Tried including fresh aeotec radiator valves and a (reset) range extender to a fresh hassio instance with a factory reset z-stick 5. Nothing works.

Maybe give this a try

Thanks for the reply but this did not fix my issue.

Are you running the zwavejs addon? Does the addon start and connect to the zstick? Any log errors in home assistant or the add on?

I would make sure the addon has the right path to the zstick configured. Ideally use the path by id. Screenshot where the settings are:


I have checked those things.
I have tried the zwave JS add-on and the MQTT one both on fresh hassio instances.

Both addons are able to successfully communicate with the stick, manually adding zwave devices to the network by pressing the button on the stick works. They show up in Home Assistent as unknown devices. However, the interview process gets stuck with the message the interview has failed because the node is dead.

But when trying to delete the dead node it says it can’t because it responds to a ping (because that makes sense :upside_down_face: ). When checking the controller logs in MQTT it says it drops messages of those same nodes.

When adding a node using the correct include process in home assistant the log says it successfully starts the include process (tried secure and non-secure) on the stick. But it does not react to single node in the vicinity that I have factory reset and put into inclusion at the same time.

At this point I’m 80% sure the stick is in some way broken, I’m ordering the new aeotec zstick gen 5 +.
Thanks for your time trying to help.

I’d tend to agree, but there could be an issue somewhere with the machine itself. What kind of system are you running home assistant on? There’s some conflict with this zstick and an rpi4


You can try a different usb port or plug into a powered usb hub

Also are you using a vm or is hassio installed right on the device?

I am running VMWare ESXi 6.7 on a Dell Optiplex.
Used the VMDK from the Linux guide here Linux - Home Assistant.

The only other thing I can think of is something is going wrong with the usb pass-through to the VM.

I’m not sure if this guide applies to your specific vmware install, but see if you can check on the usb pass through settings. See if you can force usb 2.0 in the pass through vs usb 3.1. I don’t have too much experience with VMs so if anyone can think of anything else hopefully they can chime in.

Hehe, you gave me hope.
Then it was instantly destroyed the moment I checked :sweat_smile:.

The only other thing I can think of to confirm a bad zstick and not a pass-through issue is to try and install zwavejs2mqtt outside the vm or on a different machine. There are a lot of ways to install zwavejs2mqtt (see documentation below) and then as long as it’s installed on the same network it can link back to Home Assistant by the zwavejs integration.


When I get home I’ll just plug the stick back into my laptop and install some controller that’s compatible with windows.

Then I’ll know for sure, thanks for the idea.


Why couldn’t the stupid thing just be broken.

It works now, fresh virtualbox VM on a laptop. interesting thing is it operates/commands the radiator at a speed I haven’t seen before.

well… I have figured it out for now and will spend time trying to fix it in ESXi


I am stuck once again.

Spent half a day updating my ESXi to U3, didn’t fix it.
Then found this and this link which seemed to be appropriate, also didn’t fix it.

ESXi is garbage.

You might want to just run zwavejs2mqtt on a different device. I run zwavejs2mqtt in docker with an aeotec zstick and have had no issues with it. Here’s steps how to.

1 Like

In the Netherlands we would say: “Het is net niets”, street language would be “Net Nix”, what means “It is almost nothing”

I must say this, inspired by your nickname. :smiley:

This is an interesting way to fix it. Will look into it, thanks.

Het werkt ook gewoon net niet…

1 Like

Got this to work on a raspberry pi 3 b. Looks like I’ll have to do a load of tinkering to get back to a decent working situation (names, automation, etc).

Thanks for the suggestion.

1 Like