ZHA Thermostat

Tags: #<Tag:0x00007fc3f3af27b0>

Hi based on my issue above I worked with @Adminiuga to resolve the issue specifically for the Centralite Pearl.

Unsure how non breaking changes like this get introduced into the next releases, but soon it will work as expected. Would love if others want to test a custom_component for a bit to verify its working as expected.

Also, I will be opening another issue to track removing the heat_cool option for the Centralite Pearl, which is a mode it does not support.

My Zen thermostats are reporting the correct states fwiw

Those sure are purdy. I was so tempted, but the price…

I scored three in one lot for $30 a pop on eBay. Brand new. I still can’t believe it. They guy was selling tons of them. He must have been an ex Comcast employee or something.

Edit: just checked. $114 shipped to my door for three white beautiful zen-01’s. I check eBay every now and then because I’m curious if they pop up cheap like that often but it seems I indeed caught a unicorn.

Edit edit: someone is selling them on eBay for $41 right now

My Zen thermostats are running well also. One thing I liked about the old custom component (no idea which version – I had not updated it in a while) was that I could set the heat and cool setpoints regardless of what mode the unit is in. Now it seems the only way I can set the cooling setpoint is if the system is in cooling mode. I liked it better the old way because I only needed one automation for both heating and cooling modes. I could just set it to heat/cool but I really don’t want to have it bouncing between modes without my direction. We have many days where both heating and cooling could take place and I like to have more granular control of when it switches.

Anyway, is this by design or am I missing something?

Old:

New:

I came from smartthings and was used to having strange things happen when pushing set points to these thermostats when not actively in that mode. As of now, I have an automation for coolung set points when in cooling mode, one for heating set points in heating mode, and one to bounce between cooling, heating, or fan only based on environmental conditions. When the mode changes, I fire both set point automations and let the conditions sort it out.

Yeah – I will do something like that. I have had general weirdness with these thermostats but I still like them. I had the same problems under Smartthings so I am pretty sure it is a bug with Zen itself. I have scripts set up to fire whenever a change is made and double check to make sure the thermostat actually accepted the change and retry until it does. I will just amend that to do it depending on mode.

Oh yeah, there’s that whole thing too. I’d say one out of every 6-10 set point commands gets dropped. I always just thought it was me and my flakey mesh.

Yeah they’re pretty but, as usual, you’ve got pay for pretty with a bit of crazy. Small price though for a device that is not cloud dependent.

Does anyone know how to send outside temperature to zigbee thermostat via zha.
I’ve found the following service: zha.issue_zigbee_cluster_command but I can’t find any doc on what are the arg to pass with the command.

What exactly do you mean by outside temperature? Are you asking how to send a command to change a setpoint of a zha thermostat?

If so, I simply use the climate.set_temperature service. Every now and then it fails to go through, but for the most part it works as expected.

On my thermostat display I can see room temperature and setpoint temperature. But it is also possible to display the outside temperature in place of the setpoint temperature. This is a lot better as I can see the room temperature and the outside temperature on each thermostat.
For setpoint temperature change it is easy to change it via the climate.set_temperature service but I want to send outside temperature once per hour or more frequently if possible. So I need something like climate.set_outside_temperature service if something like that exist.
In some documentation I’ve found they are talking about zha.issue_zigbee_cluster_command but I don’t know how to use this. Need more RTFM
I also have non zigbee thermostat that I can send the outside temperature via a python command but I don’t know how to set that in an automation. What service to call ??

Oh man yeah I have no idea. I don’t have that functionality.

I know that SmartThings is implementing this feature for the Sinope ones.
Maybe worth to check the code of this integration

Suggest that you submit a patch or a new seoerate feature request for that function :slight_smile:

Hello everybody,

I have an ecozy thermostat and despairing with the configuration. I was able to pair it vie zigbee to deconz and it appears in home assistant. I can set the desired temperature without problem, but it will not start to heat. The havac_mode is still ‘off’ and I have no idea how to change that. I tried almost every sensible message I could think of. I am trying to accomplish that in Node-Red, but the home assistant thermostat card isnt working either.
In Node-Red I get the error "Call-service API error. Error Message: extra keys not allowed @ data['hvacMode']" Where ‘havacMode’ ist the first part of the text I write in the data field. And the home assistant thermostat card leads to the error Error while calling the service climate/set_hvac_mode. /sensor/13/config/mode parameter, mode, not available (my translation from german).

Can anybody please tell me how to change the havo_mode so the thermostat will heat?

Here a screenshot from tho Node-Red node.

I have a centralite pearl thermostat. Everything works but for one thing. Homeassistant is not able to display the current temperature and is stuck at the temperature when homeassistant last restarted.

Setting it to heat/cool works, and even then the current temperature does not update in homeassistant. Did anyone face similar issues?

1 Like

I believe I had that issue early on, unpair, remove from ZHA, and repair

I have a Centralite HA 3156105 thermostat. Sometimes when I restart (ie after an update), it shows temperature and mode with power toggle, but I can’t set temperature or mode. It doesn’t seem to retain the capabilities of the thermostat.

HA allows me to see history of temperature and mode, but also states device became unavailable after restarting the service (despite still providing temperature updates and updating the clock on the thermostat). This happens about 50% of the time I restart the service or pi. Doing a re-pair usually works, but not a good solution.

image

I have the same issue with my Zen thermostats. They will usually come back if I go to the integrations page and reload the automation. Sometimes I have to do this more than once but it works. Something is clearly going on but reload is better than a entire restart.