ZHA with HACore at Synology DS216J


I have installed Home Assitant Core correctly on my Synology DS216J. I am aware that it is not the recomended option, but docker is not supported by my NAS due it has an amrv7 processor so that is not an option for me.
My intention is to use a conbee 2 usb stick with ZHA and zigpy-deconz library. The problem is that I can’t get intalled ZHA.
The log is in this link https://pastebin.com/ydBa7k8X (it is quite long)
Note that Home Assitant does not make anything when I try to install ZHA, it just show the message “please wait while the integration is installed” and gets blocked: half an hour later it is the same message. I had to refresh the browser be able to check the log and see what’s wrong but I really don’t know what to do with that information.
I will be very thankfull if anybody could tell me how to solve it.

Kind regards

After several checks and I have decided to try uninstall comunity package and installing HA according this post.
It have noted that this post makes reference to a manual to install HA on a Synology, however the link seems to be broken:
At the end I managed to follow all steps (and some other required but not mentioned) and start HA. However the user interface is not available. The log says the following:

2021-04-15 16:10:57 ERROR (SyncWorker_2) [homeassistant.util.package] Unable to install package pillow==8.1.2: WARNING: The directory ‘/volume1/@fake_home_link/asm/.cache/pip’ or its parent directory is not owned or is not writable by the current user. The cache has been disabled. Check the permissions and owner of that directory. If executing pip with sudo, you may want sudo’s -H flag.
ERROR: Command errored out with exit status 1:
command: /opt/bin/python3 -u -c ‘import sys, setuptools, tokenize; sys.argv[0] = ‘"’"’/tmp/pip-install-3g3m1cd0/pillow/setup.py’"’"’; file=’"’"’/tmp/pip-install-3g3m1cd0/pillow/setup.py’"’"’;f=getattr(tokenize, ‘"’"‘open’"’"’, open)(file);code=f.read().replace(’"’"’\r\n’"’"’, ‘"’"’\n’"’"’);f.close();exec(compile(code, file, ‘"’"‘exec’"’"’))’ install --record /tmp/pip-record-12saodvh/install-record.txt --single-version-externally-managed --prefix ‘’ --user --prefix= --compile --install-headers /volume1/homeassistant/deps/include/python3.9/pillow
cwd: /tmp/pip-install-3g3m1cd0/pillow/

I understand why is made reference to this path /volume1/@fake_home_link/asm/.cache/pip as it does not exist any directory called @fake_home_link at volume1. In any case I tried to install manually the pillow package but I get the same error (except for the directory reference)
Any idea or how to proceed?

Kind regards

Finally I solved the problem. To use comunity HA core package some other packages must be installed manually by running the following command in /var/packages/homeassistant/target/env/bin:

./pip install bellows==0.21.0 zha-quirks==0.0.51 zigpy-cc==0.5.2 zigpy-deconz==0.11.1 zigpy-xbee==0.13.0 zigpy-zigate==0.7.3 zigpy-znp==0.3.0 zigpy==0.30.0

Then you need to restart homeassistant before adding the Zigbee Home Automation integration.
I found the solution here: