Zigbee network keeps crashing ... feels like I tried everything

Hi there,

I’m still in testing phase but I think I found the issue.
It seems my SSD enclosure was faulty, working but most likely generating a lot of errors.
I also move the Zigbee dongle to the powered hub, probably help.
Then fresh install and it seems to be working so far. I’m reinstalling addons and devices one after the other with a few days in between so I can identify where crashed come from if any.

I’m not there yet but seems on track.
Hope that helps but it seems my pb was very specific…

I might have a “faulty” SSD SATA adapter to USB form my Pi. I was having a huge delay with Supervisor Logs and after disabling the UAS it started working. Weird to affect the system only when adding a Zigbee dongle and running Z2M.
I will try with the Power supply i’m still waiting to arrive and after that (if not solved) I might change the adapter.

What erros did you see?

It’s hard to say what was related to what (see above, I posted the logs and some errors) but I had regular “can’t read supervisor data” which I couldn’t find the source for. The disk sort of connecting/disconnecting, sometime the LED light from the enclosure was only partially lit up which is not normal on this enclosure.
I changed it and since then, running smoothly.

@PJBLinkHA any update here? Things are working as they should?

Note that USB 3.0 ports are known to cause serious interference with Zigbee Coordinator, and while that is not an issue on Raspberry Pi 3 as it has no USB 3.0 ports, if you move to a NUC or other computer with only USB 3.0 ports then you should also consider putting the Zigbee Coordinator on a powered USB 2.0 hub to be sure it is not close to any USB 3.0 ports or other pheriphials and cables connected to USB 3.0 ports (especially SSD disks connected to USB 3.0 ports are known to cause a lot of interference for Zigbee).

Regardless of the actual root cause, always aim to keep the firmware of the Zigbee Coordinator updated, add more products acting as Zigbee Routers devices and implement workarounds for interference, see:




Understand and remember that Zigbee signals are weak so rely on a strong Zigbee network mesh (meaning many Zigbee Router devices) and are very sensitive to RMF/EMI/RMI interference so it makes it much easier to troubleshoot and find the real root cause if have already optimized your setup and environment to work around that.

I’ve been meaning to report for a while but didn’t take the time, sorry.
Yet, I’m not sure it’s going to be very helpful for anywone as it was super specific to my case: my SSD enclosure was faulty, creating errors accumulating, creating lag and corruption on the pi. Too much for the Zigbee network which was going down.
I’m lucky I noticed the led blinking a bit weakly on the enclosure while doing my third re-install of HA, otherwise, I could have searched forever …
Since I changed the enclosure, not even one crash.

What also helped before and after that issue was:

  • moving the Zigbee dongle to a powered USB (2) Hub (even with genuine pi power supply, it’s not enough for the Zzh for example)
  • increasing the swap file. I have a Pi 3B and HA has become a bit too much for 1go of Ram. This [(How to increase the swap file size on Home Assistant OS)] is super easy and work perfectly. It solved all of the other issue I had on the PI.

Hope this helps someone one day!
And thanks to all who took the time to answer :slight_smile:

@ marcoskp, did you find your problem?

FYI, have summarized all my general tips here since my ZHA docs PR is taking forever to be reviewed:


Radio frequency interference impact on all 2.4GHz wireless devices is a well known issue with USB 3.0:


…and how USB 3.0 interfere with Zigbee is actually covered in linked tips :wink:

Workaround is to move the Zigbee USB dongle to a powered USB 2.0 hub or to a native USB 2.0 port.

1 Like