Zwave not working on mac

Hi all,

I am using zwave aeotec stick on macmini, and it has been running fine on version 0.75.2.
However I got zwave configuration error after upgrade to 0.77.3. I had to upgrade back to 0.75.2 in order to make it work again.

I don’t see any major break change to zwave from 0.75.2 to 0.77.3

My configuration as follow:

  usb_path: /dev/cu.usbmodem1431
  autoheal: True

I figure out issue because it failed to install python-openzwave 0.4.9.
When I tried to install manually got some error… Anyone know how to fix it?

creating build/temp.macosx-10.9-x86_64-3.7
creating build/temp.macosx-10.9-x86_64-3.7/openzwave-embed
creating build/temp.macosx-10.9-x86_64-3.7/openzwave-embed/open-zwave-master
creating build/temp.macosx-10.9-x86_64-3.7/openzwave-embed/open-zwave-master/python-openzwave
creating build/temp.macosx-10.9-x86_64-3.7/openzwave-embed/open-zwave-master/python-openzwave/src-lib
creating build/temp.macosx-10.9-x86_64-3.7/openzwave-embed/open-zwave-master/python-openzwave/src-lib/libopenzwave
gcc -Wno-unused-result -Wsign-compare -Wunreachable-code -fno-common -dynamic -DNDEBUG -g -fwrapv -O3 -Wall -arch x86_64 -g -DPY_LIB_VERSION=0.4.9 -DPY_SSIZE_T_CLEAN=1 -DPY_LIB_FLAVOR=embed -DPY_LIB_BACKEND=cpp -Isrc-lib/libopenzwave/ -Iopenzwave-embed/open-zwave-master/cpp/src -Iopenzwave-embed/open-zwave-master/cpp/src/value_classes -Iopenzwave-embed/open-zwave-master/cpp/src/platform -Iopenzwave-embed/open-zwave-master/cpp/build/mac -I/Library/Frameworks/Python.framework/Versions/3.7/include/python3.7m -c openzwave-embed/open-zwave-master/python-openzwave/src-lib/libopenzwave/libopenzwave.cpp -o build/temp.macosx-10.9-x86_64-3.7/openzwave-embed/open-zwave-master/python-openzwave/src-lib/libopenzwave/libopenzwave.o -stdlib=libc++ -mmacosx-version-min=10.7
openzwave-embed/open-zwave-master/python-openzwave/src-lib/libopenzwave/libopenzwave.cpp:3:9: warning: 'PY_SSIZE_T_CLEAN' macro redefined [-Wmacro-redefined]
<command line>:3:9: note: previous definition is here
#define PY_SSIZE_T_CLEAN 1
openzwave-embed/open-zwave-master/python-openzwave/src-lib/libopenzwave/libopenzwave.cpp:32283:60: warning: 'BeginControllerCommand' is deprecated [-Wdeprecated-declarations]
  __pyx_t_6 = __Pyx_PyBool_FromLong(__pyx_v_self->manager->BeginControllerCommand(__pyx_t_1, __pyx_t_2, __pyx_f_12libopenzwave_ctrl_callback, ((void *)__pyx_v_pythonfunc), __pyx_t_3, __pyx_t_4, __pyx_t_5)); if (unlikely(!__pyx_t_6)) __PYX_ERR(0, 4207, __pyx_L1_error)
openzwave-embed/open-zwave-master/cpp/src/Manager.h:1732:3: note: 'BeginControllerCommand' has been explicitly marked deprecated here
                DEPRECATED bool BeginControllerCommand( uint32 const _homeId, Driver::ControllerCommand _command, Driver::pfnControllerCallback_t _callback = NULL, void* _context = NULL, bool _highPower = false, uint8 _nodeId = 0xff, uint8 _arg = 0 );
openzwave-embed/open-zwave-master/cpp/src/Defs.h:58:35: note: expanded from macro 'DEPRECATED'
#define DEPRECATED __attribute__((deprecated))
2 warnings generated.
g++ -bundle -undefined dynamic_lookup -arch x86_64 -g build/temp.macosx-10.9-x86_64-3.7/openzwave-embed/open-zwave-master/python-openzwave/src-lib/libopenzwave/libopenzwave.o openzwave-embed/open-zwave-master/libopenzwave.a -o build/lib.macosx-10.9-x86_64-3.7/ -framework CoreFoundation -framework IOKit
clang: error: no such file or directory: 'openzwave-embed/open-zwave-master/libopenzwave.a'
error: command 'g++' failed with exit status 1


Command “/Library/Frameworks/Python.framework/Versions/3.7/bin/python3.7 -u -c “import setuptools, tokenize;file=‘/private/var/folders/w9/zpb2m5bn4gb6jwpw1v7n497c0000gn/T/pip-install-kyz6vhx4/python-openzwave/’;f=getattr(tokenize, ‘open’, open)(file);‘\r\n’, ‘\n’);f.close();exec(compile(code, file, ‘exec’))” install --record /private/var/folders/w9/zpb2m5bn4gb6jwpw1v7n497c0000gn/T/pip-record-rqeeyq3z/install-record.txt --single-version-externally-managed --compile” failed with error code 1 in /private/var/folders/w9/zpb2m5bn4gb6jwpw1v7n497c0000gn/T/pip-install-kyz6vhx4/python-openzwave/

Found the solution on the GitHub - OpenZWave/python-openzwave: Python wrapper for openzwave
Solved my problem installing pyhton-openzwave with:

(venvX) pip install cython wheel six
(venvX) pip install ‘PyDispatcher>=2.0.5’
(venvX) pip install python_openzwave --no-deps --install-option=“–flavor=git”

My apologies for off-topic, how do you like running HA on a mini with Z-Wave?

I am considering doing just the same. We are an iOS house but I was itching to upgrade our alarm so I upgraded it to Konnected and went with a ST hub. I’ve added a few Z-Wave switches but wishing I could control everything with Siri instead of telling Siri goodnight and then grabbing the phone to swipe to the ST widget and set the alarm, annoying although I am aware these are 1st world problems.

Did you have any trouble setting up HA on a mini? May I ask what mini you are using? I picked one up off of ebay but its not what the listing said it was. I’m torn about sending it back, the seller is apologetic and is willing to come off of the price even more to keep it. Basically I would be in it for $200 with a magic mouse 2 and a wireless keyboard, mid 2010 but with only 2gb ram and 320gb hard drive. I would likely need to upgrade the ram and may want to upgrade the hard drive to use it as media storage for streaming to ATV4’s and other devices.

Hi, I am using late 2012 Mac Mini running 2.5G intel Core i5, 16G with 250SSD. It’s so much faster than running on raspberry pi! I am running a few services like Homeassistant, MQTT server and Unifi controller, there is no external monitor, keyboard and mouse connected to it. I am accessing remotely to manage the server. For your spec, you should update the RAM and change the HDD to SSD.

To use mac mini with z-wave, you need to install python_openzwave package. You can follow the guide through Installation - Home Assistant

or if you install from scratch (to install on virtual environment):

python3 -m venv env
python3 -m pip install cython six wheel
python3 -m pip install ‘PyDispatcher>=2.0.5’
python3 -m pip install python_openzwave==0.4.9 --no-deps --install-option=“–flavor=git”
python3 -m pip install homeassistant

After that, find the directory of the zwave stick, run ls /tty/ttyusb then put it into the zwave configuration usb_path: .

1 Like

Thank you for your response to my off-topic question.

I am really excited to get this project going.

no problem~! hope that helps. Enjoy the best home automation system!


I’m sort of up and running, but having the same errors with zwave as your original post. The first string solution you posted installed, the other two had errors. I’m going to try a re-start.

You should post the error messages you get. Really hard without knowing what went wrong.

Yeah, I meant to come back after restarting everything and post the actual errors.

Then dinner time happened.

I’ll get back after it tonight, I think I got it working actually.

If you do have it working, post back so others can benefit.