0.105 is a mess. What happened?

Update worked for me but…

I’m unable able to scroll windows like the log viewer on my mobile devices (iPad, iPhone). It happens on both safari and chrome. I see the initial page but nothing after that is viewable. Worked great before the update. Not a show stopper but until that’s fixed, I can’t do any debugging or development at 3 in the morning when I can’t sleep any longer…


open a new issue. it was a big release in terms of UI.

Happy to do so.

Ok, hit me with a link. It should be painfully obvious, but I can never find the place to log bugs unless someone posts it here.


no problem.
there is a root HA page on GitHub.
from there you can navigate to the bit that you have issue with, namely - core, fronted (UI), underlying OS, supervisor, android companion and documentation.

in your case the first guess is UI, i.e you click on home-assistant-polymer and there you can see under its name tabs Code, Issues, Pull requests etc.
Click on Issues and there is a shiny green New issue button there. Choose the right option, fill in a form and that’s (almost :slight_smile: ) it.


You da man. Perfect. Thanks.

1 Like

When the update leaves you unable to get to Lovelace through the browser, SSH and Samba loads correctly where do you report the issue?

I’d say it’s Frontend


Safe mode might be a bit too sensitive. issue at hand, missed 1 simple line in customize_domain.yaml…

  custom_ui_state_card: state-card-custom-ui
    icon_color: >
      if (state === 'on') return 'rgb(251, 210, 41)';
      return 'rgb(54, 95, 140)';

instead of:

  custom_ui_state_card: state-card-custom-ui
    icon_color: >
      if (state === 'on') return 'rgb(251, 210, 41)';
      return 'rgb(54, 95, 140)';

otoh, it did startup, and I could easily click restart after editing the file…


I don’t know if I would say 0.105.x is a mess, but…

I updated from 0.102.3 which for me was working perfectly to 0.105.2.
This upgrade in particular for me experienced lots of issues. I also upgrade to HassOS 3.9, which I did after the HA upgrade. Not sure if the order was important, I didn’t see anything posted to indicate one way or the other (but I might have missed it).
I have been experiencing, in my opinion (at least with my setup) significant issues.
I will summarize them here, because I don’t quite know where I should post it, since my issues are varied.

My current issues (though HA is “running”):

  1. State History seems to be non-existent (click anything in the frontend and 'No State history found"
  2. Node-Red had significant issues with the upgrade and it was removed, reinstalled, multiple times. It is now running (latest version of the HA plugin), and though “functional”, I have numerous timers that turn things on and off, but the time is 5 hours off.
  3. HA plugins all had to be started individually once I got the upgrade to sort of work.
  4. Wipe & Restore didn’t roll me back to the 0.102.3 that I was on, but I purposely did a full snapshot before doing the upgrade.

I have been using HA for a year, and been very very happy with it. I am not complaining. I would appreciate input from you guys and if you saw similar problems and if you were able to resolve them without rolling back to prior version…

I still can’t get the browser to load Lovelace after updating. Posted error messages and don’t see a solution. Config check does not show any issues. Don’t really want to start over (again). Going back to .104.3 works with no issues.

It’s not zwave, I use the native zwave in HA and it works fine for me. In fact 0.105.x has actually been faster and smoother with this latest update for me. :slight_smile:

Wipe and restore doesn’t revert versions. It only wipes your current config and restores an existing config.

EDIT: if you didn’t change your config, all you needed to do was via SSH:

hassio ha update --version=0.102.3 
1 Like

Thank you. That was not clear to me…I appreciate that. Just tried 0.105.3, if the same issues continue, I will be rolling back

1 Like

No issues whatsoever for me, running Home Assistant (Supervised) 0.105.3 on Ubuntu server. Updated from 0.104.x. Other than needing to make 1 small config change to add state_color: true, the update ran perfectly and continues to run perfectly.


I rolled back to 0.102.3, but it is still HassOS 3.10.

  1. State history has returned (had to reset ha db too)
  2. plugins all started on their own this time
  3. node-red started, but is having trouble talking HA again.

Have to see how things go over the weekend. Time in Node-Red seems to be correct now, but without HA connection…this might have to be another reinstall, but I suspect it won’t be as involved this time.
I think HA has reached a point where it is necessary to have a test device.
Perhaps a feature could be added similar to enterprise networking hardware. Keep the current and upgrade version in parallel. Presuming the current version (for me 0.102.3) is working. When time to upgrade, the “working” version is not wiped or overwritten, but the new version is loaded next to the current (0.105.3), Ha restarted using new version for test/validation. Once complete, if everything is successful (user validated), update and make it the “operational” version, if not, then simply flip the switch back, and restart.

Yes, I understand that might be considered a wipe & restore after HA downgrade, but that took well over 30-40 for me on rPi 3 B+. Using the method I suggest above, could be minutes.

Just some thoughts. Looking forward to testing 0.105.3+ and hoping some of the issues get resolved.

BTW 0.105.4 is out, my upgrade went smoothly (so far)

this is why ive started a thing where i check the forum and wait a few days before updating

1 Like

I do it a bit differently to stay on a safe side: read release notes, blog, forum and never update to .0 (usually to .2). Used to make a fun SD backup but not occasionally create snapshots (as my config is backed up anyway).


I too, always read the release notes, and try to have a look at the forum.
I used to have a dev HA, but got a little lax with checking that one since the SD card was too slow and it would crash. But that is probably the best way for me.
The main (prod) one to actually control things, and the dev one to have to observe how things are behaving. I also rarely do .0 level updates.

FYI, I run hassos as well, and the supervisor page showed the hassos 3.10 upgrade first, then after that completed (after reboot) the hassio 0.105.3 upgrade showed up. Not sure if that was just dumb luck, or if the order presented was intentional.

As a sidenote, the upgrade for me was painless and all is working as it should. There might be something with your config that is causing issues with the update. Either way, it’s 0.x software so, y’know, gotta roll with the punches and submit your bug reports and PR’s to github… and scream bloody murder as well if you get something out of that.