0.115: B-Day release! Media browser, tags, automations & WTH

I’ve just installed it on my Pi, pip install py-spy seems to have worked for me :slight_smile:

same issue here after adding Kodi as integration (and removing it from yaml)

  • service: kodi.call_method
    data:
    entity_id: media_player.osmc
    method: Player.stop
    playerid: 1

does nothing, no errors

Yep same here, and my 0.114.2 install was very basic. Looking at the logfile, I have:

2020-09-17 23:10:14 ERROR (MainThread) [homeassistant.setup] Setup failed for image: Unable to import component: libopenjp2.so.7: cannot open shared object file: No such file or directory

Google seems to suggest that is something to do with Pillow, which I think I read elsewhere on here, looking for more info right now…

make sure to open an issue on github

The changes are limited to service_template and data_template.

Fixed it:

sudo apt-get install libopenjp2-7
sudo apt-get install libtiff5

Restarted HA and after a few minutes it came up.

3 Likes

How do we integrate the entities from the Broadlink integration? It picked up my S1c, rm pro and mini ok but the S1c shows zero entities. I would like to see the existing entities - 3 sensors and the keyfob.
For the moment I rolled back. All of these become unknown even with the new integration and old code removed.

image

I cant call any Kodi methods either after adding as an integration.

You have to wake up device before configuration. Support for battery powered devices is currently very limited.

I am also having extremely high cpu usage… I wasn’t sure if the profile.svg was possibly enough or I need to save something else also?

This first one had been running awhile…

This is right after a restart of HA

Please let me know if I can provide more info

A number of Template Sensors that had been working flawlessly now report as UNKNOWN until I manually go to Server Controls and reload Template Entities.

Anyone else experiencing the same thing?

3 Likes

beware that the official shelly integration for shellyem is not pulling the solar export data (energy_returned/ total_returned). as a temporary stopgap you can create a rest sensor for this as below.

- platform: rest
  name: shellyem_energy_returned
  resource: http://192.168.1.75/emeter/0/returned_energy
  value_template: '{{ value_json.total_returned | multiply(0.001) | round(2) }}'
  unit_of_measurement: kWh

Thanks a lot, config worked fine afer wake up :grinning:

severel minutes later, the sensors are anavailable. should they not send the same information to HAas they send to the Shelly App. Or is the prolbem, that HA try to get the information and can’t wake up the device? if this ist the problem, these battery powered sensors are not usabel :disappointed_relieved:

Which sensors for doors, smoke, water and gas could you recommend?

It looks like you have templates that reference each other or themselves with an expensive filter. It likely wasn’t an issue before because we could not discover all the referenced states in older versions so the loop never triggered.

It would be great if you could post a copy of your template entities configuration somewhere so we can help look for a loop. I’m also curious about the filter as I’ve not seen one that expensive yet.

We also have additional debug log coming in 0.115.1 to help find these type of loops:

1 Like

So upon initial restart after update I saw all of the warnings about entity_id in templates, so I removed them thinking the constant logging of that message was causing a weird issue, so both of those profile.svgs are with entity_id: removed from all template sensors…
Also Im not sure if you remember I had some of those weird templates in the thread discussing now(), sensor.time etc… (I know you may not as you are a busy guy, so I’ll try to find it)… I will try to update again with the entity_id still there… (will it use the entity_id if it needs to with 0.115? or is it completely ignored?)

Also, im not sure what you mean by “an expensive filter”… what am I looking for?

Thanks. I remember now that the scripts and automation action syntax are basically interchangeable.

The entity_id is completely ignored now so it shouldn’t make any difference besides silencing the warning.

For the filter, you are looking for templates with a pipe character “|” in them (sorry that is probably a lot of them).

ok tried to update history_stats from the latest git repo.

Now I get a new error:

Platform error sensor.history_stats - cannot import name 'DOMAIN' from 'custom_components.history_stats' (unknown location)

Has the custom component been upgraded to work with 0.115