0.116: Entities card row editor, restore snapshots and performance metrics

@ttaidapos, I did this guide ages ago for upgrading python when running core in a venv. Obviously you’ll need to download and run the python version you want rather than the one in the commands there, and make sure you adapt for your install paths and autostart service if they are different…

There’s some troubleshooting further down the thread too if needed.


It suggests processor_use doesn’t provide an accurate picture of what the CPU is doing. :thinking:

It’s odd to see it report the CPU is running at 1% of its total capacity whereas Supervisor CPU usage claims it’s using 6.3%. :man_shrugging:

Thanks for this! Haven’t tried this guide yet, will give it a swirl and report back.

1 Like

I’m tempted to open an issue for the system monitor to get the cpu use to reflect the total hardware cpu use, not just the home assistant use.

1 Like

Does anyone else notice that in this version the use of the processor has several highs and lows?
I also have errors with the stream component

Logger: homeassistant.components.stream.worker
Source: components/stream/worker.py:240
Integration: Stream (documentation, issues)
First occurred: 20:06:41 (2 occurrences)
Last logged: 20:16:55

Timestamp overflow detected: dts = 1023391, resetting stream
Timestamp overflow detected: dts = 60906146, resetting stream
Logger: homeassistant.components.stream.worker
Source: components/stream/worker.py:246
Integration: Stream (documentation, issues)
First occurred: 20:06:18 (3 occurrences)
Last logged: 20:17:00

Dropping out of order packet: 183510 <= 183510
Dropping out of order packet: 195267 <= 195267

When you open the camera player visually there is no problem

The system monitor runs inside the container so it doesn’t know what is going on outside of it unless there is an external service that provides the data.


In that case, the new System Metrics feature provides a more accurate picture of what is actually being reported:

  1. Core CPU usage
  2. Supervisor CPU usage

where System Monitor’s processor_use is Core CPU usage and has never represented the total CPU usage when part of Home Assistant OS, Supervised, or Container.

That would indeed explain why tom_I’s system was reporting high temperatures but processor_use was very low; something beyond the homeassistant container’s boundaries was monopolizing the CPU.

If your system overheats again, let us know what Supervisor CPU usage indicates. Even at idle, it already consumes more CPU time on my RPI3 than Core.

1 Like

Great release! I love the improvements to the Synology component. Thanks to the whole team and double extra special thanks to @shenxn for the Synology work!!

1 Like

Install very smooth. I tried the new Raspberry PI power supply integration and it would not install. Clicked on install and it closes without installing. No errors in log. Should I open an issue on github? Error showed up today: Error occurred loading configuration flow for integration rpi_power: No module named 'custom_components.rpi_power.config_flow.
I had a custom component that I forgot I installed. Removed and it installed correctly.


Hate to be “that guy” but it worked for me. Installed on RPI3.

Screenshot from 2020-10-07 14-54-44

Screenshot from 2020-10-07 14-55-05

Screenshot from 2020-10-07 14-56-02

Anyone wanting to pull these metrics into the frontend, I created some examples here.


The integration of the Raspberry PI power supply works well for me. Created the entity and monitors the resource

I have the same, it doesn’t install.

Got it solved. The custom component was still installed on the device. After deleting and reboot it worked.

I have a pi 4. Looks like it works for some and not for others. Tried again this morning and get Error occurred loading configuration flow for integration rpi_power: No module named 'custom_components.rpi_power.config_flow.
I had a custom component that I forgot I installed. Removed and it installed correctly.

Seeing this as well. My stream in lovelace is freezing as well. Rolled back to 0.115.6 and all good again.

are you guys using the synology dsm component for cameras?

I’m using the amcrest ad110 doorbell camera
rtsp is stable outside of HA

  - host:
    name: Doorbell Camera
    username: !secret amcrest_username
    password: !secret amcrest_pw
    stream_source: rtsp
      - motion_detected
      - online

Yes, I’m using it. And it works ok

Yay Hyperion is fixed!!!

Edit: awesome performance metrics, if I could make 1 feature request/suggestion to add to it: Uptime
then I can remove all the manual stats I made in one of the panels.

It does not work for me too… Did anyone find anything on this?

Is that because we had custom component for rpi_power before? I tried removing it too, but did not work for me. Entity name is same as that of custom component.