0.116 onboarding to a fresh install Bad Gateway message

Trying the new onboarding process. Trying to upload a file at the initial start page, but get


Could there also be something about what settings are honoured / migrated e.g. is the fixed IP migrated?

Someone else reported this was not working for them too:

I suggest you open an issue.

There is a frontend bug open for it, it should ignore 502, since those are expected when the core restarts.
Just wait


Thanks. I’m migrating off a Pi to a Proxmox HassOS and I ended up doing it the old fashioned way! It took over an hour to import. Largely running except for bluetooth.

I found that I needed to refresh the page, 502 went away and it was there (had been waiting a while so could have been a lot quicker than the 30 minutes I waited!)

1 Like

Yeah, once the dialog with the error is shown, the redirect is blocked, which is part of the issue.

1 Like

Same issue here… after first boot of 5.3, the Pi wasn’t showing on the local network. Power cycled, and the Pi showed up. I let it finish initializing, then on the onboarding process selected the restoration option. Selected the .tar-file I downloaded earlier. Got the “Upload failed - Error: 502 Bad Gateway” message in every browser I’ve tried. No log to show since no access at all…

Running a Pi4B, running from a Sandisk Extreme USB3.0 (in the blue port). Had this running flawless on v5.1 when I made the mistake of ‘rogue clicking’ the update-button… (an option to hide this info-box would be very nice and much needed…)

Update (20/10)
After a regular initialisation and adding the SMB-share add-on, I’ve tried uploading a backup tar-ball. Uploadibg is painfully slow, sometimes moving forward a couple of 100 MB’s in a few seconds, after which follows a period of (sometimes seconds, sometimes minutes) nothing… just the Finder waiting for the upload progress bar to continue. (note: uploaded from a 1300mbit wireless connected notebook to a wired Pi4b - this upload usually takes tens of seconds to finish)

Rolling back to 5.2 as a fall back before rolling back to the last known stable situation (5.1)…

Update 2 (20/10)
After restoring a backup (full wipe-and-restore) the Pi wouldn’t automatically come up in the network again (although it was still visible in the network). Power cycle, and up and running. Disappointed to see that only a handfull of add-ons was restored. Started a manual restore for just the missing add-ons, but all I got was a lot of “[supervisor.ingress] Fails Ingress panel for {add-on name} with 500”, which leads me to suspect a server configuration error. This is in line with the previous upload errors.

Update 3 (20/10)
My LAN sniffer just detected a double hostname: turns out the Hassio RPi copied a DNS name from a completely random client inside the network, which leads me to think that resolving the Pi through the hostname might lead to trouble… investigating…

Update 4 (21/10)
The hostname issue ‘corrected’ itself - most likely some caching issue. Hostname is now shown as ‘homeassistant’.

1 Like

Same issue.

Fresh install of hassos_rpi3-4.15.img.gz

same error here
created a snapshot from HA on Raspi4B

installed HA on proxmox
started HA VM on proxmox

at the onboarding page, tried to upload the snapshot i’ve made a couple of seconds ago in the live HA
upload failed. 502 bad gateway

live HA where the snapshot came from: 0.117.1
supervisor: 2020.10.0
HassOS 4.15

new created proxmox vm with HA
latest versions because i’ve used the whiskerz007 install script that downloads the latest version

Not sure it matters, but the same here today, fresh install 0.117.02 onto a Pi3, restore at onboarding kept giving a 502.

Same issue here too.
I’m using it on a virtual box vm using a new image file hassos_ova-4.15.vdi
The snapshot was also created today

New to HA, trying to teach myself how to do snapshot and restore. Source is a new install on RPi. Destination is a QCOW image running on KVM. Trying to upload the snapshot, and received 502 Bad Gateway.

I just install the samba add-on after creating a dummy user. Then copied the backup to the share over the network. Restoring now and waiting… 500gb restore is taking some time, hope this goes well.

Please let us know if you succeeded!

Yes. It worked.
Long time ago I decided to not run HA on port 8123, that causes some troubles when installing.
I also run Unifi and DNS/Aguard as an HA addon, which is something you need to plan ahead for.

let’s see if you did the same as I did, I put a new installation on a new SD card. Then start up with the new installation. Install Samba. place the snapshot in the backup folder. then restore the snapshot. and then have patience? I thought I waited a long time, but home assistant remained unreachable. That is the workaround?


Sounds right. Can you access it via IP? Can you ping it? It might be running but you might not have the right IP of be an issue with DNS. Lots of things can go wrong depending on your setup. I had to add my duckdns.org domainname to my windows host file. HA seems very picky as to how you access it, i.e. can’t use IP number, only my custom hostname.

Thanks for your answer. I did use the IP adress I discovered. And I used it. You say I have to use my duckdns, I will try it again.

I got the same message , bad gateway

How do i restore it? Workaround?

Yes there is a workaround. Download a fresh full snapshot. Make a fresh homeassistant o a new sd card. Log on the new installation and install samba. Go the network on your PC and upload the snapshot to the backup folder in homeassistant. Then do a wipe and restore action. Wait a while give it time. Then look for the IP adres of homeassitant, mostly it will be a new one.I have changed the ip address for a static IP address with a network dir on a USB stick. I did a restart and loggend on with duchdns. IT WORKS!!