0.118: Grid and logbook cards, quick navigation, native template types

I try to log in via ssh to update hacs.
But i cannot get Terminal & SSH running.
It terminate every time, showing this in the logs:
INFO: Restoring host keys…
cp: can’t stat ‘/data/host_keys/*’: No such file or directory

My config is simple:

authorized_keys: []
password: test
tcp_forwarding: false’

I do love the new “natitive types support for templates”.

I process temperature sensors output that comes in via MQTT in an appdaemon app. The automation that triggers appdaemon is like this:

- id: rtl_mqtt_trigger
  alias: RTL MQTT trigger
    platform: mqtt
    topic: 'rtl_433/RPi4/events'
  mode: queued
    event: RTL_MQTT
      topic: '{{ trigger.topic }}'
      payload: '{{ trigger.payload }}'

The payload is JSON format and previously I had to use json.loads in the appdaemon app to cast the payload from string to JSON, but now the payload is directly JSON.

Well done, devs and contributors!

When i want to setup the Shelly Integration, i get this screen:
What am i supposed to do here?

Never mind, the integration was flagged as ignored.

Can anyone tell me if the stylesheet added with 117 has been reverted with 118, or has a workaround? Markdown works different now, which messes my entire UI. Unfortunately there is only radio silence on the github ticket I created. Lot of people who depend on markdown for their UI are kinda stuck now…

I had to skip HA 117 entirely since the change was introduced with the first version and no changes all throughout 117. I really hope there at least will be a viable workaround, so I can finally update…

My yeelight devices stopped working after upgrading to 0.118 with nothing in HA logs. Rolling back to 0.117.6 brings them back to life. Is anyone else having the same issue?
EDIT: I see https://github.com/home-assistant/core/pull/40251 related to having yeeligh in different subnets but it’s not my case.

What device is it?

I made the update to 0.118 last night.
After that everything went fine and I could use the two new maps Logbook and Grid.
Then I did the system update and went to bed.
This morning after getting up I look on my dashboard and notice that the new maps don’t work.
They are no longer found and do not appear in the overview.
But much worse, parts of the system do not work anymore.
No more logbook, the developer tools don’t work, I can’t view devices/entities under settings.
Everywhere the error “Error loading page” appears.
I am completely desperate …

I cannot update as I’m getting the following error:

ERROR (SyncWorker_0) [supervisor.docker.interface] Can't install homeassistant/raspberrypi4-homeassistant:0.118.0 -> 500 Server Error: Internal Server Error ("toomanyrequests: You have reached your pull rate limit. You may increase the limit by authenticating and upgrading: https://www.docker.com/increase-rate-limit").

Any idea what I can do?

This is due to the new DockerHub pull limits.

You can check your status, more info on how to do that there.

Maybe HA will move from DockerHub to GitHub packages (like many others like LinuxServer.io) ?

Simple question, how do I get to the new logbook and grid cards? The are not listed here “Which card would you like to add to your “Home” view”

I tried to use the new logbook card, but no matter which entities I select, the card stay like that:

1 Like

Where did you find the card

edit dashboard
click + add card. its listed in there

It wasn’t. I had to refresh my cache several times. Not sure why the first refresh did not work. It did not show on any of my devices. Now it works on all. Thanks.

Looks like the OS upgrade bricked my Pi, so that’s fun.

Update: 5 or 6 power cycles later, it decided to actually boot up.

This did it for me too: download and replace the folder :smiley:

1 Like

To clarify, what you described is typically handled with trigger.payload_json which receives a string in JSON format and converts it to an object. This has worked in all versions prior to 0.117 (where ‘native types for templates’ was first introduced). It’s the way users have been receiving data from rtl_433, Sonoff RF Bridge, OpenMQTTGateway, etc for a long time.

The difference now appears to be that it no longer needs the hint of payload_json and handles type conversion with just payload.

1 Like

I was not aware of the trigger.payload_json option and so had solved the string to JSON conversion in the appdaemon app. Had I known I might have saved half an hour of bug fixing this morning (as json.loads was not too happy about trying to convert JSON to JSON… :wink: )

my onvif camera stop working after 117.0 update, and still not working after 118.0. Works fine on 116.4. After update camera is in reboot loop. My camera is KENIK kg-2036d…