0.39.0 upgrade experience

I tried to upgrade again to 0.39.0 with no luck, I still don’t get anything in the logs, HA doesn’t seem to start at all (.HA_VERSION it’s not updated either).

I did the following changes but nothing helped:

  • Added device_config: !include zwave_device_config.yaml
  • Added an empty groups.yaml
  • Commented the zwave customizations
  • Commented all the zwave configurations

Anyone else having problem to start HA, it would be helpful if I had something in the homeassistant.log but mine totally empty :confused:

rpitera, yes that is in my configuration.yaml. The zwave_device_config.yaml is blank.

1 Like

Thanks! I’m imaging my whole SD card at the moment, then copying over configs before even attempting an upgrade. Playing it safer than usual with this one.

Appreciate your reply.

1 Like

exactly same problem here :frowning:

Mine upgrade seemed to work. I have the AIO install on a Pi3 and previously had Z Wave and Groups setup and working.

I created a blank zwave_device_config.yaml file and a blank groups.yaml (after backing up my existing groups.yaml file)

I then added the


line to my configuration.yaml and also amended my zwave: entry in configuration.yaml to read:

zwave: !include zwave_device_config.yaml

restarted and there were errors.

I then pasted my backed up groups.yaml content into the new one and put the following in my zwave_device_config.yaml:

usb_path: /dev/ttyACM0
config_path: /home/homeassistant/.homeassistant/config
polling_interval: 120000

restarted and hey presto - all back to normal…

Except I am now getting errors in my log to do with timings - that said my automations and zwave devices are responding as expected so I am still looking into the errors.

Edit: added some ‘z’ in front of ‘wave’… autocorrect!!

1 Like

@turboc This happens to me every time I upgrade and I don’t have a full solution. On my install, I enter the hass virtual environment and then use:

pip3 install --upgrade package

Where ‘package’ is whatever is in your log as a broken dependency (ie. netdisco==0.8.3). If you go through and do this for each error it should resolve itself.

My problem is that this leaves me with a bunch of dependencies that are from git and not pip3 that can’t be installed, and I can’t figure out how to force those to upgrade. Does anyone have a better solution for this? Happens every time I upgrade (Raspberry Pi with Hassbian following the upgrade directions in the wiki).

I just wrote a script to do it for me, sort of. I have to run it and specify the packages and version.

(homeassistant_venv) homeassistant@hass2:~$ cat reload_deps.sh 
pip3 uninstall $1
pip uninstall $1
sudo pip3 uninstall $1
sudo pip uninstall $1
pip3 install --upgrade --target=/home/homeassistant/.homeassistant/deps $1==$2 
(homeassistant_venv) homeassistant@hass2:~$ 

I’m going to modify it and just have it go through the home_assistant.log file and look for “dependency” and strip out the package and version to automate it further since it seems like this is an ongoing thing.

Hmmm. I was thinking to update hoping to fix my Wink hub issues but I think I will wait.
Also this was suppose to have the MyQ component added?
Taking an image just in case I get the urge to upgrade. lol

As long as you have good backups, you should be fine after doing some forum readings like this thread.

I just finished pulling my SD card and creating an image with Win32DiskImager and while it takes a fair bit of time, it’s worth it for the piece of mind. I can upgrade and if it goes totally south, I just pull the card and write the backup image over it and I’m back in business. I highly suggest it for upgrades especially.

(I still haven’t tried etcher yet, may be faster.)

Well I did the upgrade. Not bad. It just don’t like that I have customize in my zwave setup.

        polling_intensity: 1

        polling_intensity: 1

        polling_intensity: 1

        polling_intensity: 1

I’m also confused about the groups config. I have upgraded and enabled config for groups and zwave, but my groups section shows “No entities found”. I have 2 z-wave devices that are working fine in HA. Do those not count as entities for groups?

Note: I have never setup any groups, so I may be making an assumption as to how they work.

As far as I can understand it, you are not (yet) able to create groups via the configuration interface. What I did was to create the empty groups.yaml, reload HA and then add my old groups to the groups.yaml. And of course, reload. I still don’t have a grasp of what’s in “core” and what’s not, so I usually reload and restart everything :slight_smile:
Viola! Groups visible.

Now I am able to do some minor changes to the groups. I tried changing a group to a view, but saving that change removed all other groups. My HA system is still very new so not much was messed up, and for once I had a backup.


Yep, editing a group and then saving seems to remove all the other groups for me.
The quick reloading of group configuration is pretty handy though!

Anyone know how I can poll my zwave dimmers in this new setup?
HA don’t like if you use customize in the new zwave_device_config.yaml

Edit: I got it. Had to do some reading.

  usb_path: /dev/ttyACM0
  config_path: /srv/homeassistant/src/python-openzwave/openzwave/config
  polling_interval: 10000
  debug: 0
      polling_intensity: 1
      polling_intensity: 1

I’m experiencing 3 problems since upgrading to 0.39 - my home-assistant.log is practically just these three messages and nothing else:

WARNING (MainThread) [homeassistant.components.media_player] Updating samsungtv media_player took longer than the scheduled update interval 0:00:10

Traceback (most recent call last):
  File "/srv/homeassistant/lib/python3.5/site-packages/homeassistant/helpers/entity_component.py", line 396, in _update_entity_states
    yield from update_coro
  File "/srv/homeassistant/lib/python3.5/site-packages/homeassistant/helpers/entity.py", line 212, in async_update_ha_state
    yield from self.hass.loop.run_in_executor(None, self.update)
  File "/usr/lib/python3.5/asyncio/futures.py", line 361, in __iter__
    yield self  # This tells Task to wait for completion.
  File "/usr/lib/python3.5/asyncio/tasks.py", line 296, in _wakeup
  File "/usr/lib/python3.5/asyncio/futures.py", line 274, in result
    raise self._exception
  File "/usr/lib/python3.5/concurrent/futures/thread.py", line 55, in run
    result = self.fn(*self.args, **self.kwargs)
  File "/srv/homeassistant/lib/python3.5/site-packages/homeassistant/components/switch/command_line.py", line 141, in update
    payload = str(self._query_state())
  File "/srv/homeassistant/lib/python3.5/site-packages/homeassistant/components/switch/command_line.py", line 135, in _query_state
    return CommandSwitch._query_state_value(self._command_state)
  File "/srv/homeassistant/lib/python3.5/site-packages/homeassistant/components/switch/command_line.py", line 98, in _query_state_value
    return_value = subprocess.check_output(command, shell=True)
  File "/usr/lib/python3.5/subprocess.py", line 626, in check_output
  File "/usr/lib/python3.5/subprocess.py", line 693, in run
    with Popen(*popenargs, **kwargs) as process:
  File "/usr/lib/python3.5/subprocess.py", line 947, in __init__
    restore_signals, start_new_session)
  File "/usr/lib/python3.5/subprocess.py", line 1490, in _execute_child
    restore_signals, start_new_session, preexec_fn)
OSError: [Errno 12] Cannot allocate memory```

And an error that says 

```nmap.nmap.PortScannerError: 'nmap program was not found in path. PATH is : /usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin'```

even though 

```which nmap```



The combined effect - or maybe just the effect of the OSError: [Errno 12] Cannot allocate memory - is that HAss uses up all the host memory in about 15 seconds and then stops responding until I reboot the machine.

Is anyone else experiencing any of these problems?


are you connecting to your samsung tv through a command line? Also, you might want to try uninstalling and re-installing nmap. I seem to remember having to do that once when I was rebuilding my HA instance.

Thanks will check it out.

I was nervous about the upgrade and didn’t understand the customise, groups and zwave stuff but decided I’d just try it and then downgrade if it didn’t work right away. I was expecting it to fail but it worked and so far everything seems to be working OK. Have had it running overnight. Unexpected since I use groups, zwave, customize, and have limitlessLed (v4 Bridge).

That said, I do have a ton of errors in the log that I don’t have time to dig through right now.

The part that is confusing me is that it says no entities found. Are groups entities just as the devices HA controls are entities? If they are, then I think it would be clearer if it specified the type of entity that could not be found.

Nearly the same, editing a group and calling it a view killed the rest of the groups

Same here. Set one of my groups to a view and now the dropdown only lets me select that view. The other groups are not selectable.