0.39.0 upgrade experience

I just upgraded to 0.39.0. I had to install the following packages manually since they would not load as HA started up.

17-02-25 19:50:15 ERROR (Thread-1) [homeassistant.bootstrap] Not initializing discovery because could not install dependency netdisco==0.8.3
17-02-25 19:53:07 ERROR (Thread-6) [homeassistant.bootstrap] Not initializing wink because could not install dependency pubnubsub-handler==1.0.1
17-02-25 20:06:39 ERROR (Thread-5) [homeassistant.bootstrap] Not initializing zeroconf because could not install dependency zeroconf==0.18.0
17-02-25 20:18:47 ERROR (Thread-5) [homeassistant.bootstrap] Not initializing sensor.systemmonitor because could not install dependency psutil==5.1.3
17-02-25 20:18:47 ERROR (Thread-5) [homeassistant.bootstrap] Not initializing sensor.systemmonitor because could not install dependency psutil==5.1.3
17-02-25 20:20:27 ERROR (Thread-3) [homeassistant.bootstrap] Not initializing media_player.apple_tv because could not install dependency pyatv==0.1.4
17-02-25 20:20:43 ERROR (Thread-11) [homeassistant.bootstrap] Not initializing media_player.cast because could not install dependency pychromecast==0.8.0

database not ready errors again
install mysqlclient current version

Configuration pages AWESOME!!!
Next feature, add and delete entities in groups (including support for other groups (nested groups))

You renamed the log file from homeassistant.log to home_assistant.log ???

Just created a fresh docker container for version 0.39.0, everything seems to have installed fine:

17-02-26 10:26:22 INFO (Thread-1) [homeassistant.util.package] Attempting install of pychromecast==0.8.0
17-02-26 10:26:34 INFO (MainThread) [homeassistant.bootstrap] Setting up media_player
17-02-26 10:26:34 INFO (MainThread) [homeassistant.components.media_player] Setting up media_player.cast
17-02-26 10:26:42 INFO (Thread-3) [pychromecast] Querying device status

Should have added mine is a manual install

Can the cutomize section be more clear?

I have a separate file cutomize.yaml (i guess a lot do like that otherwise configuration.yaml would be too long)
where i have customized only the entitites like below. And now tih all the globs, e.t.c - quite lost. And the online conversion tool requires different yaml spacing. So converting will need a whole lot of work to do.

    friendly_name: Movement kitchen

or the z-wave

    friendly_name: Kitchen Main
    assumed_state: false
1 Like

0.39 broke my Limitless LED setup.
Checked out the Configuration Option and it is heading in the right direction esp the simple buttons to restart the core etc.
The config checker is awesome and saves going online to the YAML Validator.
After playing around with the views things got funky so had to downgrade back to 0.38.3 to get the lights working again.


Cannot confirm. All the components installed nicely. It was home-assistant.log (well at least since 0.3x)

Also have a question on groups.yaml

Already have this file set up with all the groups? Does it mean i have to start from a scratch using the web config and empty groups.yaml?

Yea I don’t know what I was thinking. for some reason I thought it was homeassistant.log. Guess I was wrong.

Having a bit of trouble understanding the customize and group changes. I see that there is a util to convert customize but I don’t know if I get how group works.

It mentions creating an empty groups.yaml, but does it then populate it for you or what?

I haven’t done any changes in my customize configuration since i don’t use domain and global customizations. And I have activated the “config:” since I’m not going to use the gui for configuring anything.

I did the upgrade in my AIO with fab upgrade_homeassistant as usual and now my HA is totally dead. I don’t get anything in the log even with the logger in debug mode.

Going back to 0.38.3 everythig works fine.

Any help would be appreciated?

Assuming you meant “haven’t” here.

Looks like I’m going to go offline and image the SD card and then copy over configs before even thinking of upgrading. First time I ever considered not doing an upgrade on release…

Yes I meant haven’t :slight_smile:

Yes backing up and upgrading then sounds like a good idea with this release. There are some things in the release notes that I don’t really get :confused:

1 Like

This is in the breaking changes, may help:

Limitlessled support for Bridge v6 and RGBWW bulbs require users to specify version and port

Add me to the list of people confused. I even made a comment about this in the blog release post about the confusion in the forums.

I’m having a hard time getting ZWave configuration working again after the upgrade.

I changed my zwave config to:

zwave: !include devices/zwave.yaml


  usb_path: /dev/ttyUSB0
  config_path: /home/apsoares/python-openzwave/openzwave/config
  polling_interval: 5000
    polling_intensity: 1

Running hass --script check_config, I get:

Testing configuration at /home/apsoares/.homeassistant
17-02-26 16:11:44 ERROR (MainThread) [homeassistant.bootstrap] Invalid config for [zwave]: [usb_path] is an invalid option for [zwave]. Check: zwave->zwave->device_config->usb_path. (See /home/apsoares/.homeassistant/configuration.yaml, line 65). Please check the docs at https://home-assistant.io/components/zwave/
Failed config
    device_config: [source /home/apsoares/.homeassistant/devices/zwave.yaml:1]
      config_path: /home/apsoares/python-openzwave/openzwave/config
      polling_interval: 5000
      sensor.aeotec_home_energy_meter_power_2_4: [source /home/apsoares/.homeassistant/devices/zwave.yaml:5]
        polling_intensity: 1
      usb_path: /dev/ttyUSB0

Successful config (partial)

Running it without usb_path/config_path in the zwave config file results in:

17-02-26 16:05:29 ERROR (MainThread) [homeassistant.bootstrap] Error during setup of component zwave
Traceback (most recent call last):
  File "/usr/local/lib/python3.5/dist-packages/openzwave-0.3.0-py3.5.egg/openzwave/option.py", line 72, in __init__
raise ZWaveException(u"Can't find device %s : %s" % (device, traceback.format_exception(*sys.exc_info())))
openzwave.object.ZWaveException: "Zwave Generic Exception : Can't find device /zwaveusbstick : ['NoneType\\n']"

Can someone point me to any direction in order to get zwave working again?

Thanks in advance.

I am pretty sure you don’t need the devices_config line at the start of your zwave.yaml.

I just went straight into the USB path in mine.

Then it is something that everyone that use zwave needs to add and not just the ones that are using the new config: It’s not so clear in the release notes

Edit: I just saw that you wrote don’t :slight_smile: So no need to add that

Well, I’m an idiot. :blush:

I read the release notes, somehow added device_config into configuration.yaml and included my zwave configuration file. Afterwards I tried a lot of small variations on top of that.

Of course, now is working as expected.

Thanks for the help.

So from what I understand the “device_config” part of zwave is only needed if you are turning config on. I wasn’t using any customizing in zwave yet but I added it in there just to be safe. I got it to work by having a separate line, the usb_path, etc, does not go in the zwave_device_config.yaml. The below component is working for me right now though I haven’t tried actually using the config panel yet.

  usb_path: /dev/ttyUSB0
  config_path: /srv/hass/src/open-zwave-control-panel/config
  polling_interval: 60000
  device_config: !include zwave_device_config.yaml

edit: oh sounds like you got it figured out.

What you posted; is that in your configuration.yaml?

And what is the content of your zwave_device_config.yaml?