0.39 update - Help with Getting My Limitless LED Working Again

Hi Al

Initially, I did not notice that 0.39 had a breaking change for the LimitlessLED component, so of course after upgrading my “Easybulb” version of the LimitlessLED’s it did not work. The forums set me straight on that breaking change and I went about fixing the groups and views so that the new config panel displayed everything just right.

I can not seem to get the HA LimitlessLED configuration entry correct so here is what I have.

I have tried the bridge version number 4 and 5. These display the light sliders but they do not work
Substituting 6 for the bridge number, the sliders are no longer displayed at all.
I can confirm the IP address of the bridge remains unchanged using Fing for Android phones.

Any ideas would be appreciated.

Also thought I might post a picture of the groups and views as they display in the new configuration panel so that those yet to change over to 0.39 can see it.


Same Here,

Have been trying to specify ‘version’ and ‘port’ as per breaking changes for this release but no luck so far. I did go into the browser config settings of the device and changed the default username and password from “admin” and “admin” so it is slightly more secure.

I report back if i have any joy.



Hi, if you are using bridge version 5, use port 8899. If you are using bridge version 6, use port 5987. If LimitlessLED was working prior to 0.39, you have bridge version 5.

Or like me a version 4… google on bridge versions and look at the images of the bridge that eventually told me I had version 4 and port 8899

Before 39 it worked without specifying version and port

Yes, 0.39 made version 6 the default. That was a breaking change for those of us on version 5 or below.

I made a PR to the docs to clarify that you need 8899 for bridges < 6 (https://github.com/home-assistant/home-assistant.github.io/pull/2171). I also suggest to automatically set the port default regarding to the selected version.

Another problem with 0.39.{0,1,2} is, that transitions do not work on version <6. This is due to a bug in python-limitlessled. The fix is already released and HA should bump the requirement to the fixed version in the next release.

Thanks happyleaves.

Using your recommendation of port 8899 on a V5 bridge got them working again.
Much appreciated.


Glad that you got it working RAWB.

I unfortunately am still battling - I have tried to set the bridge version and port to variations of 1-5 and 5987/8899 respectively to no avail.

is there any information out there to identify the version of the bridge that you have.

pointing my browser to the ip address of the bridge reveals that it is on port 8899 (under the other settings tab). (user/pass = admin/admin)

are there any ways to identify the bridge version form the browser config page?



Hi Phil

I am still confused myself as to what version bridge I have.
Logging into the admin console of the bridge (then switching to English) I can see the string
“Software Version V10.04a-JCY-1”

I am thinking that might indicate a V4 Bridge.

LimitlessLED have some dev tools on their site at http://www.limitlessled.com/dev/
More specifically they have a config utility that discovers the V5 and V6 bridges so that might help to ID the bridge.
Mine is probably V4 as the utility does not find any bridges.

Lastly here is a snip of the configuration.yaml that is working on my RPI system.


OK looks like I solved my problem.

I own the RGBWW bulbs but my bridge only supports the white and the RGBW bulbs.

In my config I specified that the bulbs were RGBWW after the update but they were not supported by the v5 bridge (at least that is my understanding)
I changed them to RGBW bulbs with (v5 on port 8899) and and all is back to normal.

Thanks for the help!

1 Like

Yes its a little bit confusing, the
RGBW is for RGBW or RGBWW less
RGBWW is for the RGB CW/WW lights, aka them that you can set color temp on as well as rgb.

Thanks for the clarification - is guess I messed up in that I tried to change multiple things at once.