0.54.0 broke Vera component?


I updated to 0.54.0 and all my sensors connected to my Vera Edge now show “Unknown”. The sensors are working on the Vera. I don’t get any error message in the log.

Other devices like switches that is connected to the Vera is shown properly and can be controlled through HASS as usual.

I have tried removing the line for Vera in configuration.yaml, restrating and then adding it back. This did not change anything.


The problem is already fixed on the dev-branch


1 Like

Oh, great!

I’ve just started using HASS and Rpi. Could you tell me how to upgrade to dev version? I’m using the All-In-One-Installer, so usually I just follow the instructions in https://home-assistant.io/docs/installation/raspberry-pi-all-in-one/#upgrading .

I guess I need to download the dev version instead but what should I type instead of pip3 install --upgrade homeassistant ?

What you need to do is run the command

pip3 install --upgrade git+git://github.com/home-assistant/home-assistant.git@dev

However, as stated on Common tasks - Operating System - Home Assistant (at the very bottom) it contains more fixes than just this one and may be unstable.

No, that didn’t work with HASS installed using the All-In-One-Installer. I get some error:

Traceback (most recent call last):
  File "/srv/homeassistant/homeassistant_venv/lib/python3.4/site-packages/pip/basecommand.py", line 215, in main
    status = self.run(options, args)
  File "/srv/homeassistant/homeassistant_venv/lib/python3.4/site-packages/pip/commands/install.py", line 289, in run
    delete=build_delete) as build_dir:
  File "/srv/homeassistant/homeassistant_venv/lib/python3.4/site-packages/pip/utils/build.py", line 22, in __init__
    name = os.path.realpath(tempfile.mkdtemp(prefix="pip-build-"))
  File "/srv/homeassistant/homeassistant_venv/lib/python3.4/tempfile.py", line 426, in mkdtemp
    dir = gettempdir()
  File "/srv/homeassistant/homeassistant_venv/lib/python3.4/tempfile.py", line 370, in gettempdir
    tempdir = _get_default_tempdir()
  File "/srv/homeassistant/homeassistant_venv/lib/python3.4/tempfile.py", line 312, in _get_default_tempdir
FileNotFoundError: [Errno 2] No usable temporary directory found in ['/tmp', '/var/tmp', '/usr/tmp', '/home/pi']

I assume this error with Vera will be fixed in the next stable version so I’ll just wait.

you could just pull the changed vera sensor py file from the repo, and replace that in your install for a quick fix.

Ahh, sorry I don’t use the AIO installer

I tried to search for vera.py on my Rpi3 using WinSCP but couldn’t find anything, so I can’t update the file. I assume it’s because I use the AIO version of HASS.

I love HASS but it’s frustrating when new versions breaks functionality that previously worked properly.

find / -name "vera.py"

you want the sensor one, which on my machine is here:

I guess you won’t have to wait too long now for a new HA release anyway if you’re struggling!