0.74: Tuya, Cloudflare DNS, Push Camera and Users UI


#41

No the iOS dev is aware and has fixed this issue for the next release. Not just you.


#42

Hi,

I finally had some time for an upgrade from 0.56.2. But, after the normal procedure with “sudo pip3 install --upgrade homeassistant” I still have 0.56.2? The installation logs shows 0.74 though… What has changes? This is running on a RPI 3 with a lot of other things (MQTT, Node-Red, Unifi) so I guess that a HASS.io installation is not my best choice?

/Joakim


#43

Python 56.2 was the last version to support Python 3.4. we now require Python 3.5.3 minimally


#44

Yes, I’ve seen that. My RPI is running Stretch already. So, I assume that Python 3.5.3 is used when I start hass. I’ve tried uninstalling and reinstalling. But it does not touch my “old” installation. Only the parts in /usr/local/bin/?


#45

what about tuya sensors (door sensors, pir motion sensors…)?
will these work?


#46

Need help!!!
On 0.74 I cannot use. If put this I cannot access my ha frontend at all. So I remove all below.

homeassistant:
  auth_providers:
   - type: homeassistant
   # - type: legacy_api_password
auth:

After update to 0.74.1 . I cannot access my ha frontend. Whether put or don’t put.

homeassistant:
  auth_providers:
   - type: homeassistant
   # - type: legacy_api_password

#47

Ha load normally if I dont put auth_providers but I cannot access ha frontend

If I put auth_providers, Ha load normally but again I cannot access ha frontend. Log file show auth api enabled and legacy_api_password support enabled. Please use access_token instead api_password, although you can still use legacy api_password.

I cannot access ha at all. On my iphone show

This on computer


#48

The only change may cause this is auth component auto load since 0.74.1 no matter whether you enabled new auth or not.

So, it looks like auth component cause some error to bring down the frontend component.

Can you post your full configuration.yaml? Any third party of custom components are using?


#49

This happen to me since 0.74 so I didn’t use auth_providers and auth:

Upgrade 0.74.1 will automatically load auth:

My latest custom_component is alexa as media player. I have quite many custom_component mostly are broadlink.


#50

Please try to disable all custom component.


#51

I have disable custom_component. Still the same I cannot access ha frontend at all.

2018-07-24 22:22:44 WARNING (MainThread) [homeassistant.components.http] Experimental auth api enabled and legacy_api_password support enabled. Please use access_token instead api_password, although you can still use legacy api_password


#52

It just a warning about legacy api_password, nothing special. Again, can you post your full configuration?


#53
homeassistant:
  auth_providers:
   - type: homeassistant
  name: !secret homeassistant_name
  latitude: !secret home_latitude
  longitude: !secret home_longitude
  elevation: !secret home_elevation
  unit_system: metric
  time_zone: Asia/Bangkok  
  customize: !include config/customize.yaml
  customize_glob: !include config/customize_glob.yaml
  customize_domain:
    automation:
      initial_state: 'on'
  packages: !include_dir_named config/packages/
  whitelist_external_dirs:   
    - !secret whitelist_1
    - !secret whitelist_2
    - !secret whitelist_3

Whether I put with or without - type: legacy_api_password. I cannot access ha frontend. Ha is running as I see the db go bigger and status is active

homeassistant:
  auth_providers:
   - type: homeassistant
   - type: legacy_api_password

#54

Can you post your frontend and http config?


#55
frontend:
  javascript_version: latest   
  extra_html_url:
    - /local/custom_ui/state-card-custom-ui.html
    - /local/custom_ui/state-card-tiles.html
    - /local/custom_ui/state-card-script-custom-text.html
    - /local/custom_ui/custom-weather-card.html
    - /local/custom_ui/state-card-mini-media-player.html
    - /local/custom_ui/state-card-iframe.html

  extra_html_url_es5:
    - /local/custom_ui/state-card-custom-ui-es5.html
    - /local/custom_ui/state-card-tiles_es5.html
    - /local/custom_ui/state-card-script-custom-text-es5.html
    - /local/custom_ui/custom-weather-card.html
    - /local/custom_ui/state-card-mini-media-player_es5.html

  themes: !include_dir_merge_named themes/

http:
  base_url: !secret base_url  
  api_password: !secret api_password
#  server_port: !secret server_port
  ssl_certificate: !secret ssl_certificate
  ssl_key: !secret ssl_key
  cors_allowed_origins:
   - !secret cors_1
   - !secret cors_2
#  use_x_forwarded_for: true
#  trusted_proxies:
#    - 127.0.0.1
#    - ::1
  trusted_networks:
   - !secret trusted_1
  ip_ban_enabled: true
  login_attempts_threshold: 3

My base_url is include port inside so I # on server_port
The trusted_networks: is my local network 192.168.1.0/24


#56

Did you see any ip_ban warning/error in error log? I am wondering if you have been banned. Could you try to disable ip_ban_enabled and login_attempts_threshold.

There is a todo for me to honor trusted_networks config, basically if you enabled new auth, the trusted_networks will not work now. So if you have some other integration from your local network, it will trigger the failed login now, and may be caused yourself be banned.


#57

There is no ip_ban. Thank you for your recommend. I will disable the ip_ban_enabled and login_attempts_threshold also trust_networks and inform you.


#58

Same result. I also clear all browsing history and cached from google chrome.

in log show
2018-07-24 23:05:08 WARNING (MainThread) [homeassistant.components.http] Experimental auth api enabled. Please use access_token instead api_password.

2


#59

Can you ping me at #homeassistant chat channel? https://www.home-assistant.io/join-chat/
I don’t want to hijack this thread anymore.


#60

What is your name in discord channel?