0.85: ESPHome, Plum Lightpad, OpenSenseMap


#101

unable to upgrade to 0.85.1
docker pull kept pointing to 0.85.0 and saying my image is upto date


#102

Apparently the “latest” version tag wasn’t updated to 0.85.1 yet. You can always reference an specific version, and get back to latest when they update it:

That’s what I run to get the latest version:
docker pull homeassistant/home-assistant:0.85.1


#103

Anyone else having issues with the envisalink component?

I’m getting an “Invalid Config” error. It worked before and I don’t see any breaking changes on that component.


#104

Thanks. That worked.


#105

Did you use HassOS?
You may have an old configuration file somewhere?
Regarding systemmonitor, since_last_boot has been removed.


#106

No, the HA seems to be stuck somewhere that is not running. Cleared by browser cache etc, but still doesn’t work. I unplug the cable and plug it back in everything runs back to 0.85.0. Anyway I can do manual updates or seeing the log via ssh?


#107

I am having issues with Xiaomi, mitemp_bt devices. Keep saying timeout etc. Doesn’t happen back in 0.84.6


#108

They got rid of since_last_boot


#109

All you z-wave people with issues, have you logged or seen if your issue has been raised on GitHub? i saw one raised but it could be different for you. https://github.com/home-assistant/home-assistant/issues/19903
So i would suggest adding your problem if it’s the same or create a new one.

The information found in this link fixed my issue. Thank you all for the help. I am now happily running version 0.85.1 of HomeAssistant on my Raspberry Pi. My only issue now is that I cannot figure out how to use a scene to turn off Light_A and turn on Light_B and Light_C (but only if the sun is below the horizon). Any guidance will be greatly appreciated.


#110

Installed version 0.85.1 but HomeKit controller did not start, because not all requirement were met. Also manual installation of new HomeKit controller resulted in error.

Jan 15 00:10:10 osmc hass[1544]: 2019-01-15 00:10:10 ERROR (Thread-22) [homeassistant.util.package] Unable to install package homekit==0.12.0: Command “python setup.py egg_info” failed with error code 1 in /tmp/pip-build-khisfyck/homekit/
Jan 15 00:10:10 osmc hass[1544]: 2019-01-15 00:10:10 ERROR (MainThread) [homeassistant.requirements] Not initializing homekit_controller because could not install requirement homekit==0.12.0
Jan 15 00:10:10 osmc hass[1544]: 2019-01-15 00:10:10 ERROR (MainThread) [homeassistant.setup] Setup failed for homekit_controller: Could not install all requirements.
J

Back to version 0.84.6


#111

Please post an issue on github so it gets fixed.


#112

Not here. Open a new thread please.


#113

Yes sir. Sorry about that. I appreciate all of the help that occurs in this blog/forum.


#114

Update error massgae:

python-jose-cryptodome 1.3.2 has requirement pycryptodome<3.4.0,>=3.3.1, but you’ll have pycryptodome 3.4.11 which is incompatible.
locationsharinglib 3.0.9 has requirement requests~=2.20.1, but you’ll have requests 2.21.0 which is incompatible.

How can I fix it?
Please help me.


#115

Andy, I think this one has been removed between 83 and now. Check the component documentation.


#116

I just updated to 0.85.1 and it seems that all internet connections are not working any longer (internal connection via MQTT and local network is possible):

2019-01-16 01:03:58 ERROR (SyncWorker_10) [homeassistant.components.weather.openweathermap] Exception when calling OWM web API to update data
2019-01-16 01:04:36 ERROR (SyncWorker_8) [homeassistant.components.sensor.rest] Error fetching data: <PreparedRequest [GET]> from http: … failed with HTTPConnectionPool(host=’…’, port=80): Max retries exceeded with url: /wetter.htm (Caused by NewConnectionError(’<urllib3.connection.HTTPConnection object at 0x6e3e53f0>: Failed to establish a new connection: [Errno -3] Try again’,))
2019-01-16 01:05:27 ERROR (SyncWorker_16) [homeassistant.components.sensor.dwd_weather_warnings] Unable to fetch data from DWD-Weather-Warnings

I use Hassio 142 on raspberry pi and HA 0.85.1. I neither changed anything in my config nor can I find a breaking change, which could cause this strange behaviour. Has anybody an idea??


#117

Maybe the hassio container DNS is not working. I saw some thread talking about it


#118

Updated from 0.84.6 to 0.85.1 and HA stopped working. Gets stuck on startup with
„WARNING (MainThread) [homeassistant.setup] Setup of sensor is taking over 10 seconds.“

Downgraded to 0.84.6 again to keep HA working.


#119

Yeah that’ll help diagnosing the problem you are having.


#120

thats common on startup for as long as I’ve had HA (over a year) so nothing serious to worry about… you probably just needed to wait longer