0.86.2 (hass.io) removed all sensors. No idea how to include them again now in lovelace

I am using hass.io since some month and was quite susseful reading my SMA inverter information (6 different energy sensors) with the help of the component sensor.
Moreover i am using Grafana on base of influxdb to finally display the information. This is all documented nicely and I got used to the working style here .
I do not need any other sensors currently.

Now after upgrading to 0.86.2 my sma infomation is not available on lovelace UI. I have an empty UI and basically no idea how to include the component sensor here. I have done what is described in the sensor documentation (e.g. edit configuration.yaml) but this does not have any effect on lovelace as I understand.

Acctually I am very interested in lovelace UI - even to replace my inflaxdb-grafana setup but I have no clue where to start.

  • Is there a difference between hass.io versions and other implementations wrt lovelace? I do not have the impression that the transformtion to lovelace as standard UI is supported here.
  • How would I include a component sensor in lovelace (0.86.2 on hass.io)? Is configuration.yaml still used? Where would I configure my sensor data (e.g. IP@ , usr, …) if not in configuration.yaml
  • Is the lovelace yaml file mandatory or optional.

Sorry if those questions are too basic. But I do not find them answred anywhere after 2 hours searching here. Thanks for any advice.

I think, the sensor.sma is broken?? All other sensors work, but the sma says invalid config after upgrade form 0.85.1 to 0.86.3

sensor sma:
  - platform: sma
    password: secret
        key: "6400_00262200"
        unit: Wh

2019-01-27 21:28:07 ERROR (MainThread) [homeassistant.config] Invalid config for [sensor.sma]: current_power does not exist. Got OrderedDict([(‘platform’, ‘sma’), (‘host’, ‘’), (‘password’, ‘secret’), (‘sensors’, OrderedDict([(‘current_consumption’, None), (‘current_power’, None), (‘total_yield’, None), (‘daily_yield’, None)])), (‘custom’, OrderedDict([(‘daily_yield’, OrderedDict([(‘key’, ‘6400_00262200’), (‘unit’, ‘Wh’)]))]))]). (See ?, line ?). Please check the docs at https://home-assistant.io/components/sensor.sma/

regards Richard

Try removing sma after sensor…so it should look like:

  - platform: sma
    password: secret

…sure, But all SMA sensor are lost after upgrade to 0.86.3
The same error code comes with my implementation. I am happy I am not the only one…
After fallback to 0.85 sensors work again.

:wink: Jens

I upgraded now to 0.86.4. Same problem. All SMA sensors were gone with cause: error in configuration file.
After removal and new configurartion of the sma sensors from configuration.yaml some sensors could be brought back again.
For some reason I get failed a SMA sensor config once I try to enable ‘current_power’ which was working earlier.