0.96: Notion, updated sidebar, advanced mode

Hi! Thanks for the solution for the SSL-issue. Now my ASUSWRT works fine again. BUT after that the Telldus Live stopped working. I removed the integration and the telldus.conf-file and restarted HASS. I added the component Telldus Live, but I only get an error message:

In Swedish:
Okänt fel när genererar en url för att auktorisera.

In English:
Unknown error when generating an url for authorization.

After this error I only get a search windows with no new avaible integrations.

This is in the log:

Failed to retrieve authorization URL: HTTPSConnectionPool(host=‘api.telldus.com’, port=443): Max retries exceeded with url: /oauth/requestToken (Caused by SSLError(SSLError(“bad handshake: Error([(‘SSL routines’, ‘ssl_choose_client_version’, ‘unsupported protocol’)])”)))

Any idea of what to do about this?

The configuration of individual monitored conditions has been removed so that now all conditions are available per module by default. https://github.com/home-assistant/home-assistant/pull/24944

0.96.1 fixes ecobee

1 Like

Great news

Having the exact same problem looks like a bug.

I have to agree. I personally don’t like it either and would like an option to toggle between new and old.

1 Like

Hello everyone!

Great release, update was flawless (read the breaking changes and backed up before doing it :slight_smile:).

The only problem is that my notifications are now different from my current theme (dark red). Any ideas on how to change that?


Did you figure out what your issue with your custom component was? I have two custom components that aren’t anything special, just existing components with subtle tweaks – but neither of them will load. I’m at a loss.

Yes, 0.96’s version of MQTT HVAC has changed, this time due to the advent of Climate 1.0.

It’s what I suspected because this is about the fourth time it has changed (since last November) and rendered my custom component inoperative. It’s why I wrote “… and here we go again” because I revised it merely a month ago.

To be clear, I’m not complaining. My custom component is an enhanced version of MQTT HVAC. Therefore whenever a new version of Home Assistant contains a modified MQTT HVAC, my custom component fails to work (because underlying code has changed). The MQTT integration has evolved a great deal since I made a custom version of it (Nov 2018) and for the better. However, it does make my job (keeping up with MQTT HVAC’s changes) a bit of a chore.

Fortunately, I believe my need to create a custom version of MQTT HVAC may have come to an end. ‘Climate 1.0’ addresses many things including one of my pain-points and that’s the lack of a distinction between a thermostat’s operating state (is it currently heating, cooling, or idle) and its operation mode (auto, heat, cool, off, etc). ‘Climate 1.0’ now handles the two separately thereby providing improved visibility into the HVAC system’s operation (e.g. the thermostat’s history chart can now show when the system is actively heating and cooling as opposed to when it is simply in heat or cool mode).

Having said all that, we’re not quite there yet. This is the first release of ‘Climate 1.0’ so there are a few bugs to fix. In time they will be addressed. For example, I reported that MQTT HVAC still doesn’t display a correct history chart, only to discover a few hours later that a PR is already in the pipeline to fix the issue. :+1:

There are other enhancements I’ve made but, instead of continuing with a custom component, I plan to revert to the stock version and use automations (already created and tested) to fill in for the missing functionality. As a result, I’ll no longer need to maintain a custom MQTT HVAC component and future upgrades will be easier.

In your case, you’ll have to review the new component’s code and see how it differs from your component. FWIW, last time I discovered that the new code used relative imports as opposed to absolute imports. This subtle little change was sufficient to derail my component:


I just upgraded to 96.1 from 95.4 and it seems to have broken my media players.
So I read through the breaking changes a few times now and I also searched on the forum (might be that I have overlooked something), but I get this error after the update:

Setup failed for media_player: No setup function defined.

And on the Notification tab I get this:

The following components and platforms could not be set up:

Please check your config.

I just don’t get what it is I suddenly miss.

At the moment I don’t see any of my Media Players. Strangely enough under Integration, I do see the Google Cast units, but it tells me that the devices are unreachable.

Anyone seen this as well?

My custom components have nothing to do with Climate. I have an onkyo media_player component that just adjusts the volume steps from 80 to 200, and a MQTT binary_sensor that just doesn’t log warning when it receives a topic that doesn’t match its own.

These both worked in 0.95.4, and I can’t figure out what I need to change. I’ve read the breaking changes, and nothing caught my eye. Have I just missed something?


Yeah, I checked all that stuff too. I even added the empty services.yaml file to my custom components. I was looking for something above and behond the obvious. I thought it was something to do with all custom components.

BUT. It turns out it was a false alarm.

I just upgraded to 0.96.2, and now everything works. Go figure.

Maybe this is the same I experience with my Media Players.
Looking forward to see the 96.2 on my hassio panel then :blush:

I had a media_player.py file placed in an old library of the samsung custom component. That one messed with the configuration and after I removed it - everything seems back to normal.

Nope, not in 0.96.

None of the documented changes for 0.96.1 or 0.96.2 appears to have anything to do with media_players.

Consider yourself lucky the problem disappeared (and hopefully not just temporarily).

Upgraded to 0.96.1 but nmap_tracker error is still there.

I get it during “Check Home Assistant configuration” addon on Hassio, not during “hassio ha check” command from terminal or from Configuration validation under Settings->General

@woody4165, does the nmap tracker function properly with 0.96.1, even though the Hassio configuration check add-on gives an error? Thanks.

after upgrading to version 0.96, the climate section has changed.
could someone convert these automations according to the new syntax in Home Assistant?

  - service: climate.set_away_mode
      entity_id: climate.netatmo_cucina
      away_mode: 'on'
  - service: climate.set_away_mode
      entity_id: climate.netatmo_cucina_2
      away_mode: 'off'
  - data:
      away_mode: 'off'
      entity_id: climate.netatmo_cucina_2
    service: climate.set_away_mode
  - data:
      entity_id: climate.netatmo_salone_2
      temperature: 20
    service: climate.set_temperature

All of the climate-related services are listed in the documentation.

set_away_mode no longer exists. It has been replaced by set_preset_mode and you have to indicate which preset_mode you want to set.

The services are also listed here:

1 Like

looks like the problem is known

Error while setting up platform enphase_envoy 0.96.0

need to install requests-async