0.99: Withings, Device Automations, launch Home Assistant Cast from Python

Hello everyone. I’m experiencing an issue with this version (Hass.io on Raspberry Pi 3+). I can’t acces the manage entities page for Alexa anymore (/config/cloud/alexa). Worked just fine before the update.
Does anyone know how to fix this?

Are you casting onto a television? I’m not sure why it says

Cannot read property ‘config’ of null

Are you doing anything special?

Have you cleared your browser cache and logged back in?

1 Like

Thank you! That did the trick :slight_smile:

1 Like

I can cast via lovelace but calling the new service doesn’t work.


          - type: entities
            title: Chromecast Control
            show_header_toggle: false
              - type: cast
                name: System
                view: "home_assistant"
                hide_if_unavailable: false
              - type: cast
                name: Weather
                view: "weather"
                hide_if_unavailable: false

Doesn’t work.
I get an error on the screen:

EDIT: I specified a port as I’m not using 443 and it works ONLY if I specify 0 as the path and then it displays the states page. Any other view says unable to display path x

Tried with a TV and with this config:

type: custom:button-card
entity: binary_sensor.remote_ui

So…is that a no? :man_shrugging:

After update 0.99.2 i dont have any history from my entity’s anyone else have this issue?

I still can’t update to docker to 99.2.
Keeps updating to 99.1

Did you manage to get yours to 99.2?

Look here for an explanation.


Port 4865 is only the default for a pi-hole created as a hass.io addon. @kanga_who’s solution is only valid for those.

Adding port 4865 will break the connection to pi-hole’s running on a raspberry pi or outside of hass.io

Even with the port it seems that does not work.

Do you have a workaround, please?


just pull 0.99.2 manually.

1 Like

I see someone else has noted that on the Github issue.

I find it odd that this change has been made with the documents not corrected updated prior to the change and that the change fragments the way the PiHole now operates.

I don’t understand the ins and outs of these things, but as an end user it’s a source of frustration.


Have you tried it like this?

  host: localhost:4865

Hi guys, I’ve gone looking for this to help with a lawn fertilizer card I’m making and can’t find any details. Is the documentation still in development?

Yes, I had.

Set SSL to false, apparently that solves the issue.

It did:

  host: !secret pi-hole_host
  verify_ssl: false