0.99: Withings, Device Automations, launch Home Assistant Cast from Python

with the cast.show_lovelace_view service, I can’t get anything to display, it shows the connected screen on my home hub. for the view_path, I have a view with url path defined as downstairs, so I use that for the “view_path” option, yet nothing shows. I can manually cast from the frontend fine.

Hi team,
Thank you for that update!
I’m having trouble integrating withings.

-> Conf is valid
-> Home assistant restarted
-> New device discovered: Withings
X issue 1: clicking the configure button next to withings in the integration page doesn’t do anything with the following error log:

2019-09-19 10:17:38 ERROR (MainThread) [frontend.js.latest.201909181] https://mydomain/frontend_latest/chunk.43dcfc6e5b8d18714299.js:1007:164 Uncaught TypeError: Cannot read property 'item' of undefined

I then tried the following workaround for that 1st issue:
-> “+” button / “Withings” works
-> Select user profile and submit ::: Redirected to Withings website
-> Select user profile “Allow this app”
-> Redirected to my home assistant “This step requires you to visit an external website to be completed” / Open website ::: Redirected to Withings website
-> Select user profile “Allow this app”
X issue 2: " 500 Internal Server Error, Server got itself in trouble"
(also tried changing the domain part of the url with local name and got the same result)

Checking the logs, here is what I can find:

oauthlib.oauth2.rfc6749.errors.MissingTokenError: (missing_token) Missing access token parameter.

the failing url looks like this: https://abc.ui.nabu.casa/api/withings/authorize?flow_id=def&profile=ghi&code=jkl&state=mno

Did I miss anything ?
Thank you all

I still manage devices this way, I also use Unifi equipment.

  hide_if_away: false
  mac: DC:4F:22:5B:XX:XX
  name: sonoff-5891
  track: false

  hide_if_away: false
  mac: 84:0D:8E:63:XX:XX
  name: ESP 63F006
  track: true

I’m having exactly the same issue, except I have a local setup instead of nabu.casa.

I’ve worked out the solution, the documents on this need to be updated - they do not specific the need to list the IP and Port of the Pi Hole host.

Using this as per the docs did not work;


Using this as per the docs did not work;

  host: IP_ADDRESS

Using this as per the PR page did not work;

  host: pi.hole

Working config in configuration.yaml is;


My Hass.io install is on the machine at I will submit a PR to update the docs with this.

Seeing this error with 0.99 that I have not seen before: TypeError: e.model is undefined

Also HA has discovered a certificate expiry integration though I am unable to configure it. Clicking on ‘Configure’ does nothing.

I do have this existing sensor config:

- platform: cert_expiry
  host: my_domain_redacted.duckdns.org

Though this sensor is now unavailable in my Lovelace front end.

I could not find any sensor in the dev tools states page similar to my previous sensor.

Is it possible to have two pihole instances?

According to this Github issue, it looks like the re-factoring of the component has broken the ability to have multiple instances running.

Tom - it’s now an integration. Try removing from config, restarting then adding integration, restarting and adjusting the lovelace card.

I will but the docs do say it should be possible manually:

has the name of it changed? check states?

This update killed my trådfri connection. Can’t even reconnect it under integrations. I’m 100% sure that the code is correct. Screenshot_20190919_074337|230x500

Nope. Was working before the update.

After removing the config and restarting the discovery has gone away. Grrr…

manually add it + bottom right. Certificate.

can we update to this by clicking update in the system manager tool:?

I did. All good.

Same here with Tradfri configured in configuration.yaml
possibly fixed by this

No logs = no issue

Is it possible under 0.98> to customize the device trackers anymore for the UniFi integration? I had pictures customized for the families phones but I can’t see where to do this under the 0.99 integration as the devices are no longer in known_devices.yaml. Am I missing something?

On a 2nd note, is there an easy way to remove all of my IoT devices that are appearing in the UniFi integrations page now (albeit unavailable)?

@cben0ist some of us couldn’t get Withing to woork in the beta version of 0.99

I have updated the issue ticket, even though it was closed down.